aboutsummaryrefslogtreecommitdiff
path: root/www/firefox
diff options
context:
space:
mode:
authorFlorian Smeets <flo@FreeBSD.org>2012-10-28 17:03:28 +0000
committerFlorian Smeets <flo@FreeBSD.org>2012-10-28 17:03:28 +0000
commit912a7b12e4e109551df76471e1e446eb4d5a8b37 (patch)
treebfdd16290ece91145dc3df1818b888573eface15 /www/firefox
parent8866b5a40d11eb5d621edb42874296c743c1bcec (diff)
downloadports-912a7b12e4e109551df76471e1e446eb4d5a8b37.tar.gz
ports-912a7b12e4e109551df76471e1e446eb4d5a8b37.zip
Notes
Diffstat (limited to 'www/firefox')
-rw-r--r--www/firefox/Makefile7
-rw-r--r--www/firefox/Makefile.options1
-rw-r--r--www/firefox/distinfo4
-rw-r--r--www/firefox/files/patch-bug71380213
-rw-r--r--www/firefox/files/patch-bug799441116
-rw-r--r--www/firefox/files/patch-z-bug76244570
6 files changed, 190 insertions, 21 deletions
diff --git a/www/firefox/Makefile b/www/firefox/Makefile
index 85d63cc62195..df5dbb6ab087 100644
--- a/www/firefox/Makefile
+++ b/www/firefox/Makefile
@@ -6,8 +6,7 @@
#
PORTNAME= firefox
-DISTVERSION= 16.0.1
-PORTREVISION= 1
+DISTVERSION= 16.0.2
PORTEPOCH= 1
CATEGORIES= www ipv6
MASTER_SITES= ${MASTER_SITE_MOZILLA}
@@ -84,10 +83,6 @@ MOZ_MK_OPTIONS+=PROFILE_GEN_SCRIPT="${PYTHON_CMD} \
@MOZ_OBJDIR@/_profile/pgo/profileserver.py"
.endif
-.if ${ARCH} == amd64 || ${ARCH} == i386
-BUILD_DEPENDS+= yasm:${PORTSDIR}/devel/yasm
-.endif
-
pre-extract:
.if ${PORT_OPTIONS:MPGO}
@${ECHO} "*****************************************************************"
diff --git a/www/firefox/Makefile.options b/www/firefox/Makefile.options
index 20937f22314d..cfe88fa602b4 100644
--- a/www/firefox/Makefile.options
+++ b/www/firefox/Makefile.options
@@ -16,3 +16,4 @@ GNOMEUI_DESC?= libgnomeui support module
LIBPROXY_DESC?= Proxy support via libproxy
LIGHTNING_DESC?= Calendar extension
LOGGING_DESC?= Additional log messages
+QT4_DESC?= Qt GUI (EXPERIMENTAL, bug 521582)
diff --git a/www/firefox/distinfo b/www/firefox/distinfo
index 9dc711fa954c..b3a39f169f69 100644
--- a/www/firefox/distinfo
+++ b/www/firefox/distinfo
@@ -1,2 +1,2 @@
-SHA256 (firefox-16.0.1.source.tar.bz2) = 57ed98109718aacfdeda2af11b0179916e462ede8ac6576ee99c7d066b162fe7
-SIZE (firefox-16.0.1.source.tar.bz2) = 89452319
+SHA256 (firefox-16.0.2.source.tar.bz2) = cefe00d1440eefbe2534b119558d8ebc4adb55eb2fdaaff1ce101b9e70d02820
+SIZE (firefox-16.0.2.source.tar.bz2) = 89452077
diff --git a/www/firefox/files/patch-bug713802 b/www/firefox/files/patch-bug713802
index 956ed1cc8e97..7d3cc4dad110 100644
--- a/www/firefox/files/patch-bug713802
+++ b/www/firefox/files/patch-bug713802
@@ -25,19 +25,6 @@ index 40ab494..eae5645 100755
# MOZ_APP_DISPLAYNAME will be set by branding/configure.sh
# Changing MOZ_*BRANDING_DIRECTORY requires a clobber to ensure correct results,
# because branding dependencies are broken.
---- browser/installer/package-manifest.in~
-+++ browser/installer/package-manifest.in
-@@ -679,6 +679,10 @@ bin/libfreebl_32int64_3.so
-
- ; [Extensions]
- ;
-+#ifdef MOZ_ENABLE_GIO
-+bin/components/@DLL_PREFIX@nkgio@DLL_SUFFIX@
-+#endif
-+
- #ifdef MOZ_ENABLE_GNOMEVFS
- bin/components/@DLL_PREFIX@nkgnomevfs@DLL_SUFFIX@
- #endif
diff --git configure.in configure.in
index 87a9391..2118651 100644
--- configure.in
diff --git a/www/firefox/files/patch-bug799441 b/www/firefox/files/patch-bug799441
new file mode 100644
index 000000000000..98bc613ba60d
--- /dev/null
+++ b/www/firefox/files/patch-bug799441
@@ -0,0 +1,116 @@
+commit b9accdd
+Author: Mike Hommey <mh+mozilla@glandium.org>
+Date: Thu Oct 18 14:47:10 2012 +0200
+
+ Bug 799441 - Build GIO module in libxul. r=ted
+---
+ configure.in | 6 ++++++
+ extensions/gio/Makefile.in | 14 +++-----------
+ toolkit/library/Makefile.in | 5 +++++
+ toolkit/library/nsStaticXULComponents.cpp | 7 +++++++
+ toolkit/toolkit-tiers.mk | 4 ++++
+ 5 files changed, 25 insertions(+), 11 deletions(-)
+
+diff --git configure.in configure.in
+index a9fb5f1..37e6db8 100644
+--- configure.in
++++ configure.in
+@@ -6086,6 +6086,12 @@ if test -n "$LIBXUL_SDK_DIR" -a `echo "$MOZ_EXTENSIONS" | grep -c gio` -ne 0; th
+ MOZ_EXTENSIONS=`echo $MOZ_EXTENSIONS | sed -e 's|gio||'`
+ fi
+
++if test `echo "$MOZ_EXTENSIONS" | grep -c gio` -ne 0; then
++ MOZ_GIO_COMPONENT=1
++ MOZ_EXTENSIONS=`echo $MOZ_EXTENSIONS | sed -e 's|gio||'`
++fi
++AC_SUBST(MOZ_GIO_COMPONENT)
++
+ if test -z "$MOZ_JSDEBUGGER" -a `echo "$MOZ_EXTENSIONS" | grep -c venkman` -ne 0; then
+ AC_MSG_WARN([Cannot build venkman without JavaScript debug library. Removing venkman from MOZ_EXTENSIONS.])
+ MOZ_EXTENSIONS=`echo $MOZ_EXTENSIONS | sed -e 's|venkman||'`
+diff --git extensions/gio/Makefile.in extensions/gio/Makefile.in
+index ccf2846..79112a8 100644
+--- extensions/gio/Makefile.in
++++ extensions/gio/Makefile.in
+@@ -14,6 +14,9 @@ MODULE = nkgio
+ LIBRARY_NAME = nkgio
+ SHORT_LIBNAME = nkgio
+ IS_COMPONENT = 1
++EXPORT_LIBRARY = 1
++MODULE_NAME = nsGIOModule
++LIBXUL_LIBRARY = 1
+
+ CPPSRCS = \
+ nsGIOProtocolHandler.cpp \
+@@ -21,15 +24,4 @@ CPPSRCS = \
+
+ LOCAL_INCLUDES = $(MOZ_GIO_CFLAGS)
+
+-EXTRA_DSO_LDOPTS = \
+- $(XPCOM_GLUE_LDOPTS) \
+- $(MOZ_COMPONENT_LIBS) \
+- $(MOZ_GIO_LIBS) \
+- $(NULL)
+-
+-# make sure this component is never statically linked into the main
+-# application. this is necessary since we don't want to force users
+-# to install gio in order to use the rest of mozilla ;-)
+-FORCE_SHARED_LIB= 1
+-
+ include $(topsrcdir)/config/rules.mk
+diff --git toolkit/library/Makefile.in toolkit/library/Makefile.in
+index 7f9046e..6499758 100644
+--- toolkit/library/Makefile.in
++++ toolkit/library/Makefile.in
+@@ -333,6 +333,11 @@ COMPONENT_LIBS += gkdebug
+ endif
+ endif
+
++ifdef MOZ_GIO_COMPONENT
++DEFINES += -DMOZ_GIO_COMPONENT
++COMPONENT_LIBS += nkgio
++endif
++
+ ifdef MOZ_APP_COMPONENT_LIBS
+ COMPONENT_LIBS += $(MOZ_APP_COMPONENT_LIBS)
+ endif
+diff --git toolkit/library/nsStaticXULComponents.cpp toolkit/library/nsStaticXULComponents.cpp
+index e1d90f2..85b21a2 100644
+--- toolkit/library/nsStaticXULComponents.cpp
++++ toolkit/library/nsStaticXULComponents.cpp
+@@ -164,6 +164,12 @@
+ #define PROFILER_MODULE
+ #endif
+
++#if defined(MOZ_GIO_COMPONENT)
++#define GIO_MODULE MODULE(nsGIOModule)
++#else
++#define GIO_MODULE
++#endif
++
+ #define XUL_MODULES \
+ MODULE(nsUConvModule) \
+ MODULE(nsI18nModule) \
+@@ -220,6 +226,7 @@
+ MODULE(nsTelemetryModule) \
+ MODULE(jsinspector) \
+ MODULE(jsdebugger) \
++ GIO_MODULE \
+ /* end of list */
+
+ #define MODULE(_name) \
+diff --git toolkit/toolkit-tiers.mk toolkit/toolkit-tiers.mk
+index e87d7af..4b16d23 100644
+--- toolkit/toolkit-tiers.mk
++++ toolkit/toolkit-tiers.mk
+@@ -252,6 +252,10 @@ tier_platform_dirs += js/ductwork/debugger
+
+ tier_platform_dirs += other-licenses/snappy
+
++ifdef MOZ_GIO_COMPONENT
++tier_platform_dirs += extensions/gio
++endif
++
+ ifdef APP_LIBXUL_STATICDIRS
+ # Applications can cheat and ask for code to be
+ # built before libxul so libxul can be linked against it.
diff --git a/www/firefox/files/patch-z-bug762445 b/www/firefox/files/patch-z-bug762445
new file mode 100644
index 000000000000..fd42fea9cab2
--- /dev/null
+++ b/www/firefox/files/patch-z-bug762445
@@ -0,0 +1,70 @@
+commit b44dc8e
+Author: Jan Beich <jbeich@tormail.org>
+Date: Fri Oct 12 18:49:59 2012 +0000
+
+ Bug 762445 - Add jemalloc3 glue for heap-committed, heap-dirty in about:memory.
+---
+ memory/build/mozjemalloc_compat.c | 34 ++++++++++++++++++++++++++++------
+ 1 file changed, 28 insertions(+), 6 deletions(-)
+
+diff --git memory/build/mozjemalloc_compat.c memory/build/mozjemalloc_compat.c
+index 94ad96e..7adfef5 100644
+--- memory/build/mozjemalloc_compat.c
++++ memory/build/mozjemalloc_compat.c
+@@ -11,15 +11,50 @@
+ #define wrap(a) je_ ## a
+ #endif
+
+-extern MOZ_IMPORT_API(int)
++/*
++ * CTL_* macros are from memory/jemalloc/src/src/stats.c with changes:
++ * - drop `t' argument to avoid redundancy in calculating type size
++ * - require `i' argument for arena number explicitly
++ */
++
++#define CTL_GET(n, v) do { \
++ size_t sz = sizeof(v); \
++ wrap(mallctl)(n, &v, &sz, NULL, 0); \
++} while (0)
++
++#define CTL_I_GET(n, v, i) do { \
++ size_t mib[6]; \
++ size_t miblen = sizeof(mib) / sizeof(mib[0]); \
++ size_t sz = sizeof(v); \
++ wrap(mallctlnametomib)(n, mib, &miblen); \
++ mib[2] = i; \
++ wrap(mallctlbymib)(mib, miblen, &v, &sz, NULL, 0); \
++} while (0)
++
++MOZ_IMPORT_API(int)
+ wrap(mallctl)(const char*, void*, size_t*, void*, size_t);
++MOZ_IMPORT_API(int)
++wrap(mallctlnametomib)(const char *name, size_t *mibp, size_t *miblenp);
++MOZ_IMPORT_API(int)
++wrap(mallctlbymib)(const size_t *mib, size_t miblen, void *oldp, size_t *oldlenp, void *newp, size_t newlen);
+
+ MOZ_EXPORT_API(void)
+ jemalloc_stats(jemalloc_stats_t *stats)
+ {
+- size_t size = sizeof(stats->mapped);
+- wrap(mallctl)("stats.mapped", &stats->mapped, &size, NULL, 0);
+- wrap(mallctl)("stats.allocated", &stats->allocated, &size, NULL, 0);
+- stats->committed = -1;
+- stats->dirty = -1;
++ unsigned narenas;
++ size_t active, allocated, mapped, page, pdirty;
++
++ CTL_GET("arenas.narenas", narenas);
++ CTL_GET("arenas.page", page);
++ CTL_GET("stats.active", active);
++ CTL_GET("stats.allocated", allocated);
++ CTL_GET("stats.mapped", mapped);
++
++ /* get the summation for all arenas, i == narenas */
++ CTL_I_GET("stats.arenas.0.pdirty", pdirty, narenas);
++
++ stats->allocated = allocated;
++ stats->mapped = mapped;
++ stats->dirty = pdirty * page;
++ stats->committed = active + stats->dirty;
+ }