aboutsummaryrefslogtreecommitdiff
path: root/www/flashplugin-mozilla
diff options
context:
space:
mode:
authorJeremy Messenger <mezz@FreeBSD.org>2009-01-10 02:45:46 +0000
committerJeremy Messenger <mezz@FreeBSD.org>2009-01-10 02:45:46 +0000
commit15b6544926b07a98710eeb765baf03e3fc9a195c (patch)
tree35103cf986d2ed2295c97768e62afcc47dfed877 /www/flashplugin-mozilla
parent23fcf54562404bb41380488c8318ac0e3ce15efc (diff)
downloadports-15b6544926b07a98710eeb765baf03e3fc9a195c.tar.gz
ports-15b6544926b07a98710eeb765baf03e3fc9a195c.zip
Notes
Diffstat (limited to 'www/flashplugin-mozilla')
-rw-r--r--www/flashplugin-mozilla/Makefile14
-rw-r--r--www/flashplugin-mozilla/pkg-plist4
2 files changed, 11 insertions, 7 deletions
diff --git a/www/flashplugin-mozilla/Makefile b/www/flashplugin-mozilla/Makefile
index df7a5797042d..68900dad02b4 100644
--- a/www/flashplugin-mozilla/Makefile
+++ b/www/flashplugin-mozilla/Makefile
@@ -7,7 +7,7 @@
PORTNAME?= flashplugin-mozilla
PORTVERSION= 0.4.13
-PORTREVISION= 2
+PORTREVISION= 3
CATEGORIES= www
MASTER_SITES= SF/gplflash
DISTNAME= gplflash-${PORTVERSION}
@@ -21,14 +21,18 @@ WRKSRC= ${WRKDIR}/${DISTNAME}/plugin
USE_XORG= xt x11 xext
USE_BZIP2= yes
-PLUGIN_DIR= lib/browser_plugins
-PLIST_SUB+= PLUGIN_DIR=${PLUGIN_DIR}
GNU_CONFIGURE= yes
-CONFIGURE_ARGS+= --with-plugin-dir="${PREFIX}/${PLUGIN_DIR}"
+CONFIGURE_ARGS+= --with-plugin-dir="${WEBPLUGINS_DIR}"
CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
LDFLAGS="-L${LOCALBASE}/lib -lXt"
CONFIGURE_WRKSRC= ${WRKDIR}/${DISTNAME}
+USE_WEBPLUGINS= native
+WEBPLUGINS_FILES=libnpflash.so
+
+.include <bsd.port.pre.mk>
+.include "${PORTSDIR}/www/firefox/Makefile.webplugins"
+
post-patch:
@${REINPLACE_CMD} -e "s,-L../lib/.libs,-L${LOCALBASE}/lib," \
-e "s/libnpflash.so.0.0.0/libnpflash.so.0/" \
@@ -36,4 +40,4 @@ post-patch:
@${REINPLACE_CMD} -e 's|stdint.h|inttypes.h|' ${WRKSRC}/npapi.h
@${REINPLACE_CMD} -e 's|echo aout|echo elf|' ${CONFIGURE_WRKSRC}/configure ${CONFIGURE_WRKSRC}/ltconfig
-.include <bsd.port.mk>
+.include <bsd.port.post.mk>
diff --git a/www/flashplugin-mozilla/pkg-plist b/www/flashplugin-mozilla/pkg-plist
index 58310e6b2b4d..50cb4b09a08b 100644
--- a/www/flashplugin-mozilla/pkg-plist
+++ b/www/flashplugin-mozilla/pkg-plist
@@ -1,2 +1,2 @@
-%%PLUGIN_DIR%%/libnpflash.so
-@dirrmtry %%PLUGIN_DIR%%
+%%WEBPLUGINS_DIR%%/libnpflash.so
+@dirrmtry %%WEBPLUGINS_DIR%%