aboutsummaryrefslogtreecommitdiff
path: root/www/flashplugin-mozilla
diff options
context:
space:
mode:
authorPatrick Li <pat@FreeBSD.org>2002-11-23 02:51:53 +0000
committerPatrick Li <pat@FreeBSD.org>2002-11-23 02:51:53 +0000
commit10b7fd2bf370dbc69e7ff836beb6c1c531290d7a (patch)
treeb0301393785c6b8c422c30503c9c51ac17f41b7d /www/flashplugin-mozilla
parent8471dae31d1f8124b219ffd2b2ce1f6082f8e023 (diff)
downloadports-10b7fd2bf370dbc69e7ff836beb6c1c531290d7a.tar.gz
ports-10b7fd2bf370dbc69e7ff836beb6c1c531290d7a.zip
Notes
Diffstat (limited to 'www/flashplugin-mozilla')
-rw-r--r--www/flashplugin-mozilla/Makefile2
-rw-r--r--www/flashplugin-mozilla/files/patch-plugin.c20
2 files changed, 21 insertions, 1 deletions
diff --git a/www/flashplugin-mozilla/Makefile b/www/flashplugin-mozilla/Makefile
index 30807e342ca8..996b093f7c3c 100644
--- a/www/flashplugin-mozilla/Makefile
+++ b/www/flashplugin-mozilla/Makefile
@@ -7,7 +7,7 @@
PORTNAME?= flashplugin-mozilla
PORTVERSION= 0.4.10
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= www
MASTER_SITES= http://www.swift-tools.com/Flash/
DISTNAME= flash-${PORTVERSION}
diff --git a/www/flashplugin-mozilla/files/patch-plugin.c b/www/flashplugin-mozilla/files/patch-plugin.c
new file mode 100644
index 000000000000..a77f089cc89e
--- /dev/null
+++ b/www/flashplugin-mozilla/files/patch-plugin.c
@@ -0,0 +1,20 @@
+*** plugin.c.old Mon Jun 12 10:24:09 2000
+--- plugin.c Mon Sep 30 00:48:40 2002
+***************
+*** 193,198 ****
+--- 193,207 ----
+ XSync(This->dpy,False);
+ XFreePixmap(This->dpy, This->canvas);
+ shmdt(This->segInfo.shmaddr);
++ #ifndef linux
++ {
++ struct shmid_ds buf;
++
++ if (shmctl(This->segInfo.shmid, IPC_RMID, &buf) < 0) {
++ perror("shmctl");
++ }
++ }
++ #endif
+
+ FlashClose(This->fh);
+ This->fh = 0;