aboutsummaryrefslogtreecommitdiff
path: root/www/flat-frog/Makefile
diff options
context:
space:
mode:
authorCheng-Lung Sung <clsung@FreeBSD.org>2006-10-10 11:52:45 +0000
committerCheng-Lung Sung <clsung@FreeBSD.org>2006-10-10 11:52:45 +0000
commite88cd1a01c11b8df2aa2aa581e7f4154062ea4dc (patch)
tree94b77c56ca2a82249c9cad47c7545e4c7fe2ee0a /www/flat-frog/Makefile
parentcd3c86f522e61fab356d5c555b9a6ad9b72768c6 (diff)
downloadports-e88cd1a01c11b8df2aa2aa581e7f4154062ea4dc.tar.gz
ports-e88cd1a01c11b8df2aa2aa581e7f4154062ea4dc.zip
Notes
Diffstat (limited to 'www/flat-frog/Makefile')
-rw-r--r--www/flat-frog/Makefile33
1 files changed, 33 insertions, 0 deletions
diff --git a/www/flat-frog/Makefile b/www/flat-frog/Makefile
new file mode 100644
index 000000000000..cda5da3881f2
--- /dev/null
+++ b/www/flat-frog/Makefile
@@ -0,0 +1,33 @@
+# New ports collection makefile for: flat-frog
+# Date created: 2006-10-10
+# Whom: Gea-Suan Lin <gslin@gslin.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= flat-frog
+PORTVERSION= 2.2.13
+CATEGORIES= www
+MASTER_SITES= SOURCEFORGE
+MASTER_SITE_SUBDIR= flatfrog
+
+MAINTAINER= gslin@gslin.org
+COMMENT= A templating engine working in php
+
+NO_BUILD= yes
+USE_PHP= yes
+USE_ZIP= yes
+
+do-install:
+ ${MKDIR} ${DATADIR} ${DATADIR}/plugins
+ ${INSTALL_DATA} ${WRKSRC}/src/class.* ${DATADIR}
+ ${INSTALL_DATA} ${WRKSRC}/src/plugins/* ${DATADIR}/plugins
+ ${MKDIR} ${EXAMPLESDIR} ${EXAMPLESDIR}/templates
+ ${INSTALL_DATA} ${WRKSRC}/demo/test.* ${EXAMPLESDIR}
+ ${INSTALL_DATA} ${WRKSRC}/demo/templates/* ${EXAMPLESDIR}/templates
+.if !defined(NOPORTDOCS)
+ ${MKDIR} ${DOCSDIR}
+ ${INSTALL_DATA} ${WRKSRC}/docs/* ${DOCSDIR}
+.endif
+
+.include <bsd.port.mk>