aboutsummaryrefslogtreecommitdiff
path: root/www/flickcurl
diff options
context:
space:
mode:
authorVanilla I. Shu <vanilla@FreeBSD.org>2007-08-06 13:37:37 +0000
committerVanilla I. Shu <vanilla@FreeBSD.org>2007-08-06 13:37:37 +0000
commitbe5fcf69750ab06819d3816a1ef659abb7606520 (patch)
tree245fce08f690baa84ab5eb3e6e0ea1b7a972a59b /www/flickcurl
parenta6a495595badfeeb7434c9ce5dafee308950bd7c (diff)
downloadports-be5fcf69750ab06819d3816a1ef659abb7606520.tar.gz
ports-be5fcf69750ab06819d3816a1ef659abb7606520.zip
Notes
Diffstat (limited to 'www/flickcurl')
-rw-r--r--www/flickcurl/Makefile22
-rw-r--r--www/flickcurl/distinfo3
-rw-r--r--www/flickcurl/files/patch-flickcurl_internal.h13
-rw-r--r--www/flickcurl/pkg-descr9
-rw-r--r--www/flickcurl/pkg-plist9
5 files changed, 56 insertions, 0 deletions
diff --git a/www/flickcurl/Makefile b/www/flickcurl/Makefile
new file mode 100644
index 000000000000..10af20692e32
--- /dev/null
+++ b/www/flickcurl/Makefile
@@ -0,0 +1,22 @@
+# New ports collection makefile for: flickcurl
+# Date created: 2007-07-27
+# Whom: vanilla@
+#
+# $FreeBSD$
+#
+
+PORTNAME= flickcurl
+PORTVERSION= 0.11
+CATEGORIES= www
+MASTER_SITES= http://download.dajobe.org/flickcurl/
+
+MAINTAINER= vanilla@FreeBSD.org
+COMMENT= C library for the Flickr API
+
+LIB_DEPENDS= curl.4:${PORTSDIR}/ftp/curl
+
+USE_AUTOTOOLS= libtool:15
+USE_GNOME= gnomehack gnometarget ltverhack libxml2 pkgconfig
+USE_LDCONFIG= yes
+
+.include <bsd.port.mk>
diff --git a/www/flickcurl/distinfo b/www/flickcurl/distinfo
new file mode 100644
index 000000000000..d7a3daf4270b
--- /dev/null
+++ b/www/flickcurl/distinfo
@@ -0,0 +1,3 @@
+MD5 (flickcurl-0.11.tar.gz) = eea351e4d35e8d1c63b124cd8ee257ba
+SHA256 (flickcurl-0.11.tar.gz) = 0afd5dccd757b5c06e1a6ee46da16fa4e2f5e9e65ed7698376349210186ef9af
+SIZE (flickcurl-0.11.tar.gz) = 421285
diff --git a/www/flickcurl/files/patch-flickcurl_internal.h b/www/flickcurl/files/patch-flickcurl_internal.h
new file mode 100644
index 000000000000..5b24d09c31eb
--- /dev/null
+++ b/www/flickcurl/files/patch-flickcurl_internal.h
@@ -0,0 +1,13 @@
+--- flickcurl_internal.h.orig Sun Aug 5 12:24:18 2007
++++ flickcurl_internal.h Sun Aug 5 12:24:26 2007
+@@ -22,10 +22,6 @@
+
+ #include <libxml/tree.h>
+ #include <libxml/xpath.h>
+-#include <libxslt/xslt.h>
+-#include <libxslt/transform.h>
+-#include <libxslt/xsltutils.h>
+-
+
+ #include <curl/curl.h>
+ #include <curl/types.h>
diff --git a/www/flickcurl/pkg-descr b/www/flickcurl/pkg-descr
new file mode 100644
index 000000000000..f4799ca447d9
--- /dev/null
+++ b/www/flickcurl/pkg-descr
@@ -0,0 +1,9 @@
+Flickcurl is a C library for the Flickr API, handling creating the requests,
+signing, token management, calling the API, marshalling request parameters
+and decoding responses. It uses libcurl to call the REST web service and
+libxml2 to manipulate the XML responses. The current version supports part of
+the API (see Flickcurl API coverage) primarily the functions for reading
+photo, people and tags description, uploading photos, changing tags and
+comments.
+
+WWW: http://librdf.org/flickcurl/
diff --git a/www/flickcurl/pkg-plist b/www/flickcurl/pkg-plist
new file mode 100644
index 000000000000..39f07ebc6e1d
--- /dev/null
+++ b/www/flickcurl/pkg-plist
@@ -0,0 +1,9 @@
+bin/flickcurl
+bin/flickcurl-config
+bin/flickrdf
+include/flickcurl.h
+lib/libflickcurl.a
+lib/libflickcurl.la
+lib/libflickcurl.so
+lib/libflickcurl.so.0
+libdata/pkgconfig/flickcurl.pc