aboutsummaryrefslogtreecommitdiff
path: root/www/flock
diff options
context:
space:
mode:
authorJoe Marcus Clarke <marcus@FreeBSD.org>2005-09-21 23:49:19 +0000
committerJoe Marcus Clarke <marcus@FreeBSD.org>2005-09-21 23:49:19 +0000
commit44036f0330db37bf8d71dd5b78bbb85980141c56 (patch)
tree4b8845a2591cb8722d79480d4deffaf4412531c7 /www/flock
parent9caf96ed77a4118d25885835e832b0231d077c26 (diff)
downloadports-44036f0330db37bf8d71dd5b78bbb85980141c56.tar.gz
ports-44036f0330db37bf8d71dd5b78bbb85980141c56.zip
Notes
Diffstat (limited to 'www/flock')
-rw-r--r--www/flock/Makefile21
-rw-r--r--www/flock/distinfo6
-rw-r--r--www/flock/files/patch-CAN-2005-2871104
-rw-r--r--www/flock/files/patch-browser_app_mozilla.in14
4 files changed, 20 insertions, 125 deletions
diff --git a/www/flock/Makefile b/www/flock/Makefile
index 6dc7d041ef76..a8b4efb9ba0e 100644
--- a/www/flock/Makefile
+++ b/www/flock/Makefile
@@ -7,8 +7,7 @@
#
PORTNAME= firefox
-PORTVERSION= 1.0.6
-PORTREVISION= 5
+PORTVERSION= 1.0.7
PORTEPOCH= 1
CATEGORIES= www
MASTER_SITES= ${MASTER_SITE_MOZILLA}
@@ -79,19 +78,19 @@ OPTIONS= DEBUG "Build a debugging image" off \
OPTIMIZED_CFLAGS "Enable some additional optimizations" off \
XFT "Enable support for anti-aliased fonts" on \
SMB "Enable smb:// URI support using gnomevfs" off \
- NEWTAB "Open external links in a new tab" on \
- CJK "Enable CJK font family support" off
+ NEWTAB "Open external links in a new tab" on
+# CJK "Enable CJK font family support" off
.include <bsd.port.pre.mk>
# Enable CJK Font Familyname support
-.if defined(WITH_CJK)
-PATCH_SITES+= http://bbs.ilc.edu.tw/~chinsan/ \
- http://bsdchat.com/dist/firefly-cjk-patchset/ \
- ftp://local-distfiles.freebsd.org.cn/pub/china-ports/hamigua/
-PATCHFILES+= mozilla-1.7.10-cjkfamilyname-20050731.patch.gz
-PATCH_DIST_STRIP+= -p1
-.endif
+#.if defined(WITH_CJK)
+#PATCH_SITES+= http://bbs.ilc.edu.tw/~chinsan/ \
+# http://bsdchat.com/dist/firefly-cjk-patchset/ \
+# ftp://local-distfiles.freebsd.org.cn/pub/china-ports/hamigua/
+#PATCHFILES+= mozilla-1.7.10-cjkfamilyname-20050731.patch.gz
+#PATCH_DIST_STRIP+= -p1
+#.endif
.if defined(WITH_DEBUG)
WITH_LOGGING= yes
diff --git a/www/flock/distinfo b/www/flock/distinfo
index 249f095bc045..d58d05b54c4f 100644
--- a/www/flock/distinfo
+++ b/www/flock/distinfo
@@ -1,4 +1,2 @@
-MD5 (firefox-1.0.6-source.tar.bz2) = 7b4c1d10d478dcb4c52fbbe3e41745d9
-SIZE (firefox-1.0.6-source.tar.bz2) = 32782840
-MD5 (mozilla-1.7.10-cjkfamilyname-20050731.patch.gz) = f449044d3128950ea6b87cdd5ebe4840
-SIZE (mozilla-1.7.10-cjkfamilyname-20050731.patch.gz) = 1928
+MD5 (firefox-1.0.7-source.tar.bz2) = 5704a8c36de84b408e069afb0c5bc1df
+SIZE (firefox-1.0.7-source.tar.bz2) = 32793876
diff --git a/www/flock/files/patch-CAN-2005-2871 b/www/flock/files/patch-CAN-2005-2871
deleted file mode 100644
index eca8515adbdb..000000000000
--- a/www/flock/files/patch-CAN-2005-2871
+++ /dev/null
@@ -1,104 +0,0 @@
-Index: netwerk/base/src/nsStandardURL.cpp
-===================================================================
-RCS file: /cvs/mozilla/netwerk/base/src/nsStandardURL.cpp,v
-retrieving revision 1.60.16.2
-diff -p -u -1 -2 -r1.60.16.2 nsStandardURL.cpp
---- netwerk/base/src/nsStandardURL.cpp 17 Feb 2005 23:40:53 -0000 1.60.16.2
-+++ netwerk/base/src/nsStandardURL.cpp 9 Sep 2005 16:34:46 -0000
-@@ -403,24 +403,25 @@ nsStandardURL::AppendToBuf(char *buf, PR
- // 4- update url segment positions and lengths
- nsresult
- nsStandardURL::BuildNormalizedSpec(const char *spec)
- {
- // Assumptions: all member URLSegments must be relative the |spec| argument
- // passed to this function.
-
- // buffers for holding escaped url segments (these will remain empty unless
- // escaping is required).
- nsCAutoString encUsername;
- nsCAutoString encPassword;
- nsCAutoString encHost;
-+ PRBool useEncHost;
- nsCAutoString encDirectory;
- nsCAutoString encBasename;
- nsCAutoString encExtension;
- nsCAutoString encParam;
- nsCAutoString encQuery;
- nsCAutoString encRef;
-
- //
- // escape each URL segment, if necessary, and calculate approximate normalized
- // spec length.
- //
- PRInt32 approxLen = 3; // includes room for "://"
-@@ -440,34 +441,36 @@ nsStandardURL::BuildNormalizedSpec(const
- approxLen += encoder.EncodeSegmentCount(spec, mBasename, esc_FileBaseName, encBasename);
- approxLen += encoder.EncodeSegmentCount(spec, mExtension, esc_FileExtension, encExtension);
- approxLen += encoder.EncodeSegmentCount(spec, mParam, esc_Param, encParam);
- approxLen += encoder.EncodeSegmentCount(spec, mQuery, esc_Query, encQuery);
- approxLen += encoder.EncodeSegmentCount(spec, mRef, esc_Ref, encRef);
- }
-
- // do not escape the hostname, if IPv6 address literal, mHost will
- // already point to a [ ] delimited IPv6 address literal.
- // However, perform Unicode normalization on it, as IDN does.
- mHostEncoding = eEncoding_ASCII;
- if (mHost.mLen > 0) {
-+ useEncHost = PR_FALSE;
- const nsCSubstring& tempHost =
- Substring(spec + mHost.mPos, spec + mHost.mPos + mHost.mLen);
- if (IsASCII(tempHost))
- approxLen += mHost.mLen;
- else {
- mHostEncoding = eEncoding_UTF8;
- if (gIDNService &&
-- NS_SUCCEEDED(gIDNService->Normalize(tempHost, encHost)))
-+ NS_SUCCEEDED(gIDNService->Normalize(tempHost, encHost))) {
- approxLen += encHost.Length();
-- else {
-+ useEncHost = PR_TRUE;
-+ } else {
- encHost.Truncate();
- approxLen += mHost.mLen;
- }
- }
- }
-
- //
- // generate the normalized URL string
- //
- mSpec.SetLength(approxLen + 32);
- char *buf;
- mSpec.BeginWriting(buf);
-@@ -483,25 +486,30 @@ nsStandardURL::BuildNormalizedSpec(const
- mAuthority.mPos = i;
-
- // append authority
- if (mUsername.mLen > 0) {
- i = AppendSegmentToBuf(buf, i, spec, mUsername, &encUsername);
- if (mPassword.mLen >= 0) {
- buf[i++] = ':';
- i = AppendSegmentToBuf(buf, i, spec, mPassword, &encPassword);
- }
- buf[i++] = '@';
- }
- if (mHost.mLen > 0) {
-- i = AppendSegmentToBuf(buf, i, spec, mHost, &encHost);
-+ if (useEncHost) {
-+ mHost.mPos = i;
-+ mHost.mLen = encHost.Length();
-+ i = AppendToBuf(buf, i, encHost.get(), mHost.mLen);
-+ } else
-+ i = AppendSegmentToBuf(buf, i, spec, mHost);
- net_ToLowerCase(buf + mHost.mPos, mHost.mLen);
- if (mPort != -1 && mPort != mDefaultPort) {
- nsCAutoString portbuf;
- portbuf.AppendInt(mPort);
- buf[i++] = ':';
- i = AppendToBuf(buf, i, portbuf.get(), portbuf.Length());
- }
- }
-
- // record authority length
- mAuthority.mLen = i - mAuthority.mPos;
-
diff --git a/www/flock/files/patch-browser_app_mozilla.in b/www/flock/files/patch-browser_app_mozilla.in
index 6389a61b5e8b..414bc881e492 100644
--- a/www/flock/files/patch-browser_app_mozilla.in
+++ b/www/flock/files/patch-browser_app_mozilla.in
@@ -123,7 +123,7 @@
# Use run-mozilla.sh in the current dir if it exists
# If not, then start resolving symlinks until we find run-mozilla.sh
-@@ -82,149 +114,221 @@
+@@ -82,151 +114,221 @@
curdir=`dirname "$progname"`
progbase=`basename "$progname"`
run_moz="$curdir/run-mozilla.sh"
@@ -183,7 +183,6 @@
-fi
-
-script_args=""
--moreargs=""
-debugging=0
-MOZILLA_BIN="${progbase}-bin"
-
@@ -385,7 +384,8 @@
-# Default action - no running instance or _USE_EXIST (${_USE_EXIST}) ! -eq 1
-########################################################################### Main
--while [ $# -gt 0 ]
+-pass_arg_count=0
+-while [ $# -gt $pass_arg_count ]
-do
- case "$1" in
- -p | --pure | -pure)
@@ -402,8 +402,11 @@
- shift 2
- ;;
- *)
-- moreargs="$moreargs \"$1\""
-- shift 1
+- # Move the unrecognized argument to the end of the list.
+- arg="$1"
+- shift
+- set -- "$@" "$arg"
+- pass_arg_count=`expr $pass_arg_count + 1`
- ;;
- esac
-done
@@ -449,7 +452,6 @@
+fi
-export MRE_HOME
--eval "set -- $moreargs"
+# real invocation
+eval "set -- ${moreargs}"