aboutsummaryrefslogtreecommitdiff
path: root/www/fluxbb/Makefile
diff options
context:
space:
mode:
authorMartin Wilke <miwi@FreeBSD.org>2013-03-05 17:07:43 +0000
committerMartin Wilke <miwi@FreeBSD.org>2013-03-05 17:07:43 +0000
commitfb3520254ab73be0aad04c3a63b781750cf26b5b (patch)
tree268d74f9d8738f78b0c895672044611aa6343387 /www/fluxbb/Makefile
parent4706739618b79681811e5b336a54032908638160 (diff)
Notes
Diffstat (limited to 'www/fluxbb/Makefile')
-rw-r--r--www/fluxbb/Makefile15
1 files changed, 6 insertions, 9 deletions
diff --git a/www/fluxbb/Makefile b/www/fluxbb/Makefile
index 780da7d602f5..ad0d66a4c7d1 100644
--- a/www/fluxbb/Makefile
+++ b/www/fluxbb/Makefile
@@ -17,21 +17,18 @@ SUB_FILES= pkg-message
NO_BUILD= yes
USE_PHP= yes
-OPTIONS= MYSQL "Add support for a MySQL database server" On \
- PGSQL "Add support for a PostgreSQL database server" Off \
- SQLITE "Add support for a SQLite database server" Off
+OPTIONS_DEFINE= MYSQL PGSQL SQLITE
+OPTIONS_DEFAULT= MYSQL
-.include <bsd.port.pre.mk>
-
-.if defined(WITH_MYSQL)
+.if ${PORT_OPTIONS:MMYSQL}
USE_PHP+= mysql
.endif
-.if defined(WITH_PGSQL)
+.if ${PORT_OPTIONS:MPGSQL}
USE_PHP+= pgsql
.endif
-.if defined(WITH_SQLITE)
+.if ${PORT_OPTIONS:MSQLITE}
USE_PHP+= sqlite
.endif
@@ -47,4 +44,4 @@ do-install:
post-install:
@${CAT} ${PKGMESSAGE}
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>