aboutsummaryrefslogtreecommitdiff
path: root/www/fnord
diff options
context:
space:
mode:
authorFlorent Thoumie <flz@FreeBSD.org>2005-10-14 11:24:43 +0000
committerFlorent Thoumie <flz@FreeBSD.org>2005-10-14 11:24:43 +0000
commit91765c484f2ad3d0f3416990738941f63c7a1b38 (patch)
tree8d1bac3128ab1a316fe99a10687b6ddfd7238e61 /www/fnord
parent51a47cf4fac30b3ad909fb04cad6b5a0bdc1d09a (diff)
downloadports-91765c484f2ad3d0f3416990738941f63c7a1b38.tar.gz
ports-91765c484f2ad3d0f3416990738941f63c7a1b38.zip
- Update to 1.10.
- Dependancies on daemontools and ucspi-tcp are now optional. - Installs an inetd wrapper. - Some bits of a howto in a newly created pkg-message.
Notes
Notes: svn path=/head/; revision=145362
Diffstat (limited to 'www/fnord')
-rw-r--r--www/fnord/Makefile26
-rw-r--r--www/fnord/distinfo4
-rw-r--r--www/fnord/files/fnord.inetd.in8
-rw-r--r--www/fnord/files/pkg-message.in26
4 files changed, 56 insertions, 8 deletions
diff --git a/www/fnord/Makefile b/www/fnord/Makefile
index 811340274b80..781867b9d399 100644
--- a/www/fnord/Makefile
+++ b/www/fnord/Makefile
@@ -6,30 +6,40 @@
#
PORTNAME= fnord
-PORTVERSION= 1.9
+PORTVERSION= 1.10
CATEGORIES= www
MASTER_SITES= http://www.fefe.de/fnord/
MAINTAINER= flz@FreeBSD.org
COMMENT= Small and fast webserver with CGI-capability
-RUN_DEPENDS= setuidgid:${PORTSDIR}/sysutils/daemontools \
- tcpserver:${PORTSDIR}/sysutils/ucspi-tcp
-
USE_GMAKE= yes
USE_BZIP2= yes
USE_REINPLACE= yes
PLIST_FILES= bin/fnord \
- bin/fnord-conf
+ bin/fnord-conf \
+ bin/fnord.inetd
+
+SUB_FILES= pkg-message fnord.inetd
-OPTIONS= CGI "Enable CGI support" on \
+OPTIONS= DAEMONTOOLS "Use DJB's daemontools" off \
+ TCPSERVER "Use DJB's tcpserver" off \
+ CGI "Enable CGI support" on \
DIR_LIST "Enable directory listing" on \
SYSTEM_SYMLINK_DEREF "Enable system symlink (needs DIR_LIST)" off \
OLD_STYLE_REDIRECT "Enable old style redirection" off
.include <bsd.port.pre.mk>
+.if defined(WITH_DAEMONTOOLS)
+RUN_DEPENDS= setuidgid:${PORTSDIR}/sysutils/daemontools
+.endif
+
+.if defined(WITH_TCPSERVER)
+RUN_DEPENDS= tcpserver:${PORTSDIR}/sysutils/ucspi-tcp
+.endif
+
.if !defined(WITHOUT_CGI)
SED_SCRIPT+= -e "s|^// \(\#define CGI\).*|\1|"
.endif
@@ -75,5 +85,9 @@ do-build:
do-install:
${INSTALL_PROGRAM} ${WRKSRC}/fnord ${PREFIX}/bin/
${INSTALL_SCRIPT} ${WRKSRC}/fnord-conf ${PREFIX}/bin/
+ ${INSTALL_SCRIPT} ${WRKDIR}/fnord.inetd ${PREFIX}/bin/
+
+post-install:
+ @${CAT} ${PKGMESSAGE}
.include <bsd.port.post.mk>
diff --git a/www/fnord/distinfo b/www/fnord/distinfo
index 28cc300739d1..6757cb14b3fe 100644
--- a/www/fnord/distinfo
+++ b/www/fnord/distinfo
@@ -1,2 +1,2 @@
-MD5 (fnord-1.9.tar.bz2) = 7867e64539e1ad1f98704275e2f95387
-SIZE (fnord-1.9.tar.bz2) = 28753
+MD5 (fnord-1.10.tar.bz2) = 4c7d9f0e2b2f071d4687688f3018ba91
+SIZE (fnord-1.10.tar.bz2) = 33408
diff --git a/www/fnord/files/fnord.inetd.in b/www/fnord/files/fnord.inetd.in
new file mode 100644
index 000000000000..fdd1a68446bc
--- /dev/null
+++ b/www/fnord/files/fnord.inetd.in
@@ -0,0 +1,8 @@
+#! /bin/sh
+
+if [ ! -d "$1" ]; then
+ echo "usage: $0 <www_root_directory>"
+else
+ cd $1
+ exec %%PREFIX%%/bin/fnord 2>/dev/null
+fi
diff --git a/www/fnord/files/pkg-message.in b/www/fnord/files/pkg-message.in
new file mode 100644
index 000000000000..47277dcefcc0
--- /dev/null
+++ b/www/fnord/files/pkg-message.in
@@ -0,0 +1,26 @@
+------------------------------------------------------------------
+Now that fnord is installed, do the following :
+
+1) If you chose to use daemontools and/or tcpserver, I assume you
+know how to do it, go to 4). If you chose to use inetd go to 2).
+
+2) Create a webroot somewhere :
+
+ # mkdir /usr/local/www
+
+3) Add an entry in inetd.conf like this :
+
+ "http stream tcp nowait root %%PREFIX%%/bin/fnord.inetd \
+ fnord.inetd /usr/local/www"
+
+4) Finally add some virtual hosts to your webserver :
+
+ # cd /usr/local/www
+ # mkdir host.tld:80
+ # ln -s host.tld:80 host.tld
+ # echo "test" > host.tld:80/index.html
+
+5- Test with your favorite web browser.
+
+ # links http://host.tld/index.html
+------------------------------------------------------------------