aboutsummaryrefslogtreecommitdiff
path: root/www/fnord
diff options
context:
space:
mode:
authorAdam Weinberger <adamw@FreeBSD.org>2014-07-23 16:58:55 +0000
committerAdam Weinberger <adamw@FreeBSD.org>2014-07-23 16:58:55 +0000
commitf2466b9fba0a07e061a5b60807210dd755fad93b (patch)
tree8cdbcc16140332dcf23704657ed40e2b1bd22f5a /www/fnord
parentbc296ac1a27a00c781a74fb995779f3276fa766c (diff)
downloadports-f2466b9fba0a07e061a5b60807210dd755fad93b.tar.gz
ports-f2466b9fba0a07e061a5b60807210dd755fad93b.zip
Stage, fix build without gcc, and repair a backwards OPTIONS check.
Notes
Notes: svn path=/head/; revision=362710
Diffstat (limited to 'www/fnord')
-rw-r--r--www/fnord/Makefile29
1 files changed, 10 insertions, 19 deletions
diff --git a/www/fnord/Makefile b/www/fnord/Makefile
index dcaf78e632d4..7e6b36d9cccd 100644
--- a/www/fnord/Makefile
+++ b/www/fnord/Makefile
@@ -24,18 +24,14 @@ TCPSERVER_DESC= Use DJB's tcpserver
CGI_DESC= Enable CGI support
DIR_LIST_DESC= Enable directory listing
SYSTEM_SYMLINK_DEREF_DESC= Enable system symlink (needs DIR_LIST)
-OLD_STYLE_REDIRECT_DESC= "Enable old style redirection
+OLD_STYLE_REDIRECT_DESC= Enable old style redirection
-NO_STAGE= yes
-.include <bsd.port.options.mk>
+DAEMONTOOLS_RUN_DEPENDS= setuidgid:${PORTSDIR}/sysutils/daemontools
+TCPSERVER_RUN_DEPENDS= tcpserver:${PORTSDIR}/sysutils/ucspi-tcp
-.if ${PORT_OPTIONS:MDAEMONTOOLS}
-RUN_DEPENDS= setuidgid:${PORTSDIR}/sysutils/daemontools
-.endif
+MAKE_ARGS+= DIET="" CC="${CC}" CXX="${CXX}"
-.if ${PORT_OPTIONS:MTCPSERVER}
-RUN_DEPENDS= tcpserver:${PORTSDIR}/sysutils/ucspi-tcp
-.endif
+.include <bsd.port.options.mk>
.if ${PORT_OPTIONS:MCGI}
SED_SCRIPT+= -e "s|^// \(\#define CGI\).*|\1|"
@@ -53,8 +49,8 @@ SED_SCRIPT+= -e "s|^// \(\#define CGI\).*|\1|"
# http://<vhost>/etc/passwd */
.if ${PORT_OPTIONS:MSYSTEM_SYMLINK_DEREF}
-.if ${PORT_OPTIONS:MDIR_LIST}
-IGNORE= SYSTEM_SYMLINK_DEREF has no effect if DIR_LIST is not enabled
+.if empty(PORT_OPTIONS:MDIR_LIST)
+IGNORE= SYSTEM_SYMLINK_DEREF requires the DIR_LIST option
.endif
SED_SCRIPT+= -e "s|^/\* \(\#define SYSTEM_SYMLINK_DEREF\).*|\1|"
.endif
@@ -77,15 +73,10 @@ post-patch:
${REINPLACE_CMD} ${SED_SCRIPT} ${WRKSRC}/httpd.c
@${REINPLACE_CMD} -e "/strip/d" ${WRKSRC}/Makefile
-do-build:
- cd ${WRKSRC}; ${MAKE_CMD} DIET=""
-
do-install:
- ${INSTALL_PROGRAM} ${WRKSRC}/fnord ${PREFIX}/bin/
- ${INSTALL_SCRIPT} ${WRKSRC}/fnord-conf ${PREFIX}/bin/
- ${INSTALL_SCRIPT} ${WRKDIR}/fnord.inetd ${PREFIX}/bin/
+ ${INSTALL_PROGRAM} ${WRKSRC}/fnord ${STAGEDIR}${PREFIX}/bin
+ ${INSTALL_SCRIPT} ${WRKSRC}/fnord-conf ${STAGEDIR}${PREFIX}/bin
+ ${INSTALL_SCRIPT} ${WRKDIR}/fnord.inetd ${STAGEDIR}${PREFIX}/bin
-post-install:
- @${CAT} ${PKGMESSAGE}
.include <bsd.port.mk>