aboutsummaryrefslogtreecommitdiff
path: root/www/formication/Makefile
diff options
context:
space:
mode:
authorVolker Stolz <vs@FreeBSD.org>2004-07-25 09:24:57 +0000
committerVolker Stolz <vs@FreeBSD.org>2004-07-25 09:24:57 +0000
commitd06983b147a40086a48f81d925e5a4171c31f90c (patch)
tree25857301b3325d7cf1035876ff73d9ca634ccdf0 /www/formication/Makefile
parent13b20ca3fc74f454d4f657c0f1d2fa84d8e36cd5 (diff)
downloadports-d06983b147a40086a48f81d925e5a4171c31f90c.tar.gz
ports-d06983b147a40086a48f81d925e5a4171c31f90c.zip
Notes
Diffstat (limited to 'www/formication/Makefile')
-rw-r--r--www/formication/Makefile50
1 files changed, 50 insertions, 0 deletions
diff --git a/www/formication/Makefile b/www/formication/Makefile
new file mode 100644
index 000000000000..12b1ce8c5ec2
--- /dev/null
+++ b/www/formication/Makefile
@@ -0,0 +1,50 @@
+# New ports collection makefile for: formication
+# Date created: 2004-01-25
+# Whom: Michael Ranner <mranner@inode.at>
+#
+# $FreeBSD$
+#
+
+PORTNAME= formication
+PORTVERSION= 1.0.b1
+CATEGORIES= www
+MASTER_SITES= http://www.villainy.com/downloads/ \
+ http://www.ranner.jawa.at/stuff/
+DISTNAME= ${PORTNAME}
+
+MAINTAINER= mranner@inode.at
+COMMENT= Formular processing tool written in perl
+
+CGI_UID?= www
+
+PKGMESSAGE= ${WRKDIR}/pkg-message
+USE_APACHE= yes
+USE_PERL5_RUN= yes
+USE_REINPLACE= yes
+NO_BUILD= yes
+
+PORTDOCS= BLURB COPYING feedback.fcn feedback.html formication.txt
+PLIST_FILES= www/cgi-bin/formication.pl
+
+post-patch:
+ @${REINPLACE_CMD} -e "s,^#!/usr/local/bin/perl,#!${PERL},g" \
+ -e "s,authorized_uid = 1031;,authorized_uid = ${CGI_UID};,g" \
+ ${WRKSRC}/formication.pl
+
+do-install:
+ @${INSTALL_DATA} ${WRKSRC}/formication.pl ${PREFIX}/www/cgi-bin
+.if !defined(NOPORTDOCS)
+ @${INSTALL} -d -o root -g wheel -m 0755 ${DOCSDIR}
+. for i in ${PORTDOCS}
+ @${INSTALL_DATA} ${WRKSRC}/${i} ${DOCSDIR}
+. endfor
+.endif
+
+pre-install:
+ @${SED} -e 's|%%LOCALBASE%%|${LOCALBASE}|g' \
+ -e 's|%%DOCSDIR%%|${DOCSDIR}|g' <${.CURDIR}/pkg-message >${PKGMESSAGE}
+
+post-install:
+ @${CAT} ${PKGMESSAGE}
+
+.include <bsd.port.mk>