aboutsummaryrefslogtreecommitdiff
path: root/www/foswiki/Makefile
diff options
context:
space:
mode:
authorGreg Larkin <glarkin@FreeBSD.org>2010-03-23 20:48:29 +0000
committerGreg Larkin <glarkin@FreeBSD.org>2010-03-23 20:48:29 +0000
commit656511a3efb1fa43a8894195a452a9ac36a748fe (patch)
treef56076f211b3daa6e5fb3c08d65e9a7f9c300c04 /www/foswiki/Makefile
parentfec759788a4b0b4c4b9aa62d6e358fd717ebdac5 (diff)
downloadports-656511a3efb1fa43a8894195a452a9ac36a748fe.tar.gz
ports-656511a3efb1fa43a8894195a452a9ac36a748fe.zip
Notes
Diffstat (limited to 'www/foswiki/Makefile')
-rw-r--r--www/foswiki/Makefile42
1 files changed, 32 insertions, 10 deletions
diff --git a/www/foswiki/Makefile b/www/foswiki/Makefile
index 428a507a0aa8..3cfd47c7af3e 100644
--- a/www/foswiki/Makefile
+++ b/www/foswiki/Makefile
@@ -7,6 +7,7 @@
PORTNAME= foswiki
PORTVERSION= 1.0.9
+PORTREVISION= 1
CATEGORIES= www
MASTER_SITES= SF
DISTNAME= Foswiki-${PORTVERSION}
@@ -16,17 +17,17 @@ MAINTAINER= glarkin@FreeBSD.org
COMMENT= A free and open source enterprise wiki
BUILD_DEPENDS= p5-Error>=0:${PORTSDIR}/lang/p5-Error
-RUN_DEPENDS= ${BUILD_DEPENDS}
+RUN_DEPENDS= p5-Error>=0:${PORTSDIR}/lang/p5-Error
USE_PERL5= 5.8.4+
-USE_APACHE= 2.0+
NO_BUILD= yes
OPTIONS= OPTINT "Install Perl modules for intl character support" Off \
OPTOTH "Install other optional Perl modules" On \
- APACHE "Install sample Apache 2.x config file" Off
+ APACHE "Install Apache web server and sample config file" Off
+
+.include <bsd.port.options.mk>
-.include <bsd.port.pre.mk>
.if defined(WITH_OPTINT)
BUILD_DEPENDS+= p5-Locale-Maketext-Lexicon>=0:${PORTSDIR}/devel/p5-Locale-Maketext-Lexicon
RUN_DEPENDS+= p5-Locale-Maketext-Lexicon>=0:${PORTSDIR}/devel/p5-Locale-Maketext-Lexicon
@@ -40,23 +41,44 @@ BUILD_DEPENDS+= p5-Apache-Htpasswd>=0:${PORTSDIR}/security/p5-Apache-Htpasswd \
p5-Lingua-EN-Sentence>=0:${PORTSDIR}/textproc/p5-Lingua-EN-Sentence \
p5-libwww>=0:${PORTSDIR}/www/p5-libwww \
p5-Net>=1.19:${PORTSDIR}/net/p5-Net
-RUN_DEPENDS+= ${BUILD_DEPENDS}
+RUN_DEPENDS+= p5-Apache-Htpasswd>=0:${PORTSDIR}/security/p5-Apache-Htpasswd \
+ p5-Archive-Tar>=0:${PORTSDIR}/archivers/p5-Archive-Tar \
+ p5-CGI-Session>=4.30:${PORTSDIR}/www/p5-CGI-Session \
+ p5-Digest-SHA1>=0:${PORTSDIR}/security/p5-Digest-SHA1 \
+ p5-Lingua-EN-Sentence>=0:${PORTSDIR}/textproc/p5-Lingua-EN-Sentence \
+ p5-libwww>=0:${PORTSDIR}/www/p5-libwww \
+ p5-Net>=1.19:${PORTSDIR}/net/p5-Net
.endif
.if defined(WITH_APACHE)
+USE_APACHE?= 1.3+
PLIST_SUB+= NOAPACHE=""
PKGMESSAGE= pkg-message-apache
SUB_FILES+= pkg-message-apache
+
+.include <bsd.port.pre.mk>
+
+CONFDIR= ${PREFIX}/${CONFDIR_REL}
+.if ${APACHE_VERSION} == "13"
+CONFDIR_REL= ${APACHEETCDIR}
.else
+CONFDIR_REL= ${APACHEETCDIR}/Includes
+.endif
+
+PLIST_SUB+= CONFDIR=${CONFDIR_REL}
+.else
+# Weirdness - need to include in this branch of the .if because
+# it was included in the other one. The other branch needs
+# the include performed after the USE_APACHE variable is set so
+# APACHE_VERSION can be tested above.
+
+.include <bsd.port.pre.mk>
+
PLIST_SUB+= NOAPACHE="@comment "
PKGMESSAGE= pkg-message-noapache
SUB_FILES+= pkg-message-noapache
.endif
-# Always set these so the pkg-message displays correctly
-CONFDIR= ${PREFIX}/${CONFDIR_REL}
-CONFDIR_REL= ${APACHEETCDIR}/Includes
-PLIST_SUB+= CONFDIR=${CONFDIR_REL}
SUB_FILES+= LocalSite.cfg
post-patch:
@@ -84,7 +106,7 @@ post-install:
${CONFDIR}/foswiki.conf.sample; \
else \
${ECHO_MSG} "" ; \
- ${ECHO_MSG} "Please check your Apache 2.x installation -" ; \
+ ${ECHO_MSG} "Please check your Apache installation -" ; \
${ECHO_MSG} "${CONFDIR} doesn't exist," ; \
${ECHO_MSG} "so I cannot install foswiki.conf.sample there!" ; \
${ECHO_MSG} "" ; \