aboutsummaryrefslogtreecommitdiff
path: root/www/free-sa-devel
diff options
context:
space:
mode:
authorJohn Marino <marino@FreeBSD.org>2014-04-17 19:05:35 +0000
committerJohn Marino <marino@FreeBSD.org>2014-04-17 19:05:35 +0000
commit4bd31f99723f14784fed70b1418cf56b04852e25 (patch)
tree470665f0a56c37eb0874f4f1e9109c7c66adabed /www/free-sa-devel
parent798cfa96ec126643a73f28c42b6d4b010336faa4 (diff)
downloadports-4bd31f99723f14784fed70b1418cf56b04852e25.tar.gz
ports-4bd31f99723f14784fed70b1418cf56b04852e25.zip
Notes
Diffstat (limited to 'www/free-sa-devel')
-rw-r--r--www/free-sa-devel/Makefile65
-rw-r--r--www/free-sa-devel/distinfo4
-rw-r--r--www/free-sa-devel/files/extra-patch-Makefile13
-rw-r--r--www/free-sa-devel/files/pkg-deinstall.in20
-rw-r--r--www/free-sa-devel/pkg-plist59
5 files changed, 91 insertions, 70 deletions
diff --git a/www/free-sa-devel/Makefile b/www/free-sa-devel/Makefile
index d5bc3c2215a6..e9cc45b519ec 100644
--- a/www/free-sa-devel/Makefile
+++ b/www/free-sa-devel/Makefile
@@ -2,12 +2,11 @@
# $FreeBSD$
PORTNAME= free-sa
-PORTVERSION= 2.0.0b5.10
+PORTVERSION= 2.0.0b6
CATEGORIES= www
MASTER_SITES= SF
-MASTER_SITE_SUBDIR= free-sa/free-sa-dev/2.0.0b5p10/
+MASTER_SITE_SUBDIR= free-sa/free-sa-dev/${PORTVERSION}
PKGNAMESUFFIX= -devel
-DISTNAME= free-sa-2.0.0b5p10
MAINTAINER= moiseev@mezonplus.ru
COMMENT= Statistic analyzer for daemons log files similar to SARG
@@ -20,15 +19,16 @@ LATEST_LINK= free-sa-devel
WWWDIR?= ${PREFIX}/www/${PORTNAME}
DOCSDIR= ${PREFIX}/share/doc/${PORTNAME}-${DISTVERSION}
+SUB_FILES= pkg-deinstall
+SUB_LIST= CACHEDIR="/var/cache/free-sa"
+PLIST_SUB+= RESETPREFIX=${PREFIX}
+
USE_CSTD= gnu89
-PORTDOCS= COPYING ChangeLog FAQ INSTALL README README.DEV THANKS
-MAN1= free-sa.1
-MAN5= free-sa.conf.5
MAKE_ARGS+= PREFIX="${PREFIX}" \
ETCDIR="${ETCDIR}" \
WWWDIR="${WWWDIR}" \
- CACHEDIR="/var/cache/${PORTNAME}" \
+ CACHEDIR="/var/cache/free-sa" \
LOCDIR="${DATADIR}" \
DOCDIR="${DOCSDIR}" \
LOGFILE=/var/log/squid/access.log \
@@ -38,34 +38,35 @@ MAKE_ARGS+= PREFIX="${PREFIX}" \
LARGEFILE=yes \
SATSEP="'" \
HAVE_STRL="1" \
- ADDLDFLAGS="${LDFLAGS} -mrelax" \
- MANDIR="${MANPREFIX}/man"
+ MANDIR="${MANPREFIX}/man" \
+ STAGEDIR="${STAGEDIR}"
-OPTIONS_DEFINE= OPTIMIZED_CFLAGS SA_DEBUG
+OPTIONS_DEFINE= OPTIMIZED_CFLAGS SA_DEBUG
OPTIMIZED_CFLAGS_DESC= Build with distribution-recommended CFLAGS
SA_DEBUG_DESC= Enable Free-SA debugging (level 1)
-NO_STAGE= yes
.include <bsd.port.options.mk>
pre-everything::
.if empty(PORT_OPTIONS:MOPTIMIZED_CFLAGS)
- @${ECHO_MSG} ">>> This software is computationally demanding, and users are"
- @${ECHO_MSG} ">>> advised to employ compiler optimizations when building it."
- @${ECHO_MSG} ">>> Author of this software have used such flags as"
- @${ECHO_MSG} ">>> 'CFLAGS= -O4 -pipe -march=native' and 'CC= gcc' to advantage."
- @${ECHO_MSG} ">>> You can set them in make.conf, but they depends on your system and compiler."
- @${ECHO_MSG} ">>> In addition, you can enable extra flags by defining WITH_OPTIMIZED_CFLAGS"
- @${ECHO_MSG} ">>> For example, 'make WITH_OPTIMIZED_CFLAGS=yes'"
- @${ECHO_MSG} ">>>"
+ @${ECHO_MSG} "============================================================================="
+ @${ECHO_MSG} " This software is computationally demanding, and users are"
+ @${ECHO_MSG} " advised to employ compiler optimizations when building it."
+ @${ECHO_MSG} " Author of this software have used such flags as"
+ @${ECHO_MSG} " 'CFLAGS= -O4 -pipe -march=native' and 'CC= gcc' to advantage."
+ @${ECHO_MSG} " You can set them in make.conf, but they depends on your system and compiler."
+ @${ECHO_MSG} " In addition, you can enable extra flags by defining WITH_OPTIMIZED_CFLAGS"
+ @${ECHO_MSG} " For example, 'make WITH_OPTIMIZED_CFLAGS=yes'"
+ @${ECHO_MSG} "============================================================================="
.endif
-.if empty(PORT_OPTIONS:MSA_DEBUG) && (SA_DEBUG_LEVEL)
- @${ECHO_MSG} ">>> You can enable Free-SA debugging (level 1) by defining WITH_SA_DEBUG"
- @${ECHO_MSG} ">>> For example, 'make WITH_SA_DEBUG=yes'"
- @${ECHO_MSG} ">>> Or for specific level (0-7) you can use SA_DEBUG_LEVEL"
- @${ECHO_MSG} ">>> For example, 'make SA_DEBUG_LEVEL=4'"
- @${ECHO_MSG} ">>> Note that SA_DEBUG_LEVEL overrides WITH_SA_DEBUG"
- @${ECHO_MSG} ">>>"
+.if empty(PORT_OPTIONS:MSA_DEBUG) &! (SA_DEBUG_LEVEL)
+ @${ECHO_MSG} "============================================================================="
+ @${ECHO_MSG} " You can enable Free-SA debugging (level 1) by defining WITH_SA_DEBUG"
+ @${ECHO_MSG} " For example, 'make WITH_SA_DEBUG=yes'"
+ @${ECHO_MSG} " Or for specific level (0-7) you can use SA_DEBUG_LEVEL"
+ @${ECHO_MSG} " For example, 'make SA_DEBUG_LEVEL=4'"
+ @${ECHO_MSG} " Note that SA_DEBUG_LEVEL overrides WITH_SA_DEBUG"
+ @${ECHO_MSG} "============================================================================="
.endif
.if ${PORT_OPTIONS:MSA_DEBUG}
@@ -74,15 +75,15 @@ SA_DEBUG_LEVEL?= 1
SA_DEBUG_LEVEL?= 0
.endif
-.if defined(NOPORTDOCS)
-EXTRA_PATCHES+= ${FILESDIR}/extra-patch-Makefile
-.endif
-
post-patch:
- @${REINPLACE_CMD} \
+ @cd ${WRKSRC} && \
+ ${REINPLACE_CMD} \
-e 's,^DEBUG = .*,DEBUG = ${SA_DEBUG_LEVEL},' \
-e 's,^include .(GMKPATH)/configs/.(OSTYPE)\.mk,,' \
- ${WRKSRC}/global.mk
+ global.mk && \
+ ${REINPLACE_CMD} -E \
+ -e '/#define/!s,\$$\((PREFIX|WWWDIR|CACHEDIR|DOCDIR|ETCDIR|MANDIR|LOCDIR)\),$$(STAGEDIR)&,' \
+ Makefile themes/Makefile src/Makefile etc/Makefile man/Makefile share/Makefile
.if ${PORT_OPTIONS:MOPTIMIZED_CFLAGS}
MAKE_ARGS+= ADDCFLAGS="${CFLAGS} \
diff --git a/www/free-sa-devel/distinfo b/www/free-sa-devel/distinfo
index bd26712347a4..c9dda85997db 100644
--- a/www/free-sa-devel/distinfo
+++ b/www/free-sa-devel/distinfo
@@ -1,2 +1,2 @@
-SHA256 (free-sa-2.0.0b5p10.tar.gz) = 12ba763ce38d64979c8cb378741f507a0d8acb5d3cdbb443d940716317c95bee
-SIZE (free-sa-2.0.0b5p10.tar.gz) = 98991
+SHA256 (free-sa-2.0.0b6.tar.gz) = 8fc6015bae08bd7d87bf19d53a2a0b96cb803750533ce3c1a15eec1a6037f020
+SIZE (free-sa-2.0.0b6.tar.gz) = 105566
diff --git a/www/free-sa-devel/files/extra-patch-Makefile b/www/free-sa-devel/files/extra-patch-Makefile
deleted file mode 100644
index b8397c87dee7..000000000000
--- a/www/free-sa-devel/files/extra-patch-Makefile
+++ /dev/null
@@ -1,13 +0,0 @@
---- Makefile.orig 2009-07-23 16:08:46.000000000 +0400
-+++ Makefile 2009-07-23 16:12:00.000000000 +0400
-@@ -17,10 +17,6 @@
- $(MAKEDIRS)
- @( \
- $(INSTALLODR) $(CACHEDIR); \
-- $(INSTALLDIR) $(DOCDIR); \
-- for IDOCFILE in COPYING ChangeLog FAQ INSTALL README README.DEV THANKS; do \
-- $(INSTALLFIL) $$IDOCFILE $(DOCDIR); \
-- done \
- )
-
- src/config.h: global.mk
diff --git a/www/free-sa-devel/files/pkg-deinstall.in b/www/free-sa-devel/files/pkg-deinstall.in
new file mode 100644
index 000000000000..12e0a9897367
--- /dev/null
+++ b/www/free-sa-devel/files/pkg-deinstall.in
@@ -0,0 +1,20 @@
+#! /bin/sh
+
+if [ "$2" != "POST-DEINSTALL" ]; then
+ exit 0
+fi
+
+echo
+echo "======================================================================"
+echo " If you are permanently removing Free-SA, you should manually delete:"
+if [ -d %%ETCDIR%% ]; then
+ echo " - Free-SA configuration: rm -r %%ETCDIR%%"
+fi
+if [ -d %%WWWDIR%% ]; then
+ echo " - Free-SA www directory: rm -r %%WWWDIR%%"
+fi
+if [ -d %%CACHEDIR%% ]; then
+ echo " - Free-SA cache directory: rm -r %%CACHEDIR%%"
+fi
+echo "======================================================================"
+echo
diff --git a/www/free-sa-devel/pkg-plist b/www/free-sa-devel/pkg-plist
index 9ad888047f6f..b6f30cc42bf7 100644
--- a/www/free-sa-devel/pkg-plist
+++ b/www/free-sa-devel/pkg-plist
@@ -1,24 +1,32 @@
-@unexec /bin/rm -f %D/%%WWWDIR%%/themes/default
bin/free-sa
-%%ETCDIR%%/HTTP_CONNECT_method.filter.sample
-%%ETCDIR%%/HTTP_PUT+POST_method.filter.sample
-%%ETCDIR%%/HTTP_downloads.filter.sample
-%%ETCDIR%%/HTTP_downloads_archives.filter.sample
-%%ETCDIR%%/HTTP_downloads_audio.filter.sample
-%%ETCDIR%%/HTTP_downloads_cddvd.filter.sample
-%%ETCDIR%%/HTTP_downloads_code.filter.sample
-%%ETCDIR%%/HTTP_downloads_office.filter.sample
-%%ETCDIR%%/HTTP_downloads_video.filter.sample
-%%ETCDIR%%/HTTP_proxy_auth_failures.filter.sample
-%%ETCDIR%%/HTTP_proxy_denied.filter.sample
-%%ETCDIR%%/HTTP_site_auth_failures.filter.sample
-%%ETCDIR%%/HTTP_site_denied.filter.sample
-%%ETCDIR%%/HTTP_unusual_codes.filter.sample
-%%ETCDIR%%/HTTP_unusual_methods.filter.sample
-%%ETCDIR%%/SMTP_delivery_rejected.filter.sample
-%%ETCDIR%%/SMTP_receiving_rejected.filter.sample
-%%ETCDIR%%/free-sa.conf.sample
-%%ETCDIR%%/users.filter.sample
+etc/free-sa/HTTP_CONNECT_method.filter.sample
+etc/free-sa/HTTP_PUT+POST_method.filter.sample
+etc/free-sa/HTTP_downloads.filter.sample
+etc/free-sa/HTTP_downloads_archives.filter.sample
+etc/free-sa/HTTP_downloads_audio.filter.sample
+etc/free-sa/HTTP_downloads_cddvd.filter.sample
+etc/free-sa/HTTP_downloads_code.filter.sample
+etc/free-sa/HTTP_downloads_office.filter.sample
+etc/free-sa/HTTP_downloads_video.filter.sample
+etc/free-sa/HTTP_proxy_auth_failures.filter.sample
+etc/free-sa/HTTP_proxy_denied.filter.sample
+etc/free-sa/HTTP_site_auth_failures.filter.sample
+etc/free-sa/HTTP_site_denied.filter.sample
+etc/free-sa/HTTP_unusual_codes.filter.sample
+etc/free-sa/HTTP_unusual_methods.filter.sample
+etc/free-sa/SMTP_delivery_rejected.filter.sample
+etc/free-sa/SMTP_receiving_rejected.filter.sample
+etc/free-sa/free-sa.conf.sample
+etc/free-sa/users.filter.sample
+man/man1/free-sa.1.gz
+man/man5/free-sa.conf.5.gz
+%%PORTDOCS%%%%DOCSDIR%%/COPYING
+%%PORTDOCS%%%%DOCSDIR%%/ChangeLog
+%%PORTDOCS%%%%DOCSDIR%%/FAQ
+%%PORTDOCS%%%%DOCSDIR%%/INSTALL
+%%PORTDOCS%%%%DOCSDIR%%/README
+%%PORTDOCS%%%%DOCSDIR%%/README.DEV
+%%PORTDOCS%%%%DOCSDIR%%/THANKS
%%DATADIR%%/be.cp1251
%%DATADIR%%/cs.iso88592
%%DATADIR%%/de.iso88591
@@ -48,6 +56,7 @@ bin/free-sa
%%WWWDIR%%/themes/blues/lsa.css
%%WWWDIR%%/themes/blues/rsa.css
%%WWWDIR%%/themes/blues/s.png
+%%WWWDIR%%/themes/default
%%WWWDIR%%/themes/qbiq/c.png
%%WWWDIR%%/themes/qbiq/d.png
%%WWWDIR%%/themes/qbiq/g.png
@@ -66,17 +75,17 @@ bin/free-sa
%%WWWDIR%%/themes/sarg/c.png
%%WWWDIR%%/themes/sarg/d.png
%%WWWDIR%%/themes/sarg/g.png
-%%WWWDIR%%/themes/sarg/s.png
%%WWWDIR%%/themes/sarg/gsa.css
%%WWWDIR%%/themes/sarg/lsa.css
%%WWWDIR%%/themes/sarg/rsa.css
-%%WWWDIR%%/themes/silver/s.png
+%%WWWDIR%%/themes/sarg/s.png
%%WWWDIR%%/themes/silver/c.png
%%WWWDIR%%/themes/silver/d.png
%%WWWDIR%%/themes/silver/g.png
%%WWWDIR%%/themes/silver/gsa.css
%%WWWDIR%%/themes/silver/lsa.css
%%WWWDIR%%/themes/silver/rsa.css
+%%WWWDIR%%/themes/silver/s.png
@dirrm %%WWWDIR%%/themes/silver
@dirrm %%WWWDIR%%/themes/sarg
@dirrm %%WWWDIR%%/themes/rbsec
@@ -86,4 +95,8 @@ bin/free-sa
@dirrm %%WWWDIR%%/cgi-bin
@dirrmtry %%WWWDIR%%
@dirrm %%DATADIR%%
-@dirrmtry %%ETCDIR%%
+%%PORTDOCS%%@dirrm %%DOCSDIR%%
+@dirrmtry etc/free-sa
+@cwd /
+@dirrmtry var/cache/free-sa
+@cwd %%RESETPREFIX%%