aboutsummaryrefslogtreecommitdiff
path: root/www/g-gcl/Makefile
diff options
context:
space:
mode:
authorChris Piazza <cpiazza@FreeBSD.org>1999-06-22 06:23:47 +0000
committerChris Piazza <cpiazza@FreeBSD.org>1999-06-22 06:23:47 +0000
commit3537bd37f47dd5c64e8e851c0e42587ddc8776c6 (patch)
treeb9f514e14d8e2741e83bf35f461cbe13cee1334e /www/g-gcl/Makefile
parent5c7f7285272efb29841aaf33ff15973613d88088 (diff)
Import of g-gcl.
g-gcl is a set of sample graphic counter language scripts for the creation of original web counters and timers. See the graphics/gracula port. You can see the resulting counters at: http://www.whizkidtech.net/gcl/gallery/ PR: 12330 Submitted by: G. Adam Stanislav <adam@whizkidtech.net>
Notes
Notes: svn path=/head/; revision=19621
Diffstat (limited to 'www/g-gcl/Makefile')
-rw-r--r--www/g-gcl/Makefile40
1 files changed, 40 insertions, 0 deletions
diff --git a/www/g-gcl/Makefile b/www/g-gcl/Makefile
new file mode 100644
index 000000000000..b4857556cdf5
--- /dev/null
+++ b/www/g-gcl/Makefile
@@ -0,0 +1,40 @@
+# New ports collection makefile for: g-gcl
+# Version required: 1.10
+# Date created: 21 Jun 1999
+# Whom: G. Adam Stanislav <adam@whizkidtech.net>
+#
+# $Id$
+#
+
+DISTNAME= g-gcl-1.10
+CATEGORIES= www graphics
+MASTER_SITES= ftp://ftp.whizkidtech.net/cgi/gcl/ \
+ http://www.whizkidtech.net/gcl/
+
+MAINTAINER= adam@whizkidtech.net
+
+RUN_DEPENDS= gracula:${PORTSDIR}/graphics/gracula
+
+NO_BUILD=
+
+do-install:
+ ${MKDIR} ${PREFIX}/share/gracula
+ ${MKDIR} ${PREFIX}/share/gracula/pix
+ ${MKDIR} ${PREFIX}/share/examples/gracula
+ ${INSTALL_DATA} ${WRKSRC}/g.gd ${PREFIX}/share/gracula/pix
+ ${INSTALL_DATA} ${WRKSRC}/owl.gd ${PREFIX}/share/gracula/pix
+ ${INSTALL_DATA} ${WRKSRC}/read.gd ${PREFIX}/share/gracula/pix
+ ${INSTALL_DATA} ${WRKSRC}/space.gd ${PREFIX}/share/gracula/pix
+ ${INSTALL_SCRIPT} ${WRKSRC}/g.gcl.sample ${PREFIX}/share/examples/gracula
+ ${INSTALL_SCRIPT} ${WRKSRC}/owl.gcl.sample ${PREFIX}/share/examples/gracula
+ ${INSTALL_SCRIPT} ${WRKSRC}/read.gcl.sample ${PREFIX}/share/examples/gracula
+ ${INSTALL_SCRIPT} ${WRKSRC}/space.gcl.sample ${PREFIX}/share/examples/gracula
+ ${INSTALL_SCRIPT} ${WRKSRC}/sec2000.gcl.sample ${PREFIX}/share/examples/gracula
+ ${INSTALL_SCRIPT} ${WRKSRC}/tri.gcl.sample ${PREFIX}/share/examples/gracula
+ @echo
+ @echo " Sample scripts installed in the"
+ @echo " ${PREFIX}/share/examples/gracula/"
+ @echo " directory."
+ @echo
+
+.include <bsd.port.mk>