aboutsummaryrefslogtreecommitdiff
path: root/www/galeon/Makefile
diff options
context:
space:
mode:
authorJoe Marcus Clarke <marcus@FreeBSD.org>2005-11-05 06:19:06 +0000
committerJoe Marcus Clarke <marcus@FreeBSD.org>2005-11-05 06:19:06 +0000
commit05cbaa54a40def97db44c2eddf94d61f3e2fe75d (patch)
tree3de911d217bffac166562d442697b3bc5e500ab8 /www/galeon/Makefile
parent73480e98f33228bdcc9638aac80966eba97f2893 (diff)
downloadports-05cbaa54a40def97db44c2eddf94d61f3e2fe75d.tar.gz
ports-05cbaa54a40def97db44c2eddf94d61f3e2fe75d.zip
Notes
Diffstat (limited to 'www/galeon/Makefile')
-rw-r--r--www/galeon/Makefile23
1 files changed, 13 insertions, 10 deletions
diff --git a/www/galeon/Makefile b/www/galeon/Makefile
index fd2355610d33..e2198716bb1e 100644
--- a/www/galeon/Makefile
+++ b/www/galeon/Makefile
@@ -3,10 +3,12 @@
# Whom: Maxim Sobolev <sobomax@FreeBSD.org>
#
# $FreeBSD$
+# $MCom: ports/www/galeon/Makefile,v 1.3 2005/08/26 04:03:55 marcus Exp $
#
PORTNAME= galeon
PORTVERSION= 1.3.21
+PORTREVISION= 1
CATEGORIES= www gnome
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE} \
http://osdn.dl.sourceforge.net/sourceforge/galeon/
@@ -18,23 +20,24 @@ COMMENT= A GNOME 2 Web browser based on gecko (the Mozilla rendering engine)
BUILD_DEPENDS= ${X11BASE}/lib/${MOZILLA}/components/libwidget_gtk2.so:${PORTSDIR}/www/${MOZILLA}
RUN_DEPENDS= ${X11BASE}/lib/${MOZILLA}/components/libwidget_gtk2.so:${PORTSDIR}/www/${MOZILLA}
-MOZILLA= mozilla
+MOZILLA= firefox
HEADERS_SUFX=
-MOZ_BUILD= mozilla
+MOZ_BUILD= firefox
.if !defined(WITH_MOZILLA)
-MOZILLA= mozilla
+MOZILLA= firefox
HEADERS_SUFX=
.else
-.if ${WITH_MOZILLA}=="firefox"
-MOZILLA= firefox
-MOZ_BUILD= firefox
+.if ${WITH_MOZILLA}=="mozilla"
+MOZILLA= mozilla
+MOZ_BUILD= mozilla
.else
.if ${WITH_MOZILLA}=="mozilla-devel" || ${WITH_MOZILLA}=="mozilla-devel-gtk2"
MOZILLA= mozilla-devel
HEADERS_SUFX= -devel
+MOZ_BUILD= mozilla
.else
-MOZILLA= mozilla
+MOZILLA= firefox
HEADERS_SUFX=
.endif
.endif
@@ -46,7 +49,7 @@ USE_X_PREFIX= yes
INSTALLS_OMF= yes
USE_GNOME= gnomeprefix intlhack gnomehack libgnomeui desktopfileutils \
gnomedesktop
-USE_LIBTOOL_VER=15
+USE_AUTOTOOLS= libtool:15
USE_GMAKE= yes
USE_REINPLACE= yes
CONFIGURE_ARGS= --enable-nautilus-view=no \
@@ -79,10 +82,10 @@ USE_GCC= 3.4
pre-everything::
@${ECHO_MSG} ""
- @${ECHO_MSG} " By default the port uses www/mozilla for html rendering, but you can"
+ @${ECHO_MSG} " By default the port uses www/firefox for html rendering, but you can"
@${ECHO_MSG} " change this by defining WITH_MOZILLA to one of the following values:"
@${ECHO_MSG}
- @${ECHO_MSG} " firefox "
+ @${ECHO_MSG} " mozilla "
@${ECHO_MSG} " mozilla-devel "
@${ECHO_MSG} ""