aboutsummaryrefslogtreecommitdiff
path: root/www/galeon/Makefile
diff options
context:
space:
mode:
authorJoe Marcus Clarke <marcus@FreeBSD.org>2003-11-26 06:02:15 +0000
committerJoe Marcus Clarke <marcus@FreeBSD.org>2003-11-26 06:02:15 +0000
commita73b45419fba47c8896c7f1aff61d571202190b1 (patch)
tree6415d78c228878c8a7e355b7d25a8fb820987077 /www/galeon/Makefile
parent7df6a56ab865b93561f32aa3925ba70b36693411 (diff)
downloadports-a73b45419fba47c8896c7f1aff61d571202190b1.tar.gz
ports-a73b45419fba47c8896c7f1aff61d571202190b1.zip
Notes
Diffstat (limited to 'www/galeon/Makefile')
-rw-r--r--www/galeon/Makefile13
1 files changed, 4 insertions, 9 deletions
diff --git a/www/galeon/Makefile b/www/galeon/Makefile
index 8facb362bc66..5287fd82d320 100644
--- a/www/galeon/Makefile
+++ b/www/galeon/Makefile
@@ -6,8 +6,7 @@
#
PORTNAME= galeon
-PORTVERSION= 1.2.12
-PORTREVISION= 2
+PORTVERSION= 1.2.13
CATEGORIES= www gnome
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
MASTER_SITE_SUBDIR= ${PORTNAME}
@@ -20,7 +19,7 @@ BUILD_DEPENDS= ${X11BASE}/include/mozilla${HEADERS_SUFX}/gtkembedmoz/gtkmozembed
LIB_DEPENDS= iconv.3:${PORTSDIR}/converters/libiconv
RUN_DEPENDS= ${X11BASE}/lib/${MOZILLA}/libgtkembedmoz.so:${PORTSDIR}/www/${MOZILLA}
-MOZ_CONFIGURE_ARGS=--with-mozilla-snapshot="trunk"
+MOZ_CONFIGURE_ARGS=--with-mozilla-snapshot="1.5"
.if !defined(WITH_MOZILLA)
MOZILLA= mozilla
@@ -29,7 +28,7 @@ HEADERS_SUFX=
.if ${WITH_MOZILLA}=="mozilla-devel"
MOZILLA= ${WITH_MOZILLA}
HEADERS_SUFX= -devel
-MOZ_CONFIGURE_ARGS= --with-mozilla-snapshot="1.5b"
+MOZ_CONFIGURE_ARGS= --with-mozilla-snapshot="1.6a"
.else
MOZILLA= mozilla
HEADERS_SUFX=
@@ -37,7 +36,7 @@ HEADERS_SUFX=
.endif
USE_X_PREFIX= yes
-USE_GNOME= gnomeprefix gnomehack bonobo libglade gnomevfs
+USE_GNOME= gnomeprefix gnomehack bonobo libglade gnomevfs gnometarget
USE_GMAKE= yes
USE_LIBTOOL= yes
USE_REINPLACE= yes
@@ -55,11 +54,7 @@ CONFLICTS= galeon2-*
.include <bsd.port.pre.mk>
-.if ${OSVERSION} > 500000
-# Galeon does not build correctly in -CURRENT if -Werror is passed
-# to the compiler.
NO_WERROR= yes
-.endif
# allow build with more warnings enabled
.if defined(NO_WERROR)
CONFIGURE_ARGS+= --disable-werror