aboutsummaryrefslogtreecommitdiff
path: root/www/galeon/Makefile
diff options
context:
space:
mode:
authorMichael Johnson <ahze@FreeBSD.org>2004-11-09 23:44:00 +0000
committerMichael Johnson <ahze@FreeBSD.org>2004-11-09 23:44:00 +0000
commit56375a50f5916779a07f35e453d88b3cf0144b68 (patch)
tree0083de9489ba86606a6f2da4e13c7f992e1bc538 /www/galeon/Makefile
parentf8f27743a80e1a1f38a3751e764862178fa80daa (diff)
downloadports-56375a50f5916779a07f35e453d88b3cf0144b68.tar.gz
ports-56375a50f5916779a07f35e453d88b3cf0144b68.zip
Notes
Diffstat (limited to 'www/galeon/Makefile')
-rw-r--r--www/galeon/Makefile87
1 files changed, 60 insertions, 27 deletions
diff --git a/www/galeon/Makefile b/www/galeon/Makefile
index a66c34ef2206..81efa5c95e43 100644
--- a/www/galeon/Makefile
+++ b/www/galeon/Makefile
@@ -6,33 +6,45 @@
#
PORTNAME= galeon
-PORTVERSION= 1.2.14
+PORTVERSION= 1.3.18
PORTREVISION= 1
CATEGORIES= www gnome
-MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
-MASTER_SITE_SUBDIR= ${PORTNAME}
+MASTER_SITES= ${MASTER_SITE_SOURCEFORGE} \
+ http://osdn.dl.sourceforge.net/sourceforge/galeon/
+MASTER_SITE_SUBDIR= ${PORTNAME:S/2$//}
-MAINTAINER= gnome@FreeBSD.org
-COMMENT= A GNOME Web browser based on gecko (the Mozilla rendering engine)
+MAINTAINER= gnome@freebsd.org
+COMMENT= A GNOME 2 Web browser based on gecko (the Mozilla rendering engine)
-BUILD_DEPENDS= ${X11BASE}/lib/${MOZILLA}/libgtkembedmoz.so:${PORTSDIR}/www/${MOZILLA}
-RUN_DEPENDS= ${X11BASE}/lib/${MOZILLA}/libgtkembedmoz.so:${PORTSDIR}/www/${MOZILLA}
+BUILD_DEPENDS= ${X11BASE}/lib/${MOZILLA}/components/libwidget_gtk2.so:${PORTSDIR}/www/${MOZILLA}
+RUN_DEPENDS= ${X11BASE}/lib/${MOZILLA}/components/libwidget_gtk2.so:${PORTSDIR}/www/${MOZILLA}
-MOZ_CONFIGURE_ARGS=--with-mozilla-snapshot="1.7"
+MOZILLA= mozilla
+HEADERS_SUFX=
-MOZILLA= mozilla-gtk1
-HEADERS_SUFX= -gtk1
+.if !defined(WITH_MOZILLA)
+MOZILLA= mozilla
+HEADERS_SUFX=
+.else
+.if ${WITH_MOZILLA}=="mozilla-devel" || ${WITH_MOZILLA}=="mozilla-devel-gtk2"
+MOZILLA= mozilla-devel
+HEADERS_SUFX= -devel
+.else
+MOZILLA= mozilla
+HEADERS_SUFX=
+.endif
+.endif
+WRKSRC= ${WRKDIR}/${PORTNAME:S/2$//}-${PORTVERSION:S/a$//}
+USE_BZIP2= yes
USE_X_PREFIX= yes
-USE_GNOME= gnomeprefix intlhack gnomehack bonobo libglade gnomevfs \
- gnometarget
+USE_GNOME= gnomeprefix intlhack gnomehack libgnomeui desktopfileutils
+USE_LIBTOOL_VER=15
USE_GMAKE= yes
-USE_ICONV= yes
-USE_LIBTOOL_VER=13
USE_REINPLACE= yes
CONFIGURE_ARGS= --with-mozilla-includes="${X11BASE}/include/mozilla${HEADERS_SUFX}" \
--with-mozilla-libs="${X11BASE}/lib/${MOZILLA}" \
- ${MOZ_CONFIGURE_ARGS}
+ --enable-nautilus-view=no
CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include -I${X11BASE}/include ${PTHREAD_CFLAGS}" \
LIBS="-L${LOCALBASE}/lib ${PTHREAD_LIBS}"
@@ -40,33 +52,54 @@ MAN1= galeon.1
FLASHPLAYER= ${LOCALBASE}/lib/libflashplayer.so.1
-CONFLICTS= galeon2-*
+CONFLICTS= galeon-[0-9]*
.include <bsd.port.pre.mk>
+.if ${OSVERSION} > 500000
+# Galeon does not build correctly in -CURRENT if -Werror is passed
+# to the compiler.
NO_WERROR= yes
+.endif
# allow build with more warnings enabled
.if defined(NO_WERROR)
CONFIGURE_ARGS+= --disable-werror
.endif
+pre-everything::
+ @${ECHO_MSG} ""
+ @${ECHO_MSG} " By default the port uses www/mozilla for html rendering, but you can"
+ @${ECHO_MSG} " change this by defining WITH_MOZILLA to one of the following values:"
+ @${ECHO_MSG}
+ @${ECHO_MSG} " mozilla-devel "
+ @${ECHO_MSG} ""
+
post-patch:
- @${REINPLACE_CMD} -e 's|%%PTHREAD_CFLAGS%%|${PTHREAD_CFLAGS}|' \
- -e 's|%%PTHREAD_LIBS%%|${PTHREAD_LIBS}|' \
- ${WRKSRC}/configure
+ @${REINPLACE_CMD} -e 's|mozilla-gtkmozembed|mozilla-gtkmozembed${HEADERS_SUFX}|g ; \
+ s|mozilla-xpcom|mozilla-xpcom${HEADERS_SUFX}|g ; \
+ s|$$MOZILLA-gtkmozembed|$$MOZILLA-gtkmozembed${HEADERS_SUFX}|g ; \
+ s|$$MOZILLA-xpcom|$$MOZILLA-xpcom${HEADERS_SUFX}|g' \
+ ${WRKSRC}/configure
+ @${FIND} ${WRKSRC} -name "Makefile.in*" | ${XARGS} ${REINPLACE_CMD} -e \
+ 's|-lpthread|${PTHREAD_LIBS}|g'
@${FIND} ${WRKSRC} -name "*.cpp" | ${XARGS} ${REINPLACE_CMD} -e \
's|malloc\.h|stdlib.h|g'
- @${MKDIR} ${WRKSRC}/src/libnautilus
+ @${REINPLACE_CMD} -e 's|@prefix@/@DATADIRNAME@|@datadir@|g' \
+ ${WRKSRC}/ui/galeon-bookmarks-editor-ui.xml.in
post-configure:
- @${REINPLACE_CMD} -e 's|%%PREFIX%%|${PREFIX}|g ; \
- s|%%LOCALBASE%%|${LOCALBASE}|g ; \
- s|%%X11BASE%%|${X11BASE}|g ; \
- s|%%FLASHPLAYER%%|${FLASHPLAYER}|g ; \
- s|%%MOZILLA%%|${MOZILLA}|g' ${WRKSRC}/src/galeon \
- ${WRKSRC}/src/nautstub.c
+ @${SED} -e 's|%%PREFIX%%|${PREFIX}|g ; \
+ s|%%LOCALBASE%%|${LOCALBASE}|g ; \
+ s|%%X11BASE%%|${X11BASE}|g ; \
+ s|%%MOZILLA%%|${MOZILLA}|g ; \
+ s|%%FLASHPLAYER%%|${FLASHPLAYER}|g' < ${FILESDIR}/galeon \
+ > ${WRKDIR}/galeon
pre-install:
- @-${X11BASE}/bin/gconftool --shutdown
+ @-${X11BASE}/bin/gconftool-2 --shutdown
+
+post-install:
+ @${MV} -f ${PREFIX}/bin/galeon ${PREFIX}/bin/galeon-bin
+ ${INSTALL_SCRIPT} ${WRKDIR}/galeon ${PREFIX}/bin
.include <bsd.port.post.mk>