aboutsummaryrefslogtreecommitdiff
path: root/www/galeon
diff options
context:
space:
mode:
authorJoe Marcus Clarke <marcus@FreeBSD.org>2008-07-06 19:32:08 +0000
committerJoe Marcus Clarke <marcus@FreeBSD.org>2008-07-06 19:32:08 +0000
commitd58734c674a7a29bb31d9251511220475dd39344 (patch)
tree021ede46da359c5b85a6918a2a5031bfab99ecae /www/galeon
parentc7a472121daa5ba3924b668e86f1a2b428f6cbaf (diff)
downloadports-d58734c674a7a29bb31d9251511220475dd39344.tar.gz
ports-d58734c674a7a29bb31d9251511220475dd39344.zip
Notes
Diffstat (limited to 'www/galeon')
-rw-r--r--www/galeon/Makefile14
-rw-r--r--www/galeon/distinfo6
-rw-r--r--www/galeon/files/patch-configure11
3 files changed, 23 insertions, 8 deletions
diff --git a/www/galeon/Makefile b/www/galeon/Makefile
index b7e3339a23b0..225aac5f9d8e 100644
--- a/www/galeon/Makefile
+++ b/www/galeon/Makefile
@@ -7,8 +7,7 @@
#
PORTNAME= galeon
-PORTVERSION= 2.0.5
-PORTREVISION= 2
+PORTVERSION= 2.0.6
CATEGORIES= www gnome
MASTER_SITES= SF
MASTER_SITE_SUBDIR= ${PORTNAME:S/2$//}
@@ -16,7 +15,7 @@ MASTER_SITE_SUBDIR= ${PORTNAME:S/2$//}
MAINTAINER= gnome@FreeBSD.org
COMMENT= A GNOME 2 Web browser based on gecko (the Mozilla rendering engine)
-USE_GECKO= firefox mozilla seamonkey xulrunner
+USE_GECKO= firefox mozilla seamonkey xulrunner firefox3
WRKSRC= ${WRKDIR}/${PORTNAME:S/2$//}-${PORTVERSION:S/a$//}
USE_BZIP2= yes
INSTALLS_OMF= yes
@@ -25,8 +24,7 @@ USE_GNOME= gnomeprefix intlhack gnomehack libgnomeui desktopfileutils \
GNU_CONFIGURE= yes
USE_GMAKE= yes
USE_GETTEXT= yes
-CONFIGURE_ARGS= --enable-nautilus-view=no \
- --with-mozilla=${GECKO}
+CONFIGURE_ARGS= --enable-nautilus-view=no
CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include ${PTHREAD_CFLAGS}" \
LIBS="-L${LOCALBASE}/lib ${PTHREAD_LIBS}"
@@ -45,6 +43,12 @@ NO_WERROR= yes
CONFIGURE_ARGS+= --disable-werror
.endif
+.if ${GECKO}=="firefox3"
+CONFIGURE_ARGS+= --with-mozilla=firefox
+.else
+CONFIGURE_ARGS+= --with-mozilla=${GECKO}
+.endif
+
post-patch:
@${FIND} ${WRKSRC} -name "Makefile.in*" | ${XARGS} ${REINPLACE_CMD} -e \
's|-lpthread|${PTHREAD_LIBS}|g'
diff --git a/www/galeon/distinfo b/www/galeon/distinfo
index 8a78dbf55c8f..e205a6789f79 100644
--- a/www/galeon/distinfo
+++ b/www/galeon/distinfo
@@ -1,3 +1,3 @@
-MD5 (galeon-2.0.5.tar.bz2) = bbddb89ad1ba08a62e03bceab5a38d93
-SHA256 (galeon-2.0.5.tar.bz2) = c390e93ef8cd911db8d6f66d0ef98f7e7c2a84d5705e4c76a79b082277ae367a
-SIZE (galeon-2.0.5.tar.bz2) = 3098535
+MD5 (galeon-2.0.6.tar.bz2) = 7723816d29edac94945e5fd9a2a402f8
+SHA256 (galeon-2.0.6.tar.bz2) = 266f5eb1675c704f31c63d14cb89e1f16c96e53f6256d961026bc816d0d95210
+SIZE (galeon-2.0.6.tar.bz2) = 3094830
diff --git a/www/galeon/files/patch-configure b/www/galeon/files/patch-configure
new file mode 100644
index 000000000000..89f6d121a693
--- /dev/null
+++ b/www/galeon/files/patch-configure
@@ -0,0 +1,11 @@
+--- configure.orig 2008-07-06 15:07:05.000000000 -0400
++++ configure 2008-07-06 15:07:13.000000000 -0400
+@@ -23281,7 +23281,7 @@ if test $MOZILLA = libxul-embedding-unst
+ MOZILLA_GTKMOZEMBED=$MOZILLA
+ else
+ MOZILLA_XPCOM=$MOZILLA-xpcom
+- MOZILLA_XPCOM=$MOZILLA-gtkmozembed
++ MOZILLA_GTKMOZEMBED=$MOZILLA-gtkmozembed
+ fi
+
+ pkg_failed=no