aboutsummaryrefslogtreecommitdiff
path: root/www/galeon
diff options
context:
space:
mode:
authorJeremy Messenger <mezz@FreeBSD.org>2008-08-06 16:26:18 +0000
committerJeremy Messenger <mezz@FreeBSD.org>2008-08-06 16:26:18 +0000
commit61d98836222f2de644954142467c27ac2b20f8f3 (patch)
treebf26f4462e74d343e2b01e37a0b767bd4fb47e1f /www/galeon
parent3a3b8cad2b2ce67bcd2efd9ca14a77bd491726af (diff)
downloadports-61d98836222f2de644954142467c27ac2b20f8f3.tar.gz
ports-61d98836222f2de644954142467c27ac2b20f8f3.zip
Notes
Diffstat (limited to 'www/galeon')
-rw-r--r--www/galeon/Makefile11
1 files changed, 3 insertions, 8 deletions
diff --git a/www/galeon/Makefile b/www/galeon/Makefile
index 225aac5f9d8e..570f4d4afe95 100644
--- a/www/galeon/Makefile
+++ b/www/galeon/Makefile
@@ -15,7 +15,7 @@ MASTER_SITE_SUBDIR= ${PORTNAME:S/2$//}
MAINTAINER= gnome@FreeBSD.org
COMMENT= A GNOME 2 Web browser based on gecko (the Mozilla rendering engine)
-USE_GECKO= firefox mozilla seamonkey xulrunner firefox3
+USE_GECKO= firefox mozilla seamonkey xulrunner
WRKSRC= ${WRKDIR}/${PORTNAME:S/2$//}-${PORTVERSION:S/a$//}
USE_BZIP2= yes
INSTALLS_OMF= yes
@@ -24,7 +24,8 @@ USE_GNOME= gnomeprefix intlhack gnomehack libgnomeui desktopfileutils \
GNU_CONFIGURE= yes
USE_GMAKE= yes
USE_GETTEXT= yes
-CONFIGURE_ARGS= --enable-nautilus-view=no
+CONFIGURE_ARGS= --enable-nautilus-view=no \
+ --with-mozilla=${GECKO}
CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include ${PTHREAD_CFLAGS}" \
LIBS="-L${LOCALBASE}/lib ${PTHREAD_LIBS}"
@@ -43,12 +44,6 @@ NO_WERROR= yes
CONFIGURE_ARGS+= --disable-werror
.endif
-.if ${GECKO}=="firefox3"
-CONFIGURE_ARGS+= --with-mozilla=firefox
-.else
-CONFIGURE_ARGS+= --with-mozilla=${GECKO}
-.endif
-
post-patch:
@${FIND} ${WRKSRC} -name "Makefile.in*" | ${XARGS} ${REINPLACE_CMD} -e \
's|-lpthread|${PTHREAD_LIBS}|g'