aboutsummaryrefslogtreecommitdiff
path: root/www/gallery2
diff options
context:
space:
mode:
authorSunpoet Po-Chuan Hsieh <sunpoet@FreeBSD.org>2019-01-19 20:31:59 +0000
committerSunpoet Po-Chuan Hsieh <sunpoet@FreeBSD.org>2019-01-19 20:31:59 +0000
commit0f982355a6fd6470dded45fe482964b594491d11 (patch)
tree91ead6d0f3a5c706da1e2516630decfd2a6b12d5 /www/gallery2
parent99255be0a15666885445be58b55b6cd383027999 (diff)
downloadports-0f982355a6fd6470dded45fe482964b594491d11.tar.gz
ports-0f982355a6fd6470dded45fe482964b594491d11.zip
Notes
Diffstat (limited to 'www/gallery2')
-rw-r--r--www/gallery2/Makefile2
-rw-r--r--www/gallery2/files/patch-lib-adodb-adodb-time.inc.php12
-rw-r--r--www/gallery2/files/patch-modules-core-classes-GalleryStorage-GalleryStorageExtras.class13
3 files changed, 26 insertions, 1 deletions
diff --git a/www/gallery2/Makefile b/www/gallery2/Makefile
index f51a9230d95a..80cdaae44fa5 100644
--- a/www/gallery2/Makefile
+++ b/www/gallery2/Makefile
@@ -3,7 +3,7 @@
PORTNAME= gallery2
PORTVERSION= 2.3.2
-PORTREVISION= 9
+PORTREVISION= 10
CATEGORIES= www
MASTER_SITES= SF/gallery/${PORTNAME}/${PORTVERSION}
DISTNAME= gallery-${PORTVERSION}-full
diff --git a/www/gallery2/files/patch-lib-adodb-adodb-time.inc.php b/www/gallery2/files/patch-lib-adodb-adodb-time.inc.php
new file mode 100644
index 000000000000..4aecb014650e
--- /dev/null
+++ b/www/gallery2/files/patch-lib-adodb-adodb-time.inc.php
@@ -0,0 +1,12 @@
+Obtained from: https://github.com/bobosch/gallery2/commit/4ddfafa416ffe5babd95f2a6532742c3ec903275
+
+--- lib/adodb/adodb-time.inc.php.orig
++++ lib/adodb/adodb-time.inc.php
+@@ -1006,7 +1006,6 @@ function adodb_tz_offset($gmt,$isphp5)
+ return sprintf('%s%02d%02d',($gmt<=0)?'+':'-',floor($zhrs),($zhrs-$hrs)*60);
+ else
+ return sprintf('%s%02d%02d',($gmt<0)?'+':'-',floor($zhrs),($zhrs-$hrs)*60);
+- break;
+ }
+
+
diff --git a/www/gallery2/files/patch-modules-core-classes-GalleryStorage-GalleryStorageExtras.class b/www/gallery2/files/patch-modules-core-classes-GalleryStorage-GalleryStorageExtras.class
new file mode 100644
index 000000000000..0c6de68305d3
--- /dev/null
+++ b/www/gallery2/files/patch-modules-core-classes-GalleryStorage-GalleryStorageExtras.class
@@ -0,0 +1,13 @@
+Obtained from: https://github.com/bobosch/gallery2/commit/4fc50203a12b78217999df00759d70d283efce2f
+
+--- modules/core/classes/GalleryStorage/GalleryStorageExtras.class.orig
++++ modules/core/classes/GalleryStorage/GalleryStorageExtras.class
+@@ -190,7 +190,7 @@ class GalleryStorageExtras /* the other half of GalleryStorage */ {
+ $value = $this->_gs->_normalizeValue($row[$i], $memberData[$i], true);
+
+ /* Store the value in the object */
+- $entity->$callbacks[$i] = $value;
++ $entity->{$callbacks[$i]} = $value;
+ $entity->_persistentStatus['originalValue'][$callbacks[$i]] = $value;
+ }
+