aboutsummaryrefslogtreecommitdiff
path: root/www/gallery3
diff options
context:
space:
mode:
authorBeech Rintoul <beech@FreeBSD.org>2007-09-04 08:01:04 +0000
committerBeech Rintoul <beech@FreeBSD.org>2007-09-04 08:01:04 +0000
commit4adcf7c2ce996c3490760e0578b77beb978cff05 (patch)
treeb9af8d40e3a6724029dfac8ed7ce3f02e58cc3d3 /www/gallery3
parent8ca6968b7fd5f30953ed26a0123c11d84c4e2282 (diff)
downloadports-4adcf7c2ce996c3490760e0578b77beb978cff05.tar.gz
ports-4adcf7c2ce996c3490760e0578b77beb978cff05.zip
Notes
Diffstat (limited to 'www/gallery3')
-rw-r--r--www/gallery3/Makefile78
-rw-r--r--www/gallery3/distinfo6
-rw-r--r--www/gallery3/files/pkg-message.in5
3 files changed, 44 insertions, 45 deletions
diff --git a/www/gallery3/Makefile b/www/gallery3/Makefile
index 35ac74a05959..8c01f903262f 100644
--- a/www/gallery3/Makefile
+++ b/www/gallery3/Makefile
@@ -1,44 +1,41 @@
-# New ports collection makefile for: gallery2
-# Date created: 29 Aug 2005
-# Whom: Alex Varju <freebsd-ports@varju.ca>
+# New ports collection makefile for: gallery2
+# Date created: 29 Aug 2005
+# Whom: Alex Varju <freebsd-ports@varju.ca>
#
# $FreeBSD$
#
PORTNAME= gallery2
-PORTVERSION= 2.2.2
-PORTREVISION= 1
+PORTVERSION= 2.2.3
CATEGORIES= www
-MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
+MASTER_SITES= SF
MASTER_SITE_SUBDIR= gallery
-DISTNAME= gallery-2.2.2-full
+DISTNAME= gallery-${PORTVERSION}-full
DIST_SUBDIR= gallery2
MAINTAINER= freebsd-ports@varju.ca
-COMMENT= Gallery is a web based photo album written using PHP
+COMMENT= Web based photo album organizer written in PHP
USE_PHP= pcre session
WANT_PHP_WEB= yes
-WRKSRC= ${WRKDIR}/${DIST_SUBDIR}
+WRKSRC= ${WRKDIR}/${PORTNAME}
NO_BUILD= yes
-CPIOARGS= --quiet -pdum -R
-PKGMESSAGE= ${WRKDIR}/pkg-message
SUB_FILES= pkg-message
-SUB_LIST+= WWWDIR_REL=${WWWDIR_REL}
-
-# Note that USE_PHP must be set before bsd.port.pre.mk is included, so
-# OPTIONS can't be used right now without making portlint angry
-#OPTIONS= NETPBM "Enable netpbm support" off \
-# IMAGEMAGICK "Enable imagemagick support" on \
-# GRAPHICSMAGICK "Use graphicsmagick instead of imagemagick" off \
-# PGSQL "Use PostgreSQL instead of MySQL" off \
-# JHEAD "Enable jhead support" on \
-# UNZIP "Enable unzip support" on \
-# GD "Enable gd support" off \
-# DCRAW "Enable dcraw support" off \
-# FFMPEG "Enable ffmpeg support" off
+
+OPTIONS= NETPBM "Enable netpbm support" off \
+ IMAGEMAGICK "Enable imagemagick support" on \
+ GRAPHMAGICK "Enable graphicsmagick support" off \
+ PGSQL "Use PostgreSQL instead of MySQL" off \
+ JHEAD "Enable jhead support" on \
+ UNZIP "Enable unzip support" on \
+ GD "Enable gd support" off \
+ DCRAW "Enable dcraw support" off \
+ FFMPEG "Enable ffmpeg support" off \
+ NLS "Enable National Language Support" on
+
+.include <bsd.port.pre.mk>
.if defined(WITH_PGSQL)
USE_PHP+= pgsql
@@ -49,50 +46,49 @@ USE_PHP+= mysql
USE_PHP+= gd
RUN_DEPENDS+= pngtogd:${PORTSDIR}/graphics/gd
.endif
-.if !defined(WITHOUT_NLS)
+.if defined(WITH_NLS)
USE_PHP+= gettext
+USE_GETTEXT= yes # Pet portlint
.endif
-.include <bsd.port.pre.mk>
-
.if defined(WITH_NETPBM)
RUN_DEPENDS+= giftopnm:${PORTSDIR}/graphics/netpbm
.endif
-.if defined(WITH_GRAPHICSMAGICK)
-RUN_DEPENDS+= GraphicsMagick.1:${PORTSDIR}/graphics/GraphicsMagick
-.elif !defined(WITHOUT_IMAGEMAGICK)
+.if defined(WITH_GRAPHMAGICK)
+RUN_DEPENDS+= gm:${PORTSDIR}/graphics/GraphicsMagick
+.endif
+
+.if defined(WITH_IMAGEMAGICK)
RUN_DEPENDS+= convert:${PORTSDIR}/graphics/ImageMagick
.endif
-.if !defined(WITHOUT_JHEAD)
+.if defined(WITH_JHEAD)
RUN_DEPENDS+= jhead:${PORTSDIR}/graphics/jhead
.endif
-.if !defined(WITHOUT_UNZIP)
+
+.if defined(WITH_UNZIP)
RUN_DEPENDS+= unzip:${PORTSDIR}/archivers/unzip
.endif
+
.if defined(WITH_FFMPEG)
LIB_DEPENDS+= avcodec.1:${PORTSDIR}/multimedia/ffmpeg
+
.endif
.if defined(WITH_DCRAW)
RUN_DEPENDS+= dcraw:${PORTSDIR}/graphics/dcraw
.endif
-pre-everything::
.if defined(GALLERY2DIR)
+# Continue to support legacy GALLERY2DIR variable
WWWDIR= ${GALLERY2DIR}
-.else
- @${ECHO_MSG} ""
- @${ECHO_MSG} "Define GALLERY2DIR to override default of ${WWWDIR}."
- @${ECHO_MSG} ""
.endif
do-install:
- @ ${MKDIR} -m 0755 ${WWWDIR}
- @ cd ${WRKSRC} && ${FIND} * -print | ${CPIO} ${CPIOARGS} ${WWWOWN}:${WWWGRP} ${WWWDIR}
- @ ${CHOWN} ${WWWOWN}:${WWWGRP} ${WWWDIR}
+ @cd ${WRKSRC}/&&${COPYTREE_SHARE} . ${WWWDIR}/
+ @ ${CHOWN} -R ${WWWOWN}:${WWWGRP} ${WWWDIR}/
+ @${ECHO_CMD} '@exec ${CHOWN} -R ${WWWOWN}:${WWWGRP} ${WWWDIR}' >> ${TMPPLIST}
-post-install:
.if !defined(BATCH)
@ ${CAT} ${PKGMESSAGE}
.endif
diff --git a/www/gallery3/distinfo b/www/gallery3/distinfo
index de803f3b35e2..2dc758b3852d 100644
--- a/www/gallery3/distinfo
+++ b/www/gallery3/distinfo
@@ -1,3 +1,3 @@
-MD5 (gallery2/gallery-2.2.2-full.tar.gz) = 488d7837d531e99d4b5f420150b792d9
-SHA256 (gallery2/gallery-2.2.2-full.tar.gz) = 521b4d77e6ad21591229c8bd2769a9889052835cbcbe720e0b9abd2820431ac2
-SIZE (gallery2/gallery-2.2.2-full.tar.gz) = 11900129
+MD5 (gallery2/gallery-2.2.3-full.tar.gz) = df5c1a6ecbf0b498417ceffc66fe5f3b
+SHA256 (gallery2/gallery-2.2.3-full.tar.gz) = ce7d9c1c4497954e1828047be25b31c3a271b5c86c0c97bbc652b3746aa1b364
+SIZE (gallery2/gallery-2.2.3-full.tar.gz) = 11901089
diff --git a/www/gallery3/files/pkg-message.in b/www/gallery3/files/pkg-message.in
index 2e18579cb631..ef723a80d58a 100644
--- a/www/gallery3/files/pkg-message.in
+++ b/www/gallery3/files/pkg-message.in
@@ -16,12 +16,15 @@ If you are using MySQL, here's the short version of the instructions:
You will also need to configure Apache. Consider adding the following
to your httpd.conf:
+ Alias /gallery2 "%%WWWDIR%%"
+
<Directory "%%WWWDIR%%">
AllowOverride Options FileInfo
+ Allow from all
</Directory>
Then restart Apache: 'apachectl graceful'
-Please visit 'http://{host.domain}/%%WWWDIR_REL%%/' in a
+Please visit 'http://{host.domain}/gallery2/' in a
web-browser and follow the configuration instructions.
*****************************************************************