aboutsummaryrefslogtreecommitdiff
path: root/www/gatling/Makefile
diff options
context:
space:
mode:
authorAlex Dupre <ale@FreeBSD.org>2004-02-23 00:21:00 +0000
committerAlex Dupre <ale@FreeBSD.org>2004-02-23 00:21:00 +0000
commitcd86d94aaf0ff3a8009d8123068aa4d550a09213 (patch)
tree84b154336ac056f278c57ee2a8babe5b0a1028e2 /www/gatling/Makefile
parent1716e01c067560f33847012d6657ab7c4aceab5f (diff)
downloadports-cd86d94aaf0ff3a8009d8123068aa4d550a09213.tar.gz
ports-cd86d94aaf0ff3a8009d8123068aa4d550a09213.zip
Notes
Diffstat (limited to 'www/gatling/Makefile')
-rw-r--r--www/gatling/Makefile53
1 files changed, 53 insertions, 0 deletions
diff --git a/www/gatling/Makefile b/www/gatling/Makefile
new file mode 100644
index 000000000000..c05eb234f7a6
--- /dev/null
+++ b/www/gatling/Makefile
@@ -0,0 +1,53 @@
+# Ports collection Makefile for: gatling
+# Date created: Feb 21, 2004
+# Whom: Thomas-Martin Seck <tmseck@netcologne.de>
+#
+# $FreeBSD$
+#
+
+PORTNAME= gatling
+PORTVERSION= 0.4
+CATEGORIES= www benchmarks
+MASTER_SITES= http://dl.fefe.de/
+
+MAINTAINER= tmseck@netcologne.de
+COMMENT= A high performance webserver with scalability benchmark tools
+
+BUILD_DEPENDS= ${LOCALBASE}/lib/libowfat.a:${PORTSDIR}/devel/libowfat
+
+USE_BZIP2= yes
+
+MAKE_ENV+= LDFLAGS="-L${LOCALBASE}/lib -lowfat" \
+ PTHREAD_LIBS="${PTHREAD_LIBS}"
+
+bin= dl gatling
+examples= run-gatling
+examplesdir= ${EXAMPLESDIR:S,^${PREFIX}/,,}
+PORTDOCS= CHANGES README README.ftp README.http README.performance \
+ README.prefetch
+
+OPTIONS= BENCHMARKS "Install system benchmark programs" on
+
+.include <bsd.port.pre.mk>
+
+.if !defined(WITHOUT_BENCHMARKS)
+PORTDOCS+= README.bindbench README.forkbench README.httpbench \
+ README.manymapbench README.mmapbench
+bin+= bindbench forkbench forksbench httpbench ioerr manymapbench \
+ mktestdata mmapbench pthreadbench
+examples+= prep run-bench
+.endif
+
+PLIST_DIRS= ${examplesdir}
+PLIST_FILES= ${bin:S,^,bin/,} ${examples:S,^,${examplesdir}/,}
+
+do-install:
+ cd ${WRKSRC} && ${INSTALL_PROGRAM} ${bin} ${PREFIX}/bin
+ ${MKDIR} ${EXAMPLESDIR}
+ cd ${WRKSRC} && ${INSTALL_SCRIPT} ${examples} ${EXAMPLESDIR}
+.if !defined(NOPORTDOCS)
+ ${MKDIR} ${DOCSDIR}
+ cd ${WRKSRC} && ${INSTALL_DATA} ${PORTDOCS} ${DOCSDIR}
+.endif
+
+.include <bsd.port.post.mk>