aboutsummaryrefslogtreecommitdiff
path: root/www/gatling
diff options
context:
space:
mode:
authorMartin Wilke <miwi@FreeBSD.org>2007-01-15 20:07:15 +0000
committerMartin Wilke <miwi@FreeBSD.org>2007-01-15 20:07:15 +0000
commit2edf586a96a4b8f89ecf104e9ea0e3abd1c733af (patch)
tree274c32397b0ba79711175a232dc20b94215421e0 /www/gatling
parent136339834fc486a4fe6d3e591145f6ccfef244a8 (diff)
downloadports-2edf586a96a4b8f89ecf104e9ea0e3abd1c733af.tar.gz
ports-2edf586a96a4b8f89ecf104e9ea0e3abd1c733af.zip
Notes
Diffstat (limited to 'www/gatling')
-rw-r--r--www/gatling/Makefile3
-rw-r--r--www/gatling/files/patch-dl.c11
-rw-r--r--www/gatling/files/patch-gatling.c47
3 files changed, 60 insertions, 1 deletions
diff --git a/www/gatling/Makefile b/www/gatling/Makefile
index 0a3e500e7aef..9d4ab68c669e 100644
--- a/www/gatling/Makefile
+++ b/www/gatling/Makefile
@@ -7,13 +7,14 @@
PORTNAME= gatling
PORTVERSION= 0.8
+PORTREVISION= 1
CATEGORIES= www benchmarks ftp ipv6
MASTER_SITES= http://dl.fefe.de/
MAINTAINER= tmseck@netcologne.de
COMMENT= A high performance webserver with scalability benchmark tools
-BUILD_DEPENDS= ${LOCALBASE}/lib/libowfat.a:${PORTSDIR}/devel/libowfat
+BUILD_DEPENDS= libowfat>=0.25:${PORTSDIR}/devel/libowfat
USE_BZIP2= yes
USE_GMAKE= yes
diff --git a/www/gatling/files/patch-dl.c b/www/gatling/files/patch-dl.c
new file mode 100644
index 000000000000..857525214359
--- /dev/null
+++ b/www/gatling/files/patch-dl.c
@@ -0,0 +1,11 @@
+--- dl.c.orig Sat Jan 13 15:30:02 2007
++++ dl.c Sat Jan 13 15:36:34 2007
+@@ -188,7 +188,7 @@ static inline int issafe(unsigned char c
+ return (c!='"' && c>=' ' && c!='+');
+ }
+
+-unsigned long fmt_urlencoded(char* dest,const char* src,unsigned long len) {
++size_t fmt_urlencoded(char* dest,const char* src,size_t len) {
+ register const unsigned char* s=(const unsigned char*) src;
+ unsigned long written=0,i;
+ for (i=0; i<len; ++i) {
diff --git a/www/gatling/files/patch-gatling.c b/www/gatling/files/patch-gatling.c
new file mode 100644
index 000000000000..90e453213142
--- /dev/null
+++ b/www/gatling/files/patch-gatling.c
@@ -0,0 +1,47 @@
+--- gatling.c.orig Sat Jan 13 15:37:09 2007
++++ gatling.c Sat Jan 13 15:47:04 2007
+@@ -865,7 +865,7 @@ static inline int issafe(unsigned char c
+ return (c!='"' && c!='%' && c>=' ' && c!='+');
+ }
+
+-unsigned long fmt_urlencoded(char* dest,const char* src,unsigned long len) {
++size_t fmt_urlencoded(char* dest,const char* src,size_t len) {
+ register const unsigned char* s=(const unsigned char*) src;
+ unsigned long written=0,i;
+ for (i=0; i<len; ++i) {
+@@ -1011,7 +1011,7 @@ username2:password2
+ * authentication was OK or -1 if authentication is needed (the HTTP
+ * response was then already written to the iob). */
+ int http_dohtaccess(struct http_data* h) {
+- unsigned long filesize;
++ size_t filesize;
+ char* map;
+ char* s;
+ char* auth;
+@@ -1031,7 +1031,7 @@ int http_dohtaccess(struct http_data* h)
+ char* username,* password;
+ char* decoded;
+ int i;
+- unsigned long l,dl,ul;
++ size_t l,dl,ul;
+ auth+=6;
+ while (*auth==' ' || *auth=='\t') ++auth;
+ i=str_chr(auth,'\n');
+@@ -1103,7 +1103,7 @@ int64 http_openfile(struct http_data* h,
+ char* dir=0;
+ char* s;
+ char* args;
+- unsigned long i;
++ size_t i;
+ int64 fd;
+ int doesgzip,doesbzip2;
+
+@@ -2948,7 +2948,7 @@ void forkslave(int fd,buffer* in) {
+ j=str_chr(x,'\n'); if (j && x[j-1]=='\r') { --j; }
+ k=str_chr(x,' ');
+ if (k<j) {
+- unsigned long dl;
++ size_t dl;
+ remoteuser=alloca(20+k-j);
+ i=fmt_str(remoteuser,"REMOTE_USER=");
+ scan_base64(x+k+1,remoteuser+i,&dl);