aboutsummaryrefslogtreecommitdiff
path: root/www/gatling
diff options
context:
space:
mode:
authorAlex Dupre <ale@FreeBSD.org>2004-02-23 00:21:00 +0000
committerAlex Dupre <ale@FreeBSD.org>2004-02-23 00:21:00 +0000
commitcd86d94aaf0ff3a8009d8123068aa4d550a09213 (patch)
tree84b154336ac056f278c57ee2a8babe5b0a1028e2 /www/gatling
parent1716e01c067560f33847012d6657ab7c4aceab5f (diff)
downloadports-cd86d94aaf0ff3a8009d8123068aa4d550a09213.tar.gz
ports-cd86d94aaf0ff3a8009d8123068aa4d550a09213.zip
Add gatling 0.4, a high performance webserver with scalability benchmark
tools. PR: ports/63196 Submitted by: Thomas-Martin Seck <tmseck@netcologne.de>
Notes
Notes: svn path=/head/; revision=101778
Diffstat (limited to 'www/gatling')
-rw-r--r--www/gatling/Makefile53
-rw-r--r--www/gatling/distinfo2
-rw-r--r--www/gatling/files/patch-Makefile22
-rw-r--r--www/gatling/pkg-descr4
4 files changed, 81 insertions, 0 deletions
diff --git a/www/gatling/Makefile b/www/gatling/Makefile
new file mode 100644
index 000000000000..c05eb234f7a6
--- /dev/null
+++ b/www/gatling/Makefile
@@ -0,0 +1,53 @@
+# Ports collection Makefile for: gatling
+# Date created: Feb 21, 2004
+# Whom: Thomas-Martin Seck <tmseck@netcologne.de>
+#
+# $FreeBSD$
+#
+
+PORTNAME= gatling
+PORTVERSION= 0.4
+CATEGORIES= www benchmarks
+MASTER_SITES= http://dl.fefe.de/
+
+MAINTAINER= tmseck@netcologne.de
+COMMENT= A high performance webserver with scalability benchmark tools
+
+BUILD_DEPENDS= ${LOCALBASE}/lib/libowfat.a:${PORTSDIR}/devel/libowfat
+
+USE_BZIP2= yes
+
+MAKE_ENV+= LDFLAGS="-L${LOCALBASE}/lib -lowfat" \
+ PTHREAD_LIBS="${PTHREAD_LIBS}"
+
+bin= dl gatling
+examples= run-gatling
+examplesdir= ${EXAMPLESDIR:S,^${PREFIX}/,,}
+PORTDOCS= CHANGES README README.ftp README.http README.performance \
+ README.prefetch
+
+OPTIONS= BENCHMARKS "Install system benchmark programs" on
+
+.include <bsd.port.pre.mk>
+
+.if !defined(WITHOUT_BENCHMARKS)
+PORTDOCS+= README.bindbench README.forkbench README.httpbench \
+ README.manymapbench README.mmapbench
+bin+= bindbench forkbench forksbench httpbench ioerr manymapbench \
+ mktestdata mmapbench pthreadbench
+examples+= prep run-bench
+.endif
+
+PLIST_DIRS= ${examplesdir}
+PLIST_FILES= ${bin:S,^,bin/,} ${examples:S,^,${examplesdir}/,}
+
+do-install:
+ cd ${WRKSRC} && ${INSTALL_PROGRAM} ${bin} ${PREFIX}/bin
+ ${MKDIR} ${EXAMPLESDIR}
+ cd ${WRKSRC} && ${INSTALL_SCRIPT} ${examples} ${EXAMPLESDIR}
+.if !defined(NOPORTDOCS)
+ ${MKDIR} ${DOCSDIR}
+ cd ${WRKSRC} && ${INSTALL_DATA} ${PORTDOCS} ${DOCSDIR}
+.endif
+
+.include <bsd.port.post.mk>
diff --git a/www/gatling/distinfo b/www/gatling/distinfo
new file mode 100644
index 000000000000..9aceabc339c7
--- /dev/null
+++ b/www/gatling/distinfo
@@ -0,0 +1,2 @@
+MD5 (gatling-0.4.tar.bz2) = fcc8dffa24663205c0bb317dee74b22b
+SIZE (gatling-0.4.tar.bz2) = 33923
diff --git a/www/gatling/files/patch-Makefile b/www/gatling/files/patch-Makefile
new file mode 100644
index 000000000000..8ad9d66eb310
--- /dev/null
+++ b/www/gatling/files/patch-Makefile
@@ -0,0 +1,22 @@
+--- Makefile.orig Thu Feb 19 17:22:17 2004
++++ Makefile Mon Feb 23 01:12:25 2004
+@@ -6,9 +6,7 @@
+
+ all: $(TARGET)
+
+-CC=gcc
+-CFLAGS=-pipe -Wall -Os -I../libowfat/
+-LDFLAGS=-s -L../libowfat/ -lowfat
++CFLAGS+=-I${LOCALBASE}/include/libowfat
+
+ gatling: gatling.o libsocket libiconv
+ $(CC) -o $@ gatling.o $(LDFLAGS) `cat libsocket libiconv`
+@@ -32,7 +30,7 @@
+ $(CC) -static -o $@ forkbench.o $(LDFLAGS)
+
+ pthreadbench: pthreadbench.o
+- $(CC) -o $@ pthreadbench.o $(LDFLAGS) -lpthread
++ $(CC) -o $@ pthreadbench.o $(LDFLAGS) $(PTHREAD_LIBS)
+
+ mktestdata: mktestdata.o
+ $(CC) -o $@ mktestdata.o $(LDFLAGS)
diff --git a/www/gatling/pkg-descr b/www/gatling/pkg-descr
new file mode 100644
index 000000000000..ac2ccc76583f
--- /dev/null
+++ b/www/gatling/pkg-descr
@@ -0,0 +1,4 @@
+gatling is a high-performance webserver. Some scalability benchmark
+tests are included, too.
+
+WWW: http://www.fefe.de/gatling/