aboutsummaryrefslogtreecommitdiff
path: root/www/gatling
diff options
context:
space:
mode:
authorVolker Stolz <vs@FreeBSD.org>2005-02-01 12:11:48 +0000
committerVolker Stolz <vs@FreeBSD.org>2005-02-01 12:11:48 +0000
commite4cd173d8be3a6ae81c3066e5e81d1cddd7edc1e (patch)
tree955e94086cc9a77d20326d33b4bc35cf4d85dc41 /www/gatling
parent0271a27d969079bdf6bab6a906678421d073fa1e (diff)
downloadports-e4cd173d8be3a6ae81c3066e5e81d1cddd7edc1e.tar.gz
ports-e4cd173d8be3a6ae81c3066e5e81d1cddd7edc1e.zip
Notes
Diffstat (limited to 'www/gatling')
-rw-r--r--www/gatling/Makefile2
-rw-r--r--www/gatling/files/patch-gatling.c19
2 files changed, 20 insertions, 1 deletions
diff --git a/www/gatling/Makefile b/www/gatling/Makefile
index 7006f50977bb..9bb02e54542a 100644
--- a/www/gatling/Makefile
+++ b/www/gatling/Makefile
@@ -7,7 +7,7 @@
PORTNAME= gatling
PORTVERSION= 0.5
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= www benchmarks ftp ipv6
MASTER_SITES= http://dl.fefe.de/
diff --git a/www/gatling/files/patch-gatling.c b/www/gatling/files/patch-gatling.c
new file mode 100644
index 000000000000..8952ed9e6495
--- /dev/null
+++ b/www/gatling/files/patch-gatling.c
@@ -0,0 +1,19 @@
+--- gatling.c.orig Wed Jul 28 15:23:51 2004
++++ gatling.c Mon Jan 31 18:42:03 2005
+@@ -1261,6 +1261,7 @@ e404:
+ ++c;
+ if ((i=scan_ulonglong(c,&range_last))) {
+ if (!i) goto rangeerror;
++ ++range_last;
+ }
+ }
+ } else {
+@@ -1311,7 +1312,7 @@ rangeerror:
+ c+=fmt_str(c,"\r\nContent-Range: bytes ");
+ c+=fmt_ulonglong(c,range_first);
+ c+=fmt_str(c,"-");
+- c+=fmt_ulonglong(c,range_last);
++ c+=fmt_ulonglong(c,range_last-1);
+ c+=fmt_str(c,"/");
+ c+=fmt_ulonglong(c,ss.st_size);
+ }