aboutsummaryrefslogtreecommitdiff
path: root/www/gecko-mediaplayer
diff options
context:
space:
mode:
authorBeat Gaetzi <beat@FreeBSD.org>2010-08-08 09:16:11 +0000
committerBeat Gaetzi <beat@FreeBSD.org>2010-08-08 09:16:11 +0000
commitbfb24bafaa6541581c8432c280056fe0369a62e4 (patch)
treee3de271546b873c99d4a75a1f56deef81deb5eab /www/gecko-mediaplayer
parent6ac33dd535f82bc8b760748ebaca9b7a43c1b544 (diff)
downloadports-bfb24bafaa6541581c8432c280056fe0369a62e4.tar.gz
ports-bfb24bafaa6541581c8432c280056fe0369a62e4.zip
Notes
Diffstat (limited to 'www/gecko-mediaplayer')
-rw-r--r--www/gecko-mediaplayer/Makefile14
-rw-r--r--www/gecko-mediaplayer/distinfo6
-rw-r--r--www/gecko-mediaplayer/files/patch-configure20
-rw-r--r--www/gecko-mediaplayer/pkg-plist2
4 files changed, 34 insertions, 8 deletions
diff --git a/www/gecko-mediaplayer/Makefile b/www/gecko-mediaplayer/Makefile
index a9795f360309..1530cbd1fdf3 100644
--- a/www/gecko-mediaplayer/Makefile
+++ b/www/gecko-mediaplayer/Makefile
@@ -6,8 +6,8 @@
#
PORTNAME= gecko-mediaplayer
-PORTVERSION= 0.9.5
-PORTREVISION= 5
+PORTVERSION= 0.9.9.2
+PORTREVISION= 1
CATEGORIES= www multimedia gnome
MASTER_SITES= GOOGLE_CODE
@@ -22,13 +22,16 @@ OPTIONS= GCONF "Use Gconf to store preferences" off \
GNU_CONFIGURE= yes
USE_GETTEXT= yes
-USE_GNOME= glib20
-USE_GECKO= libxul seamonkey
+USE_GNOME= glib20 pkgconfig
+USE_GECKO= libxul
USE_WEBPLUGINS= native
WEBPLUGINS_FILES= ${PORTNAME}-dvx.so ${PORTNAME}-qt.so ${PORTNAME}-rm.so \
${PORTNAME}-wmp.so ${PORTNAME}.so
CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
LDFLAGS="-L${LOCALBASE}/lib"
+CONFIGURE_ARGS+= --enable-new-libxul \
+ --with-xulrunner-sdk="${LOCALBASE}/include" \
+ --with-plugin_dir="${WEBPLUGINS_DIR}"
PORTDOCS= README COPYING AUTHORS ChangeLog INSTALL NEWS javascript.txt
@@ -47,7 +50,8 @@ CONFIGURE_ARGS+= --disable-caching
.endif
post-patch:
- @${REINPLACE_CMD} -e 's|$$(libdir)/mozilla/plugins|${WEBPLUGINS_DIR}|' \
+ @${REINPLACE_CMD} -e 's|-ldl||' \
+ ${WRKSRC}/configure \
${WRKSRC}/src/Makefile.in
.if defined(NOPORTDOCS)
@${REINPLACE_CMD} -e \
diff --git a/www/gecko-mediaplayer/distinfo b/www/gecko-mediaplayer/distinfo
index 28b4175a71c2..a1ddc8d44cc2 100644
--- a/www/gecko-mediaplayer/distinfo
+++ b/www/gecko-mediaplayer/distinfo
@@ -1,3 +1,3 @@
-MD5 (gecko-mediaplayer-0.9.5.tar.gz) = 95b83f30a41769e14a3c7bbb422b514e
-SHA256 (gecko-mediaplayer-0.9.5.tar.gz) = 60cd30e5d44e0ee1e3b96309c3767f5f2eb1cbc29d3d49b7c624cfa60579bf16
-SIZE (gecko-mediaplayer-0.9.5.tar.gz) = 220301
+MD5 (gecko-mediaplayer-0.9.9.2.tar.gz) = deb41a4bcbde2b78d548dc37b684cfbb
+SHA256 (gecko-mediaplayer-0.9.9.2.tar.gz) = 378b6c149e41efd5f0e47c8a711d7b3e108409cb72c6f9504ac4a8791de83cd6
+SIZE (gecko-mediaplayer-0.9.9.2.tar.gz) = 262053
diff --git a/www/gecko-mediaplayer/files/patch-configure b/www/gecko-mediaplayer/files/patch-configure
new file mode 100644
index 000000000000..9a78f43c92fd
--- /dev/null
+++ b/www/gecko-mediaplayer/files/patch-configure
@@ -0,0 +1,20 @@
+--- configure.orig 2010-02-24 16:19:09.000000000 +0100
++++ configure 2010-06-14 22:12:46.000000000 +0200
+@@ -8710,7 +8710,7 @@
+ if test "${with_xulrunner_sdk+set}" = set; then
+ withval=$with_xulrunner_sdk;
+ XULRUNNER_SDK_PREFIX=$with_xulrunner_sdk
+- GECKO_CFLAGS="-I$XULRUNNER_SDK_PREFIX/include -I$XULRUNNER_SDK_PREFIX/include/plugin -I$XULRUNNER_SDK_PREFIX/include/nspr -I$XULRUNNER_SDK_PREFIX/include/xpcom -I$XULRUNNER_SDK_PREFIX/include/string -I$XULRUNNER_SDK_PREFIX/include/java"
++ GECKO_CFLAGS="-I$XULRUNNER_SDK_PREFIX/libxul -I$XULRUNNER_SDK_PREFIX/nspr"
+ GECKO_LIBS="-L$XULRUNNER_SDK_PREFIX/lib -lxpcomglue_s -lxul -lxpcom -lplds4 -lplc4 -lnspr4 -lpthread -ldl"
+ # Check whether --enable-new-libxul was given.
+ if test "${enable_new_libxul+set}" = set; then
+@@ -8720,7 +8720,7 @@
+ fi
+
+
+- if test $usenewlibxul == yes; then
++ if test $usenewlibxul = yes; then
+
+ cat >>confdefs.h <<\_ACEOF
+ #define HAVE_NEW_XULRUNNER 1
diff --git a/www/gecko-mediaplayer/pkg-plist b/www/gecko-mediaplayer/pkg-plist
index 6ccf863478bd..85dabf06dd6a 100644
--- a/www/gecko-mediaplayer/pkg-plist
+++ b/www/gecko-mediaplayer/pkg-plist
@@ -3,10 +3,12 @@
%%WEBPLUGINS_DIR%%/gecko-mediaplayer-rm.so
%%WEBPLUGINS_DIR%%/gecko-mediaplayer-wmp.so
%%WEBPLUGINS_DIR%%/gecko-mediaplayer.so
+share/locale/cs/LC_MESSAGES/gecko-mediaplayer.mo
share/locale/es/LC_MESSAGES/gecko-mediaplayer.mo
share/locale/fr/LC_MESSAGES/gecko-mediaplayer.mo
share/locale/it/LC_MESSAGES/gecko-mediaplayer.mo
share/locale/ja/LC_MESSAGES/gecko-mediaplayer.mo
+share/locale/nl/LC_MESSAGES/gecko-mediaplayer.mo
share/locale/pl/LC_MESSAGES/gecko-mediaplayer.mo
share/locale/pt_BR/LC_MESSAGES/gecko-mediaplayer.mo
share/locale/tr/LC_MESSAGES/gecko-mediaplayer.mo