aboutsummaryrefslogtreecommitdiff
path: root/www/gecko-sharp20/Makefile
diff options
context:
space:
mode:
authorTom McLaughlin <tmclaugh@FreeBSD.org>2005-09-25 23:02:56 +0000
committerTom McLaughlin <tmclaugh@FreeBSD.org>2005-09-25 23:02:56 +0000
commitaff89f6bc7f1def7920e19dfd037e1787cf06a02 (patch)
treedb2bf565c236e2c08f4a09752baed7f99bbe7e38 /www/gecko-sharp20/Makefile
parent6283d52f55a67be080e408da84ea3e0b74c21e8c (diff)
Notes
Diffstat (limited to 'www/gecko-sharp20/Makefile')
-rw-r--r--www/gecko-sharp20/Makefile53
1 files changed, 53 insertions, 0 deletions
diff --git a/www/gecko-sharp20/Makefile b/www/gecko-sharp20/Makefile
new file mode 100644
index 000000000000..7a53e882af3c
--- /dev/null
+++ b/www/gecko-sharp20/Makefile
@@ -0,0 +1,53 @@
+# New ports collection makefile for: gecko-sharp
+# Date created: 20040825
+# Whom: Tom McLaughlin <tmclaugh@sdf.lonestar.org>
+#
+# $FreeBSD$
+# $Id: Makefile,v 1.6 2005/09/25 19:01:20 tmclau02 Exp $
+#
+
+PORTNAME= gecko-sharp
+PORTVERSION= 0.11
+PORTREVISION= 1
+CATEGORIES= www
+MASTER_SITES= http://go-mono.com/sources/gecko-sharp-2.0/
+DISTNAME= gecko-sharp-2.0-${PORTVERSION}
+
+MAINTAINER= bsd-sharp-list@forge.novell.com
+COMMENT= Mono bindings for embeding mozilla
+
+BUILD_DEPENDS= gapi2-parser:${PORTSDIR}/x11-toolkits/gtk-sharp20 \
+ monodoc:${PORTSDIR}/devel/mono-tools
+RUN_DEPENDS= gapi2-parser:${PORTSDIR}/x11-toolkits/gtk-sharp20 \
+ monodoc:${PORTSDIR}/devel/mono-tools \
+ ${X11BASE}/lib/${MOZILLA}/components/libwidget_gtk2.so:${PORTSDIR}/www/${MOZILLA}
+
+.if !defined(WITH_MOZILLA)
+MOZILLA= mozilla
+.else
+.if ${WITH_MOZILLA}=="firefox"
+MOZILLA= firefox
+.else
+MOZILLA= mozilla
+.endif
+.endif
+
+USE_GNOME= gnometarget
+LATEST_LINK= gecko-sharp20
+USE_REINPLACE= yes
+USE_X_PREFIX= yes
+GNU_CONFIGURE= yes
+USE_GMAKE= yes
+
+pre-everything::
+ @${ECHO_MSG} ""
+ @${ECHO_MSG} " By default ${PORTNAME} uses www/mozilla for html rendering, but you can"
+ @${ECHO_MSG} " change this by defining WITH_MOZILLA to one of the following values:"
+ @${ECHO_MSG} ""
+ @${ECHO_MSG} " firefox "
+ @${ECHO_MSG} ""
+
+post-patch:
+ @${REINPLACE_CMD} -e 's|[(]prefix[)]/lib/pkgconfig|(prefix)/libdata/pkgconfig|g' ${WRKSRC}/Makefile.in
+
+.include <bsd.port.mk>