aboutsummaryrefslogtreecommitdiff
path: root/www/gitea
diff options
context:
space:
mode:
authorAdam Weinberger <adamw@FreeBSD.org>2020-03-19 16:16:35 +0000
committerAdam Weinberger <adamw@FreeBSD.org>2020-03-19 16:16:35 +0000
commita57fc6cd2c48297411718ad70a75e5b25a5dadaf (patch)
tree15ef60c635dd06218a02df61a2ce5c7f03297b75 /www/gitea
parent390518feb7f278cfc28e4e5f61569229535eb358 (diff)
downloadports-a57fc6cd2c48297411718ad70a75e5b25a5dadaf.tar.gz
ports-a57fc6cd2c48297411718ad70a75e5b25a5dadaf.zip
Notes
Diffstat (limited to 'www/gitea')
-rw-r--r--www/gitea/Makefile6
-rw-r--r--www/gitea/distinfo6
-rw-r--r--www/gitea/files/patch-Makefile20
3 files changed, 27 insertions, 5 deletions
diff --git a/www/gitea/Makefile b/www/gitea/Makefile
index fb8d22720e61..0637d01141f9 100644
--- a/www/gitea/Makefile
+++ b/www/gitea/Makefile
@@ -2,7 +2,7 @@
PORTNAME= gitea
DISTVERSIONPREFIX= v
-DISTVERSION= 1.11.2
+DISTVERSION= 1.11.3
CATEGORIES= www
MASTER_SITES= https://github.com/go-gitea/gitea/releases/download/${DISTVERSIONPREFIX}${DISTVERSION}/
DISTNAME= gitea-src-${DISTVERSION}
@@ -47,11 +47,13 @@ DAEMONARGS= -f
SUB_LIST+= DAEMONARGS="${DAEMONARGS}"
+SSP_UNSAFE= true
# use sane defaults for path, overriden with actual PREFIX in start script
EXTRA_LDFLAGS= -X code.gitea.io/gitea/modules/setting.CustomPath=${PREFIX}/etc/gitea
EXTRA_LDFLAGS+= -X code.gitea.io/gitea/modules/setting.AppWorkPath=${PREFIX}/share/gitea
# Default LDFLAGS are incompatible with build
-MAKE_ARGS= GOPATH=${WRKDIR} TAGS="${GO_TAGS}" LDFLAGS="${EXTRA_LDFLAGS}"
+MAKE_ENV= LDFLAGS="${LDFLAGS} ${EXTRA_LDFLAGS}"
+MAKE_ARGS= GOPATH=${WRKDIR} TAGS="${GO_TAGS}"
ALL_TARGET= backend
MAKE_JOBS_UNSAFE= yes
diff --git a/www/gitea/distinfo b/www/gitea/distinfo
index 5cf73a7c684d..72c4b48f2826 100644
--- a/www/gitea/distinfo
+++ b/www/gitea/distinfo
@@ -1,3 +1,3 @@
-TIMESTAMP = 1583582463
-SHA256 (gitea-src-1.11.2.tar.gz) = 777ad27929809811e17e2d0a539d2a47163e382473cefa680debcb0777aa2cba
-SIZE (gitea-src-1.11.2.tar.gz) = 69381797
+TIMESTAMP = 1584565552
+SHA256 (gitea-src-1.11.3.tar.gz) = 5d0b31295788cc81d9f0033d00e509b6798ffeef0b603c4e1360e1762f3b11ec
+SIZE (gitea-src-1.11.3.tar.gz) = 69382786
diff --git a/www/gitea/files/patch-Makefile b/www/gitea/files/patch-Makefile
new file mode 100644
index 000000000000..ead1c6269b0c
--- /dev/null
+++ b/www/gitea/files/patch-Makefile
@@ -0,0 +1,20 @@
+--- Makefile.orig 2020-03-06 17:18:36.000000000 +0000
++++ Makefile 2020-03-18 20:56:00.588102000 +0000
+@@ -123,7 +123,7 @@
+
+ .PHONY: go-check
+ go-check:
+- $(eval GO_VERSION := $(shell printf "%03d%03d%03d" $(shell go version | grep -Eo '[0-9]+\.?[0-9]+?\.?[0-9]?[[:space:]]' | tr '.' ' ');))
++ $(eval GO_VERSION := $(shell printf "%03d%03d%03d" $(shell go version | bsdgrep -Eo 'go[0-9\.]+' | tr -d go | tr '.' ' ');))
+ @if [ "$(GO_VERSION)" -lt "001011000" ]; then \
+ echo "Gitea requires Go 1.11.0 or greater to build. You can get it at https://golang.org/dl/"; \
+ exit 1; \
+@@ -138,7 +138,7 @@
+
+ .PHONY: node-check
+ node-check:
+- $(eval NODE_VERSION := $(shell printf "%03d%03d%03d" $(shell node -v | grep -Eo '[0-9]+\.?[0-9]+?\.?[0-9]?' | tr '.' ' ');))
++ $(eval NODE_VERSION := $(shell printf "%03d%03d%03d" $(shell node -v | grep -Eo '[0-9]+\.?[0-9]+\.?[0-9]+' | tr '.' ' ');))
+ $(eval NPM_MISSING := $(shell hash npm > /dev/null 2>&1 || echo 1))
+ @if [ "$(NODE_VERSION)" -lt "010000000" -o "$(NPM_MISSING)" = "1" ]; then \
+ echo "Gitea requires Node.js 10.0.0 or greater and npm to build. You can get it at https://nodejs.org/en/download/"; \