aboutsummaryrefslogtreecommitdiff
path: root/www/gitlab
diff options
context:
space:
mode:
authorTorsten Zuehlsdorff <tz@FreeBSD.org>2017-09-27 09:05:04 +0000
committerTorsten Zuehlsdorff <tz@FreeBSD.org>2017-09-27 09:05:04 +0000
commit7d61bd218b1e479a480a04dde8032bcb1f4bfeab (patch)
treec95b0166cf2d1ed88ec9d68c684a5d31a5c3e340 /www/gitlab
parentd41a65d6575572fe2e93a22a7266634b189c34c4 (diff)
downloadports-7d61bd218b1e479a480a04dde8032bcb1f4bfeab.tar.gz
ports-7d61bd218b1e479a480a04dde8032bcb1f4bfeab.zip
Notes
Diffstat (limited to 'www/gitlab')
-rw-r--r--www/gitlab/Makefile9
-rw-r--r--www/gitlab/files/patch-Gemfile9
2 files changed, 14 insertions, 4 deletions
diff --git a/www/gitlab/Makefile b/www/gitlab/Makefile
index 319912f15e57..cebaed1bc0a8 100644
--- a/www/gitlab/Makefile
+++ b/www/gitlab/Makefile
@@ -3,6 +3,7 @@
PORTNAME= gitlab
PORTVERSION= 9.3.11
+PORTREVISION= 1
DISTVERSIONPREFIX= v
CATEGORIES= www devel
@@ -205,15 +206,19 @@ GROUPS= git
NO_ARCH= yes
NO_BUILD= yes
+post-patch-MYSQL-on:
+ ${CP} ${WRKSRC}/config/database.yml.mysql ${WRKSRC}/config/database.yml.sample
+
post-patch-MYSQL-off:
${REINPLACE_CMD} -e "/gem 'mysql2'/d" ${WRKSRC}/Gemfile
${REINPLACE_CMD} -e "/gem 'peek-mysql2'/d" ${WRKSRC}/Gemfile
- ${CP} ${WRKSRC}/config/database.yml.mysql ${WRKSRC}/config/database.yml.sample
+
+post-patch-PGSQL-on:
+ ${CP} ${WRKSRC}/config/database.yml.postgresql ${WRKSRC}/config/database.yml.sample
post-patch-PGSQL-off:
${REINPLACE_CMD} -e "/gem 'pg'/d" ${WRKSRC}/Gemfile
${REINPLACE_CMD} -e "/gem 'peek-pg'/d" ${WRKSRC}/Gemfile
- ${CP} ${WRKSRC}/config/database.yml.postgresql ${WRKSRC}/config/database.yml.sample
do-install:
${FIND} ${WRKSRC} -name '*.orig' -delete
diff --git a/www/gitlab/files/patch-Gemfile b/www/gitlab/files/patch-Gemfile
index d33867ba1e7d..fe2ea339ae21 100644
--- a/www/gitlab/files/patch-Gemfile
+++ b/www/gitlab/files/patch-Gemfile
@@ -1,6 +1,6 @@
--- Gemfile.orig 2017-09-06 21:34:31 UTC
+++ Gemfile
-@@ -1,12 +1,12 @@
+@@ -1,48 +1,47 @@
source 'https://rubygems.org'
-gem 'rails', '4.2.8'
@@ -15,7 +15,12 @@
# Default values for AR models
gem 'default_value_for', '~> 3.0.0'
-@@ -17,32 +17,31 @@ gem 'pg', '~> 0.18.2', group: :postgres
+
+ # Supported DBs
+-gem 'mysql2', '~> 0.3.16', group: :mysql
+-gem 'pg', '~> 0.18.2', group: :postgres
++gem 'mysql2', '>= 0.3.16', group: :mysql
++gem 'pg', '>= 0.18.2', group: :postgres
gem 'rugged', '~> 0.25.1.1'