aboutsummaryrefslogtreecommitdiff
path: root/www/gnome-user-share/Makefile
diff options
context:
space:
mode:
authorKoop Mast <kwm@FreeBSD.org>2014-11-19 11:49:04 +0000
committerKoop Mast <kwm@FreeBSD.org>2014-11-19 11:49:04 +0000
commitaf3811313c14afb06fe2d1f6158e3e431bbfc2b6 (patch)
tree1ad98a4e8faecd0e2fa9ac2c18e65da4cf89c236 /www/gnome-user-share/Makefile
parentc7d4d6bd7ef6ff4955eab2863a5c6e2feb14b839 (diff)
Notes
Diffstat (limited to 'www/gnome-user-share/Makefile')
-rw-r--r--www/gnome-user-share/Makefile20
1 files changed, 10 insertions, 10 deletions
diff --git a/www/gnome-user-share/Makefile b/www/gnome-user-share/Makefile
index 7c1b82c2850b..a7572979add2 100644
--- a/www/gnome-user-share/Makefile
+++ b/www/gnome-user-share/Makefile
@@ -1,9 +1,9 @@
# Created by: Joe Marcus Clarke <marcus@FreeBSD.org>
# $FreeBSD$
+# $MCom: ports/trunk/www/gnome-user-share/Makefile 19970 2014-10-16 08:47:02Z gusi $
PORTNAME= gnome-user-share
-PORTVERSION= 2.30.1
-PORTREVISION= 4
+PORTVERSION= 3.14.0
CATEGORIES= www deskutils gnome
MASTER_SITES= GNOME
DIST_SUBDIR= gnome2
@@ -11,26 +11,26 @@ DIST_SUBDIR= gnome2
MAINTAINER= gnome@FreeBSD.org
COMMENT= Personal file-sharing service for the GNOME Desktop
+BUILD_DEPENDS= itstool:${PORTSDIR}/textproc/itstool
LIB_DEPENDS= libavahi-client.so:${PORTSDIR}/net/avahi-app \
- libcanberra.so:${PORTSDIR}/audio/libcanberra \
libnotify.so:${PORTSDIR}/devel/libnotify \
+ libcanberra-gtk3.so:${PORTSDIR}/audio/libcanberra-gtk3 \
libunique-1.0.so:${PORTSDIR}/x11-toolkits/unique
-RUN_DEPENDS= ${LOCALBASE}/${APACHEMODDIR}/mod_dnssd.so:${PORTSDIR}/www/mod_dnssd \
+RUN_DEPENDS= ap*-mod_dnssd>=0:${PORTSDIR}/www/mod_dnssd \
console-kit-daemon:${PORTSDIR}/sysutils/consolekit
-USES= gettext gmake libtool pkgconfig tar:bzip2
+USES= gettext gmake libtool pkgconfig tar:xz
USE_APACHE= 22+
USE_XORG= sm
-USE_GNOME= gnomeprefix intlhack gtk20 gconf2 gnomedocutils nautilus2
+USE_GNOME= gnomeprefix gtk30 intlhack nautilus3
GNU_CONFIGURE= yes
INSTALLS_ICONS= yes
-CONFIGURE_ARGS= --with-modules-path=${LOCALBASE}/${APACHEMODDIR}
+CONFIGURE_ARGS= --with-modules-path=${LOCALBASE}/${APACHEMODDIR} \
+ --disable-bluetooth
CPPFLAGS+= -I${LOCALBASE}/include
-LDFLAGS+= -L${LOCALBASE}/lib
+LIBS+= -L${LOCALBASE}/lib
INSTALL_TARGET= install-strip
-GCONF_SCHEMAS= desktop_gnome_file_sharing.schemas
-
post-patch:
@${REINPLACE_CMD} -e 's|/etc/httpd/modules|${LOCALBASE}/${APACHEMODDIR}|g' \
${WRKSRC}/data/dav_user_*.conf