aboutsummaryrefslogtreecommitdiff
path: root/www/gnome-user-share
diff options
context:
space:
mode:
authorJoe Marcus Clarke <marcus@FreeBSD.org>2004-12-04 00:36:20 +0000
committerJoe Marcus Clarke <marcus@FreeBSD.org>2004-12-04 00:36:20 +0000
commitc765c5b2a5eb6b9010d571fdafba4b85c78a88f3 (patch)
tree0bfb8b3aa6ac20740288a3388514248070fdb59c /www/gnome-user-share
parent6d46758fc42b5f1ca441917b738b30789d03d557 (diff)
downloadports-c765c5b2a5eb6b9010d571fdafba4b85c78a88f3.tar.gz
ports-c765c5b2a5eb6b9010d571fdafba4b85c78a88f3.zip
Notes
Diffstat (limited to 'www/gnome-user-share')
-rw-r--r--www/gnome-user-share/Makefile4
-rw-r--r--www/gnome-user-share/distinfo4
-rw-r--r--www/gnome-user-share/files/patch-dav_user.conf9
-rw-r--r--www/gnome-user-share/files/patch-user_share.c38
4 files changed, 4 insertions, 51 deletions
diff --git a/www/gnome-user-share/Makefile b/www/gnome-user-share/Makefile
index bb78bf6fedf3..d19e10579a81 100644
--- a/www/gnome-user-share/Makefile
+++ b/www/gnome-user-share/Makefile
@@ -6,10 +6,10 @@
#
PORTNAME= gnome-user-share
-PORTVERSION= 0.3
+PORTVERSION= 0.4
CATEGORIES= www deskutils gnome
MASTER_SITES= ${MASTER_SITE_GNOME}
-MASTER_SITE_SUBDIR= sources/${PORTNAME}/0.3
+MASTER_SITE_SUBDIR= sources/${PORTNAME}/0.4
DIST_SUBDIR= gnome2
MAINTAINER= marcus@FreeBSD.org
diff --git a/www/gnome-user-share/distinfo b/www/gnome-user-share/distinfo
index 4b79fc6b28dc..7f1d5c2a7268 100644
--- a/www/gnome-user-share/distinfo
+++ b/www/gnome-user-share/distinfo
@@ -1,2 +1,2 @@
-MD5 (gnome2/gnome-user-share-0.3.tar.bz2) = 2f760af8691d5a7202aa2d52f286d965
-SIZE (gnome2/gnome-user-share-0.3.tar.bz2) = 219045
+MD5 (gnome2/gnome-user-share-0.4.tar.bz2) = 55a664dca2161bca06e8a10deb8a5339
+SIZE (gnome2/gnome-user-share-0.4.tar.bz2) = 220130
diff --git a/www/gnome-user-share/files/patch-dav_user.conf b/www/gnome-user-share/files/patch-dav_user.conf
deleted file mode 100644
index f3d258adf7d2..000000000000
--- a/www/gnome-user-share/files/patch-dav_user.conf
+++ /dev/null
@@ -1,9 +0,0 @@
---- dav_user.conf.orig Fri Nov 26 15:50:13 2004
-+++ dav_user.conf Fri Nov 26 15:50:22 2004
-@@ -1,5 +1,6 @@
- ServerRoot ${HOME}/.gnome2/user-share
- PidFile pid
-+LockFile lock
- LogLevel crit
- #LogLevel info
- ErrorLog log
diff --git a/www/gnome-user-share/files/patch-user_share.c b/www/gnome-user-share/files/patch-user_share.c
deleted file mode 100644
index 75fcdc3984f7..000000000000
--- a/www/gnome-user-share/files/patch-user_share.c
+++ /dev/null
@@ -1,38 +0,0 @@
---- user_share.c.orig Fri Nov 26 04:33:51 2004
-+++ user_share.c Fri Nov 26 17:24:31 2004
-@@ -59,6 +59,14 @@
- return -1;
- }
-
-+#if defined(__FreeBSD__) || defined(__NetBSD__) || defined(__APPLE__)
-+ /* XXX This exposes a potential race condition, but without this,
-+ * httpd will not start on the above listed platforms due to the fact
-+ * that SO_REUSEADDR is also needed when Apache binds to the listening
-+ * socket. At this time, Apache does not support that socket option.
-+ */
-+ close (sock);
-+#endif
- return ntohs (addr.sin_port);
- }
-
-@@ -171,7 +179,7 @@
- char *free1, *free2;
- gboolean res;
- char *argv[10];
-- char *env[10];;
-+ char *env[10];
- int i;
- gint status;
- char *pid_filename;
-@@ -195,9 +203,9 @@
- str = gconf_client_get_string (client,
- FILE_SHARING_REQUIRE_PASSWORD, NULL);
-
-- if (strcmp (str, "never") == 0) {
-+ if (str && strcmp (str, "never") == 0) {
- /* Do nothing */
-- } else if (strcmp (str, "on_write") == 0){
-+ } else if (str && strcmp (str, "on_write") == 0){
- argv[i++] = "-D";
- argv[i++] = "RequirePasswordOnWrite";
- } else {