aboutsummaryrefslogtreecommitdiff
path: root/www/gnome-user-share
diff options
context:
space:
mode:
authorJoe Marcus Clarke <marcus@FreeBSD.org>2009-11-28 20:06:37 +0000
committerJoe Marcus Clarke <marcus@FreeBSD.org>2009-11-28 20:06:37 +0000
commitf76d32b8e89fed7c0e459c1a7fe7a4b57661b01c (patch)
treead29e6808ff698f84e08dab8e047f0ae72838df9 /www/gnome-user-share
parent873cae3ab41a109b6f9cf9f4149f101d6d996235 (diff)
downloadports-f76d32b8e89fed7c0e459c1a7fe7a4b57661b01c.tar.gz
ports-f76d32b8e89fed7c0e459c1a7fe7a4b57661b01c.zip
Notes
Diffstat (limited to 'www/gnome-user-share')
-rw-r--r--www/gnome-user-share/Makefile11
-rw-r--r--www/gnome-user-share/distinfo6
-rw-r--r--www/gnome-user-share/files/patch-configure61
-rw-r--r--www/gnome-user-share/files/patch-src_user_share.c48
-rw-r--r--www/gnome-user-share/pkg-plist50
5 files changed, 168 insertions, 8 deletions
diff --git a/www/gnome-user-share/Makefile b/www/gnome-user-share/Makefile
index 3528bd5cb8e0..3f47df649814 100644
--- a/www/gnome-user-share/Makefile
+++ b/www/gnome-user-share/Makefile
@@ -3,12 +3,11 @@
# Whom: Joe Marcus Clarke <marcus@FreeBSD.org>
#
# $FreeBSD$
-# $MCom: ports/www/gnome-user-share/Makefile,v 1.14 2009/03/17 13:35:33 kwm Exp $
+# $MCom: ports/www/gnome-user-share/Makefile,v 1.17 2009/10/27 11:20:53 kwm Exp $
#
PORTNAME= gnome-user-share
-PORTVERSION= 2.26.0
-PORTREVISION= 1
+PORTVERSION= 2.28.1
CATEGORIES= www deskutils gnome
MASTER_SITES= GNOME
DIST_SUBDIR= gnome2
@@ -17,14 +16,16 @@ MAINTAINER= gnome@FreeBSD.org
COMMENT= Personal file-sharing service for the GNOME Desktop
LIB_DEPENDS= avahi-client:${PORTSDIR}/net/avahi-app \
+ canberra.0:${PORTSDIR}/audio/libcanberra \
notify.1:${PORTSDIR}/devel/libnotify
-RUN_DEPENDS= ${LOCALBASE}/${APACHEMODDIR}/mod_dnssd.so:${PORTSDIR}/www/mod_dnssd
+RUN_DEPENDS= ${LOCALBASE}/${APACHEMODDIR}/mod_dnssd.so:${PORTSDIR}/www/mod_dnssd \
+ console-kit-daemon:${PORTSDIR}/sysutils/consolekit
USE_BZIP2= yes
USE_GMAKE= yes
USE_GETTEXT= yes
USE_APACHE= 2.2+
-USE_GNOME= gnomeprefix gnomehack intlhack libglade2 gconf2 gnomedocutils
+USE_GNOME= gnomeprefix gnomehack intlhack gtk20 gconf2 gnomedocutils
GNU_CONFIGURE= yes
INSTALLS_ICONS= yes
CONFIGURE_ARGS= --with-modules-path=${LOCALBASE}/${APACHEMODDIR}
diff --git a/www/gnome-user-share/distinfo b/www/gnome-user-share/distinfo
index e02044498cab..35fa78e70075 100644
--- a/www/gnome-user-share/distinfo
+++ b/www/gnome-user-share/distinfo
@@ -1,3 +1,3 @@
-MD5 (gnome2/gnome-user-share-2.26.0.tar.bz2) = c99133b74a81a78ac0e4e10ef73fada7
-SHA256 (gnome2/gnome-user-share-2.26.0.tar.bz2) = 405be1ffbec4f865846746ab016e6816a58d9e2f2545fae48c31d4999c94d5f6
-SIZE (gnome2/gnome-user-share-2.26.0.tar.bz2) = 644020
+MD5 (gnome2/gnome-user-share-2.28.1.tar.bz2) = 4dde75de682805357af5995a748d6e4e
+SHA256 (gnome2/gnome-user-share-2.28.1.tar.bz2) = 4803ddedd77ce64ae25a85fcb04550b2589dc735baa4afd485618629700429bf
+SIZE (gnome2/gnome-user-share-2.28.1.tar.bz2) = 912102
diff --git a/www/gnome-user-share/files/patch-configure b/www/gnome-user-share/files/patch-configure
new file mode 100644
index 000000000000..52ca647a5e2f
--- /dev/null
+++ b/www/gnome-user-share/files/patch-configure
@@ -0,0 +1,61 @@
+--- configure.orig 2009-10-27 12:12:48.000000000 +0100
++++ configure 2009-10-27 12:15:00.000000000 +0100
+@@ -15214,12 +15214,12 @@
+ pkg_cv_USER_SHARE_CFLAGS="$USER_SHARE_CFLAGS"
+ elif test -n "$PKG_CONFIG"; then
+ if test -n "$PKG_CONFIG" && \
+- { ($as_echo "$as_me:$LINENO: \$PKG_CONFIG --exists --print-errors \"glib-2.0 >= 2.15.2 gio-2.0 gdk-x11-2.0 gtk+-2.0 gconf-2.0 dbus-glib-1 libnotify libcanberra-gtk \$DBUS_MODULES gnome-bluetooth-1.0 >= 2.27.7.2\"") >&5
+- ($PKG_CONFIG --exists --print-errors "glib-2.0 >= 2.15.2 gio-2.0 gdk-x11-2.0 gtk+-2.0 gconf-2.0 dbus-glib-1 libnotify libcanberra-gtk $DBUS_MODULES gnome-bluetooth-1.0 >= 2.27.7.2") 2>&5
++ { ($as_echo "$as_me:$LINENO: \$PKG_CONFIG --exists --print-errors \"glib-2.0 >= 2.15.2 gio-2.0 gdk-x11-2.0 gtk+-2.0 gconf-2.0 dbus-glib-1 libnotify libcanberra-gtk \$DBUS_MODULES \"") >&5
++ ($PKG_CONFIG --exists --print-errors "glib-2.0 >= 2.15.2 gio-2.0 gdk-x11-2.0 gtk+-2.0 gconf-2.0 dbus-glib-1 libnotify libcanberra-gtk $DBUS_MODULES") 2>&5
+ ac_status=$?
+ $as_echo "$as_me:$LINENO: \$? = $ac_status" >&5
+ (exit $ac_status); }; then
+- pkg_cv_USER_SHARE_CFLAGS=`$PKG_CONFIG --cflags "glib-2.0 >= 2.15.2 gio-2.0 gdk-x11-2.0 gtk+-2.0 gconf-2.0 dbus-glib-1 libnotify libcanberra-gtk $DBUS_MODULES gnome-bluetooth-1.0 >= 2.27.7.2" 2>/dev/null`
++ pkg_cv_USER_SHARE_CFLAGS=`$PKG_CONFIG --cflags "glib-2.0 >= 2.15.2 gio-2.0 gdk-x11-2.0 gtk+-2.0 gconf-2.0 dbus-glib-1 libnotify libcanberra-gtk $DBUS_MODULES" 2>/dev/null`
+ else
+ pkg_failed=yes
+ fi
+@@ -15230,12 +15230,12 @@
+ pkg_cv_USER_SHARE_LIBS="$USER_SHARE_LIBS"
+ elif test -n "$PKG_CONFIG"; then
+ if test -n "$PKG_CONFIG" && \
+- { ($as_echo "$as_me:$LINENO: \$PKG_CONFIG --exists --print-errors \"glib-2.0 >= 2.15.2 gio-2.0 gdk-x11-2.0 gtk+-2.0 gconf-2.0 dbus-glib-1 libnotify libcanberra-gtk \$DBUS_MODULES gnome-bluetooth-1.0 >= 2.27.7.2\"") >&5
+- ($PKG_CONFIG --exists --print-errors "glib-2.0 >= 2.15.2 gio-2.0 gdk-x11-2.0 gtk+-2.0 gconf-2.0 dbus-glib-1 libnotify libcanberra-gtk $DBUS_MODULES gnome-bluetooth-1.0 >= 2.27.7.2") 2>&5
++ { ($as_echo "$as_me:$LINENO: \$PKG_CONFIG --exists --print-errors \"glib-2.0 >= 2.15.2 gio-2.0 gdk-x11-2.0 gtk+-2.0 gconf-2.0 dbus-glib-1 libnotify libcanberra-gtk \$DBUS_MODULES \"") >&5
++ ($PKG_CONFIG --exists --print-errors "glib-2.0 >= 2.15.2 gio-2.0 gdk-x11-2.0 gtk+-2.0 gconf-2.0 dbus-glib-1 libnotify libcanberra-gtk $DBUS_MODULES") 2>&5
+ ac_status=$?
+ $as_echo "$as_me:$LINENO: \$? = $ac_status" >&5
+ (exit $ac_status); }; then
+- pkg_cv_USER_SHARE_LIBS=`$PKG_CONFIG --libs "glib-2.0 >= 2.15.2 gio-2.0 gdk-x11-2.0 gtk+-2.0 gconf-2.0 dbus-glib-1 libnotify libcanberra-gtk $DBUS_MODULES gnome-bluetooth-1.0 >= 2.27.7.2" 2>/dev/null`
++ pkg_cv_USER_SHARE_LIBS=`$PKG_CONFIG --libs "glib-2.0 >= 2.15.2 gio-2.0 gdk-x11-2.0 gtk+-2.0 gconf-2.0 dbus-glib-1 libnotify libcanberra-gtk $DBUS_MODULES" 2>/dev/null`
+ else
+ pkg_failed=yes
+ fi
+@@ -15253,14 +15253,14 @@
+ _pkg_short_errors_supported=no
+ fi
+ if test $_pkg_short_errors_supported = yes; then
+- USER_SHARE_PKG_ERRORS=`$PKG_CONFIG --short-errors --print-errors "glib-2.0 >= 2.15.2 gio-2.0 gdk-x11-2.0 gtk+-2.0 gconf-2.0 dbus-glib-1 libnotify libcanberra-gtk $DBUS_MODULES gnome-bluetooth-1.0 >= 2.27.7.2" 2>&1`
++ USER_SHARE_PKG_ERRORS=`$PKG_CONFIG --short-errors --print-errors "glib-2.0 >= 2.15.2 gio-2.0 gdk-x11-2.0 gtk+-2.0 gconf-2.0 dbus-glib-1 libnotify libcanberra-gtk $DBUS_MODULES" 2>&1`
+ else
+- USER_SHARE_PKG_ERRORS=`$PKG_CONFIG --print-errors "glib-2.0 >= 2.15.2 gio-2.0 gdk-x11-2.0 gtk+-2.0 gconf-2.0 dbus-glib-1 libnotify libcanberra-gtk $DBUS_MODULES gnome-bluetooth-1.0 >= 2.27.7.2" 2>&1`
++ USER_SHARE_PKG_ERRORS=`$PKG_CONFIG --print-errors "glib-2.0 >= 2.15.2 gio-2.0 gdk-x11-2.0 gtk+-2.0 gconf-2.0 dbus-glib-1 libnotify libcanberra-gtk $DBUS_MODULES" 2>&1`
+ fi
+ # Put the nasty error message in config.log where it belongs
+ echo "$USER_SHARE_PKG_ERRORS" >&5
+
+- { { $as_echo "$as_me:$LINENO: error: Package requirements (glib-2.0 >= 2.15.2 gio-2.0 gdk-x11-2.0 gtk+-2.0 gconf-2.0 dbus-glib-1 libnotify libcanberra-gtk $DBUS_MODULES gnome-bluetooth-1.0 >= 2.27.7.2) were not met:
++ { { $as_echo "$as_me:$LINENO: error: Package requirements (glib-2.0 >= 2.15.2 gio-2.0 gdk-x11-2.0 gtk+-2.0 gconf-2.0 dbus-glib-1 libnotify libcanberra-gtk $DBUS_MODULES) were not met:
+
+ $USER_SHARE_PKG_ERRORS
+
+@@ -15271,7 +15271,7 @@
+ and USER_SHARE_LIBS to avoid the need to call pkg-config.
+ See the pkg-config man page for more details.
+ " >&5
+-$as_echo "$as_me: error: Package requirements (glib-2.0 >= 2.15.2 gio-2.0 gdk-x11-2.0 gtk+-2.0 gconf-2.0 dbus-glib-1 libnotify libcanberra-gtk $DBUS_MODULES gnome-bluetooth-1.0 >= 2.27.7.2) were not met:
++$as_echo "$as_me: error: Package requirements (glib-2.0 >= 2.15.2 gio-2.0 gdk-x11-2.0 gtk+-2.0 gconf-2.0 dbus-glib-1 libnotify libcanberra-gtk $DBUS_MODULES) were not met:
+
+ $USER_SHARE_PKG_ERRORS
+
diff --git a/www/gnome-user-share/files/patch-src_user_share.c b/www/gnome-user-share/files/patch-src_user_share.c
new file mode 100644
index 000000000000..4305314fbdef
--- /dev/null
+++ b/www/gnome-user-share/files/patch-src_user_share.c
@@ -0,0 +1,48 @@
+--- src/user_share.c.orig 2009-09-26 09:10:16.000000000 -0400
++++ src/user_share.c 2009-09-26 09:13:52.000000000 -0400
+@@ -26,7 +26,9 @@
+ #include <gdk/gdkx.h>
+ #include <gtk/gtk.h>
+ #include <glib/gi18n.h>
++#ifndef __FreeBSD__
+ #include <bluetooth-client.h>
++#endif
+ #include <X11/Xlib.h>
+
+ #include "user_share.h"
+@@ -58,7 +60,9 @@
+ static guint disabled_timeout_tag = 0;
+ static gboolean has_console = TRUE;
+
++#ifndef __FreeBSD__
+ static BluetoothClient *client = NULL;
++#endif
+ static gboolean bluetoothd_enabled = FALSE;
+
+ #define OBEX_ENABLED (bluetoothd_enabled && has_console)
+@@ -224,6 +228,7 @@ consolekit_init (void)
+ dbus_g_connection_unref (dbus_connection);
+ }
+
++#ifndef __FreeBSD__
+ static void
+ default_adapter_changed (GObject *gobject,
+ GParamSpec *pspec,
+@@ -261,6 +266,7 @@ bluez_init (void)
+ g_signal_connect (G_OBJECT (client), "notify::default-adapter-powered",
+ G_CALLBACK (default_adapter_changed), NULL);
+ }
++#endif
+
+ char *
+ lookup_public_dir (void)
+@@ -590,7 +596,9 @@ main (int argc, char **argv)
+
+ g_object_unref (client);
+
++#ifndef __FreeBSD__
+ bluez_init ();
++#endif
+ consolekit_init ();
+
+ /* Initial setting */
diff --git a/www/gnome-user-share/pkg-plist b/www/gnome-user-share/pkg-plist
index 447088a2ca0b..9d64b7329e80 100644
--- a/www/gnome-user-share/pkg-plist
+++ b/www/gnome-user-share/pkg-plist
@@ -12,6 +12,18 @@ share/gnome/help/gnome-user-share/C/figures/sharing-over-bluetooth.png
share/gnome/help/gnome-user-share/C/figures/sharing-over-the-network.png
share/gnome/help/gnome-user-share/C/gnome-user-share.xml
share/gnome/help/gnome-user-share/C/legal.xml
+share/gnome/help/gnome-user-share/ca/figures/file-sharing-preferences.png
+share/gnome/help/gnome-user-share/ca/figures/receiving-over-bluetooth.png
+share/gnome/help/gnome-user-share/ca/figures/sharing-over-bluetooth.png
+share/gnome/help/gnome-user-share/ca/figures/sharing-over-the-network.png
+share/gnome/help/gnome-user-share/ca/gnome-user-share.xml
+share/gnome/help/gnome-user-share/ca/legal.xml
+share/gnome/help/gnome-user-share/cs/figures/file-sharing-preferences.png
+share/gnome/help/gnome-user-share/cs/figures/receiving-over-bluetooth.png
+share/gnome/help/gnome-user-share/cs/figures/sharing-over-bluetooth.png
+share/gnome/help/gnome-user-share/cs/figures/sharing-over-the-network.png
+share/gnome/help/gnome-user-share/cs/gnome-user-share.xml
+share/gnome/help/gnome-user-share/cs/legal.xml
share/gnome/help/gnome-user-share/de/figures/file-sharing-preferences.png
share/gnome/help/gnome-user-share/de/figures/receiving-over-bluetooth.png
share/gnome/help/gnome-user-share/de/figures/sharing-over-bluetooth.png
@@ -36,6 +48,12 @@ share/gnome/help/gnome-user-share/es/figures/sharing-over-bluetooth.png
share/gnome/help/gnome-user-share/es/figures/sharing-over-the-network.png
share/gnome/help/gnome-user-share/es/gnome-user-share.xml
share/gnome/help/gnome-user-share/es/legal.xml
+share/gnome/help/gnome-user-share/fr/figures/file-sharing-preferences.png
+share/gnome/help/gnome-user-share/fr/figures/receiving-over-bluetooth.png
+share/gnome/help/gnome-user-share/fr/figures/sharing-over-bluetooth.png
+share/gnome/help/gnome-user-share/fr/figures/sharing-over-the-network.png
+share/gnome/help/gnome-user-share/fr/gnome-user-share.xml
+share/gnome/help/gnome-user-share/fr/legal.xml
share/gnome/help/gnome-user-share/it/figures/file-sharing-preferences.png
share/gnome/help/gnome-user-share/it/figures/receiving-over-bluetooth.png
share/gnome/help/gnome-user-share/it/figures/sharing-over-bluetooth.png
@@ -48,6 +66,12 @@ share/gnome/help/gnome-user-share/sv/figures/sharing-over-bluetooth.png
share/gnome/help/gnome-user-share/sv/figures/sharing-over-the-network.png
share/gnome/help/gnome-user-share/sv/gnome-user-share.xml
share/gnome/help/gnome-user-share/sv/legal.xml
+share/gnome/help/gnome-user-share/zh_CN/figures/file-sharing-preferences.png
+share/gnome/help/gnome-user-share/zh_CN/figures/receiving-over-bluetooth.png
+share/gnome/help/gnome-user-share/zh_CN/figures/sharing-over-bluetooth.png
+share/gnome/help/gnome-user-share/zh_CN/figures/sharing-over-the-network.png
+share/gnome/help/gnome-user-share/zh_CN/gnome-user-share.xml
+share/gnome/help/gnome-user-share/zh_CN/legal.xml
share/icons/hicolor/16x16/apps/gnome-obex-server.png
share/icons/hicolor/22x22/apps/gnome-obex-server.png
share/icons/hicolor/32x32/apps/gnome-obex-server.png
@@ -55,8 +79,10 @@ share/icons/hicolor/48x48/apps/gnome-obex-server.png
share/locale/ar/LC_MESSAGES/gnome-user-share.mo
share/locale/as/LC_MESSAGES/gnome-user-share.mo
share/locale/bg/LC_MESSAGES/gnome-user-share.mo
+share/locale/bn/LC_MESSAGES/gnome-user-share.mo
share/locale/bn_IN/LC_MESSAGES/gnome-user-share.mo
share/locale/ca/LC_MESSAGES/gnome-user-share.mo
+share/locale/ca@valencia/LC_MESSAGES/gnome-user-share.mo
share/locale/cs/LC_MESSAGES/gnome-user-share.mo
share/locale/da/LC_MESSAGES/gnome-user-share.mo
share/locale/de/LC_MESSAGES/gnome-user-share.mo
@@ -66,8 +92,10 @@ share/locale/en_CA/LC_MESSAGES/gnome-user-share.mo
share/locale/en_GB/LC_MESSAGES/gnome-user-share.mo
share/locale/eu/LC_MESSAGES/gnome-user-share.mo
share/locale/es/LC_MESSAGES/gnome-user-share.mo
+share/locale/et/LC_MESSAGES/gnome-user-share.mo
share/locale/fi/LC_MESSAGES/gnome-user-share.mo
share/locale/fr/LC_MESSAGES/gnome-user-share.mo
+share/locale/ga/LC_MESSAGES/gnome-user-share.mo
share/locale/gl/LC_MESSAGES/gnome-user-share.mo
share/locale/gu/LC_MESSAGES/gnome-user-share.mo
share/locale/he/LC_MESSAGES/gnome-user-share.mo
@@ -75,8 +103,10 @@ share/locale/hi/LC_MESSAGES/gnome-user-share.mo
share/locale/hu/LC_MESSAGES/gnome-user-share.mo
share/locale/it/LC_MESSAGES/gnome-user-share.mo
share/locale/ja/LC_MESSAGES/gnome-user-share.mo
+share/locale/kn/LC_MESSAGES/gnome-user-share.mo
share/locale/ko/LC_MESSAGES/gnome-user-share.mo
share/locale/lt/LC_MESSAGES/gnome-user-share.mo
+share/locale/mai/LC_MESSAGES/gnome-user-share.mo
share/locale/mk/LC_MESSAGES/gnome-user-share.mo
share/locale/ml/LC_MESSAGES/gnome-user-share.mo
share/locale/mr/LC_MESSAGES/gnome-user-share.mo
@@ -95,6 +125,8 @@ share/locale/rw/LC_MESSAGES/gnome-user-share.mo
share/locale/sk/LC_MESSAGES/gnome-user-share.mo
share/locale/sl/LC_MESSAGES/gnome-user-share.mo
share/locale/sq/LC_MESSAGES/gnome-user-share.mo
+share/locale/sr/LC_MESSAGES/gnome-user-share.mo
+share/locale/sr@latin/LC_MESSAGES/gnome-user-share.mo
share/locale/sv/LC_MESSAGES/gnome-user-share.mo
share/locale/ta/LC_MESSAGES/gnome-user-share.mo
share/locale/te/LC_MESSAGES/gnome-user-share.mo
@@ -106,17 +138,25 @@ share/locale/zh_CN/LC_MESSAGES/gnome-user-share.mo
share/locale/zh_HK/LC_MESSAGES/gnome-user-share.mo
share/locale/zh_TW/LC_MESSAGES/gnome-user-share.mo
share/omf/gnome-user-share/gnome-user-share-C.omf
+share/omf/gnome-user-share/gnome-user-share-ca.omf
+share/omf/gnome-user-share/gnome-user-share-cs.omf
share/omf/gnome-user-share/gnome-user-share-de.omf
share/omf/gnome-user-share/gnome-user-share-el.omf
share/omf/gnome-user-share/gnome-user-share-en_GB.omf
share/omf/gnome-user-share/gnome-user-share-es.omf
+share/omf/gnome-user-share/gnome-user-share-fr.omf
share/omf/gnome-user-share/gnome-user-share-it.omf
share/omf/gnome-user-share/gnome-user-share-sv.omf
+share/omf/gnome-user-share/gnome-user-share-zh_CN.omf
@dirrm share/omf/gnome-user-share
+@dirrm share/gnome/help/gnome-user-share/zh_CN/figures
+@dirrm share/gnome/help/gnome-user-share/zh_CN
@dirrm share/gnome/help/gnome-user-share/sv/figures
@dirrm share/gnome/help/gnome-user-share/sv
@dirrm share/gnome/help/gnome-user-share/it/figures
@dirrm share/gnome/help/gnome-user-share/it
+@dirrm share/gnome/help/gnome-user-share/fr/figures
+@dirrm share/gnome/help/gnome-user-share/fr
@dirrm share/gnome/help/gnome-user-share/es/figures
@dirrm share/gnome/help/gnome-user-share/es
@dirrm share/gnome/help/gnome-user-share/en_GB/figures
@@ -125,6 +165,10 @@ share/omf/gnome-user-share/gnome-user-share-sv.omf
@dirrm share/gnome/help/gnome-user-share/el
@dirrm share/gnome/help/gnome-user-share/de/figures
@dirrm share/gnome/help/gnome-user-share/de
+@dirrm share/gnome/help/gnome-user-share/cs/figures
+@dirrm share/gnome/help/gnome-user-share/cs
+@dirrm share/gnome/help/gnome-user-share/ca/figures
+@dirrm share/gnome/help/gnome-user-share/ca
@dirrm share/gnome/help/gnome-user-share/C/figures
@dirrm share/gnome/help/gnome-user-share/C
@dirrm share/gnome/help/gnome-user-share
@@ -134,14 +178,20 @@ share/omf/gnome-user-share/gnome-user-share-sv.omf
@dirrmtry share/locale/zh_HK
@dirrmtry share/locale/te/LC_MESSAGES
@dirrmtry share/locale/te
+@dirrmtry share/locale/sr@latin/LC_MESSAGES
+@dirrmtry share/locale/sr@latin
@dirrmtry share/locale/rw/LC_MESSAGES
@dirrmtry share/locale/rw
@dirrmtry share/locale/oc/LC_MESSAGES
@dirrmtry share/locale/oc
@dirrmtry share/locale/mr/LC_MESSAGES
@dirrmtry share/locale/mr
+@dirrmtry share/locale/mai/LC_MESSAGES
+@dirrmtry share/locale/mai
@dirrmtry share/locale/dz/LC_MESSAGES
@dirrmtry share/locale/dz
+@dirrmtry share/locale/ca@valencia/LC_MESSAGES
+@dirrmtry share/locale/ca@valencia
@dirrmtry share/locale/bn_IN/LC_MESSAGES
@dirrmtry share/locale/bn_IN
@dirrmtry share/locale/as/LC_MESSAGES