aboutsummaryrefslogtreecommitdiff
path: root/www/gnome-web-photo/Makefile
diff options
context:
space:
mode:
authorMartin Wilke <miwi@FreeBSD.org>2011-03-25 11:49:32 +0000
committerMartin Wilke <miwi@FreeBSD.org>2011-03-25 11:49:32 +0000
commit6541cf841c8dd6ae7328000d47e8a2223305f48e (patch)
tree540715f9f0cb45b4041d403a1539232928658ab5 /www/gnome-web-photo/Makefile
parenteaf7075a977d877a007537a4ec2e1f48f8bd018a (diff)
downloadports-6541cf841c8dd6ae7328000d47e8a2223305f48e.tar.gz
ports-6541cf841c8dd6ae7328000d47e8a2223305f48e.zip
Notes
Diffstat (limited to 'www/gnome-web-photo/Makefile')
-rw-r--r--www/gnome-web-photo/Makefile15
1 files changed, 10 insertions, 5 deletions
diff --git a/www/gnome-web-photo/Makefile b/www/gnome-web-photo/Makefile
index 41f208b0762d..c5d56376f428 100644
--- a/www/gnome-web-photo/Makefile
+++ b/www/gnome-web-photo/Makefile
@@ -8,27 +8,32 @@
#
PORTNAME= gnome-web-photo
-PORTVERSION= 0.9
+PORTVERSION= 0.10
CATEGORIES= www
MASTER_SITES= GNOME
MAINTAINER= ports@FreeBSD.org
COMMENT= Tool to generate full-size image files and thumbnails
+LIB_DEPENDS= webkit-1.0.13:${PORTSDIR}/www/webkit-gtk2
+
+LICENSE= LGPL21 LGPL3
+LICENSE_COMB= dual
+
USE_BZIP2= yes
USE_GNOME= gconf2 gnomehack gnomeprefix
-USE_GECKO= libxul
USE_GETTEXT= yes
USE_GMAKE= yes
GNU_CONFIGURE= yes
-CONFIGURE_ENV= CPPFLAGS="${CPPFLAGS}" LDFLAGS="${LDFLAGS}"
+CONFIGURE_ENV= LDFLAGS="${LDFLAGS}"
+CONFIGURE_ARGS= --with-gtk=2.0
+
GCONF_SCHEMAS= thumbnailer.schemas
-CFLAGS+= `pkg-config --cflags-only-I libxul`
CPPFLAGS= -I${LOCALBASE}/include
LDFLAGS= -L${LOCALBASE}/lib
post-patch:
- @${REINPLACE_CMD} -e 's|libxul-unstable||g' ${WRKSRC}/configure
+ @${REINPLACE_CMD} -e '/test/s|==|=|g' ${WRKSRC}/configure
.include <bsd.port.mk>