aboutsummaryrefslogtreecommitdiff
path: root/www/gnome-web-photo
diff options
context:
space:
mode:
authorMarcelo Araujo <araujo@FreeBSD.org>2010-10-22 21:06:21 +0000
committerMarcelo Araujo <araujo@FreeBSD.org>2010-10-22 21:06:21 +0000
commit0eddd118015d20a0d87ecdda1bbcdd591467f8fe (patch)
tree5b77cfdfd992aba9fbf9a355deba81e9fd726e67 /www/gnome-web-photo
parent0cb0f83e1ac3f6b2d4bf5500c92f23f295f87149 (diff)
downloadports-0eddd118015d20a0d87ecdda1bbcdd591467f8fe.tar.gz
ports-0eddd118015d20a0d87ecdda1bbcdd591467f8fe.zip
Notes
Diffstat (limited to 'www/gnome-web-photo')
-rw-r--r--www/gnome-web-photo/Makefile20
-rw-r--r--www/gnome-web-photo/distinfo6
-rw-r--r--www/gnome-web-photo/files/patch-src__Writer.cpp12
-rw-r--r--www/gnome-web-photo/pkg-plist9
4 files changed, 32 insertions, 15 deletions
diff --git a/www/gnome-web-photo/Makefile b/www/gnome-web-photo/Makefile
index 6e0420bda600..41f208b0762d 100644
--- a/www/gnome-web-photo/Makefile
+++ b/www/gnome-web-photo/Makefile
@@ -8,8 +8,7 @@
#
PORTNAME= gnome-web-photo
-PORTVERSION= 0.2
-PORTREVISION= 9
+PORTVERSION= 0.9
CATEGORIES= www
MASTER_SITES= GNOME
@@ -17,16 +16,19 @@ MAINTAINER= ports@FreeBSD.org
COMMENT= Tool to generate full-size image files and thumbnails
USE_BZIP2= yes
-USE_GECKO= seamonkey
-GNU_CONFIGURE= yes
-CONFIGURE_ARGS= --with-gecko=${GECKO}
+USE_GNOME= gconf2 gnomehack gnomeprefix
+USE_GECKO= libxul
+USE_GETTEXT= yes
USE_GMAKE= yes
-USE_GNOME= gnomevfs2 gnomehack gnomeprefix
+GNU_CONFIGURE= yes
+CONFIGURE_ENV= CPPFLAGS="${CPPFLAGS}" LDFLAGS="${LDFLAGS}"
GCONF_SCHEMAS= thumbnailer.schemas
-.include <bsd.port.pre.mk>
+CFLAGS+= `pkg-config --cflags-only-I libxul`
+CPPFLAGS= -I${LOCALBASE}/include
+LDFLAGS= -L${LOCALBASE}/lib
post-patch:
- @${REINPLACE_CMD} -e 's|libpng|libpng14|' ${WRKSRC}/configure
+ @${REINPLACE_CMD} -e 's|libxul-unstable||g' ${WRKSRC}/configure
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/www/gnome-web-photo/distinfo b/www/gnome-web-photo/distinfo
index ed5b8e643a0b..a28d79dacc8f 100644
--- a/www/gnome-web-photo/distinfo
+++ b/www/gnome-web-photo/distinfo
@@ -1,3 +1,3 @@
-MD5 (gnome-web-photo-0.2.tar.bz2) = 177641fa35cc66771bfa574e17768605
-SHA256 (gnome-web-photo-0.2.tar.bz2) = c8e441cfa96a62e37d6a031ca15abc7782318a834362879bb8c311aadd475ee6
-SIZE (gnome-web-photo-0.2.tar.bz2) = 298503
+MD5 (gnome-web-photo-0.9.tar.bz2) = 62952330a62b463df5fef315f4a7cb93
+SHA256 (gnome-web-photo-0.9.tar.bz2) = b959fa061bd4d839bb13b9ec132ebdec50c908de6ea0c1667c065b41be8830e4
+SIZE (gnome-web-photo-0.9.tar.bz2) = 317068
diff --git a/www/gnome-web-photo/files/patch-src__Writer.cpp b/www/gnome-web-photo/files/patch-src__Writer.cpp
new file mode 100644
index 000000000000..2fcc3279f0e6
--- /dev/null
+++ b/www/gnome-web-photo/files/patch-src__Writer.cpp
@@ -0,0 +1,12 @@
+--- src/Writer.cpp.orig 2009-04-21 00:43:33.000000000 +0900
++++ src/Writer.cpp 2010-10-05 00:43:15.000000000 +0900
+@@ -197,7 +197,8 @@
+ width = NSAppUnitsToIntPixels(cutout.width, p2a);
+ height = NSAppUnitsToIntPixels(cutout.height, p2a);
+
+- rv = presShell->RenderDocument(cutout, PR_FALSE, PR_TRUE,
++ rv = presShell->RenderDocument(cutout,
++ nsIPresShell::RENDER_IGNORE_VIEWPORT_SCROLLING,
+ NS_RGB(255, 255, 255), context);
+ if (NS_SUCCEEDED(rv)) {
+ imgContext->DrawSurface(surface, gfxSize(width, height));
diff --git a/www/gnome-web-photo/pkg-plist b/www/gnome-web-photo/pkg-plist
index 5e0f7dedbbaf..4f9fb271f694 100644
--- a/www/gnome-web-photo/pkg-plist
+++ b/www/gnome-web-photo/pkg-plist
@@ -1,6 +1,9 @@
bin/gnome-web-photo
bin/gnome-web-print
bin/gnome-web-thumbnail
-share/gnome-web-photo/prefs.js
-share/gnome-web-photo/style.css
-@dirrm share/gnome-web-photo
+%%DATADIR%%/prefs.js
+%%DATADIR%%/style.css
+share/locale/ja/LC_MESSAGES/gnome-web-photo.mo
+share/locale/oc/LC_MESSAGES/gnome-web-photo.mo
+share/locale/sv/LC_MESSAGES/gnome-web-photo.mo
+@dirrm %%DATADIR%%