aboutsummaryrefslogtreecommitdiff
path: root/www/gohugo
diff options
context:
space:
mode:
authorSteve Wills <swills@FreeBSD.org>2018-11-27 20:05:48 +0000
committerSteve Wills <swills@FreeBSD.org>2018-11-27 20:05:48 +0000
commit86cf92bd64bf3ee1a171dd53832a0296d5052288 (patch)
treeea845ed54c8fc5fddc85c914cc0a03c8eea627a0 /www/gohugo
parentf6978f12e61a5a0e71fe7a7c3ef2ebe5dbc07e32 (diff)
downloadports-86cf92bd64bf3ee1a171dd53832a0296d5052288.tar.gz
ports-86cf92bd64bf3ee1a171dd53832a0296d5052288.zip
Notes
Diffstat (limited to 'www/gohugo')
-rw-r--r--www/gohugo/Makefile18
-rw-r--r--www/gohugo/distinfo34
2 files changed, 32 insertions, 20 deletions
diff --git a/www/gohugo/Makefile b/www/gohugo/Makefile
index 891d1f6748bb..57be7189a231 100644
--- a/www/gohugo/Makefile
+++ b/www/gohugo/Makefile
@@ -2,7 +2,7 @@
PORTNAME= hugo
DISTVERSIONPREFIX= v
-DISTVERSION= 0.50
+DISTVERSION= 0.51
CATEGORIES= www
PKGNAMEPREFIX= go
DIST_SUBDIR= ${PKGNAMEPREFIX}${PORTNAME}
@@ -22,18 +22,20 @@ GH_TUPLE= BurntSushi:locker:a6e239e:locker/src/github.com/BurntSushi/locker \
PuerkitoBio:purell:v1.1.0:purell/src/github.com/PuerkitoBio/purell \
PuerkitoBio:urlesc:de5bf2a:urlesc/src/github.com/PuerkitoBio/urlesc \
alecthomas:assert:405dbfe:assert/src/github.com/alecthomas/assert \
- alecthomas:chroma:v0.5.0:chroma/src/github.com/alecthomas/chroma \
+ alecthomas:chroma:v0.6.0:chroma/src/github.com/alecthomas/chroma \
alecthomas:colour:60882d9:colour/src/github.com/alecthomas/colour \
alecthomas:repr:117648c:repr/src/github.com/alecthomas/repr \
bep:debounce:v1.1.0:debounce/src/github.com/bep/debounce \
bep:gitmap:v1.0.0:gitmap/src/github.com/bep/gitmap \
bep:go-tocss:v0.5.0:go_tocss/src/github.com/bep/go-tocss \
chaseadamsio:goorgeous:v1.1.0:goorgeous/src/github.com/chaseadamsio/goorgeous \
+ cheekybits:is:68e9c06:is/src/github.com/cheekybits/is \
cpuguy83:go-md2man:v1.0.8:go_md2man/src/github.com/cpuguy83/go-md2man \
danwakefield:fnmatch:cbb64ac:fnmatch/src/github.com/danwakefield/fnmatch \
davecgh:go-spew:v1.1.1:go_spew/src/github.com/davecgh/go-spew \
disintegration:imaging:v1.5.0:imaging/src/github.com/disintegration/imaging \
dlclark:regexp2:v1.1.6:regexp2/src/github.com/dlclark/regexp2 \
+ dustin:go-humanize:v1.0.0:go_humanize/src/github.com/dustin/go-humanize \
eknkc:amber:cdade1c:amber/src/github.com/eknkc/amber \
fortytw2:leaktest:v1.2.0:leaktest/src/github.com/fortytw2/leaktest \
fsnotify:fsnotify:v1.4.7:fsnotify/src/github.com/fsnotify/fsnotify \
@@ -52,11 +54,13 @@ GH_TUPLE= BurntSushi:locker:a6e239e:locker/src/github.com/BurntSushi/locker \
magefile:mage:v1.4.0:mage/src/github.com/magefile/mage \
magiconair:properties:v1.8.0:properties/src/github.com/magiconair/properties \
markbates:inflect:a12c3ae:inflect/src/github.com/markbates/inflect \
+ matryer:try:9ac251b:try/src/github.com/matryer/try \
mattn:go-isatty:v0.0.4:go_isatty/src/github.com/mattn/go-isatty \
mattn:go-runewidth:v0.0.3:go_runewidth/src/github.com/mattn/go-runewidth \
miekg:mmark:v1.3.6:mmark/src/github.com/miekg/mmark \
mitchellh:hashstructure:v1.0.0:hashstructure/src/github.com/mitchellh/hashstructure \
mitchellh:mapstructure:v1.0.0:mapstructure/src/github.com/mitchellh/mapstructure \
+ bep:mapstructure:bb74f1d:bep_mapstructure/src/github.com/bep/mapstructure \
muesli:smartcrop:f6ebaa7:smartcrop/src/github.com/muesli/smartcrop \
nfnt:resize:83c6a99:resize/src/github.com/nfnt/resize \
nicksnyder:go-i18n:v1.10.0:go_i18n/src/github.com/nicksnyder/go-i18n \
@@ -74,23 +78,23 @@ GH_TUPLE= BurntSushi:locker:a6e239e:locker/src/github.com/BurntSushi/locker \
spf13:fsync:12a01e6:fsync/src/github.com/spf13/fsync \
spf13:jwalterweatherman:94f6ae3:jwalterweatherman/src/github.com/spf13/jwalterweatherman \
spf13:nitro:24d7ef3:nitro/src/github.com/spf13/nitro \
- spf13:pflag:v1.0.2:pflag/src/github.com/spf13/pflag \
+ spf13:pflag:v1.0.3:pflag/src/github.com/spf13/pflag \
spf13:viper:v1.2.0:viper/src/github.com/spf13/viper \
stretchr:testify:f2347ac:testify/src/github.com/stretchr/testify \
- tdewolff:minify:v2.3.6:minify/src/github.com/tdewolff/minify \
- tdewolff:parse:fced451:parse/src/github.com/tdewolff/parse \
+ tdewolff:minify:v2.3.7:minify/src/github.com/tdewolff/minify \
+ tdewolff:parse:v2.3.5:parse/src/github.com/tdewolff/parse \
tdewolff:test:v1.0.0:test/src/github.com/tdewolff/test \
wellington:go-libsass:615eaa4:go_libsass/src/github.com/wellington/go-libsass \
yosssi:ace:v0.0.5:ace/src/github.com/yosssi/ace \
golang:image:c73c2af:image/src/golang.org/x/image \
golang:net:161cd47:net/src/golang.org/x/net \
golang:sync:1d60e46:sync/src/golang.org/x/sync \
- golang:sys:d0be072:sys/src/golang.org/x/sys \
+ golang:sys:9b800f9:sys/src/golang.org/x/sys \
golang:text:v0.3.0:text/src/golang.org/x/text \
go-check:check:788fd78:check/src/gopkg.in/check.v1 \
go-yaml:yaml:v2.2.1:yaml/src/gopkg.in/yaml.v2
-COMMIT_ID= f5be59920461366d4481cf7536b2d2bd42a2c75e
+COMMIT_ID= f3d519079371723dbd812dba3fef3695e0b41946
OPTIONS_DEFINE= MANPAGES EXTENDED
diff --git a/www/gohugo/distinfo b/www/gohugo/distinfo
index 15675631949e..e241916e5d19 100644
--- a/www/gohugo/distinfo
+++ b/www/gohugo/distinfo
@@ -1,6 +1,6 @@
-TIMESTAMP = 1540828063
-SHA256 (gohugo/gohugoio-hugo-v0.50_GH0.tar.gz) = 4dade11c38aace73877750ea8d67ab2ccccf643751754d5a4afdd8d62e655012
-SIZE (gohugo/gohugoio-hugo-v0.50_GH0.tar.gz) = 19943257
+TIMESTAMP = 1543260999
+SHA256 (gohugo/gohugoio-hugo-v0.51_GH0.tar.gz) = 5433920c3830df4217c2e6b4e80958543b00c36a890fe4b3c990cfcf5fa46e33
+SIZE (gohugo/gohugoio-hugo-v0.51_GH0.tar.gz) = 19948327
SHA256 (gohugo/BurntSushi-locker-a6e239e_GH0.tar.gz) = 6bdc1b865e2e27dd92921c0e4c3aa743156bb5d2cf227af1d0e80573568bcd4a
SIZE (gohugo/BurntSushi-locker-a6e239e_GH0.tar.gz) = 2108
SHA256 (gohugo/BurntSushi-toml-a368813_GH0.tar.gz) = 68dc067c4105cd20a642ddf1f4acaada7474c1b58e5b249d4bd9b0d7e8edebc2
@@ -11,8 +11,8 @@ SHA256 (gohugo/PuerkitoBio-urlesc-de5bf2a_GH0.tar.gz) = 0d4b469d8d1dfe12e740661d
SIZE (gohugo/PuerkitoBio-urlesc-de5bf2a_GH0.tar.gz) = 6796
SHA256 (gohugo/alecthomas-assert-405dbfe_GH0.tar.gz) = 5f9a1b6f048bb3346b2db0c52061ef3330583eba4dfdb3a3309e234fded670e4
SIZE (gohugo/alecthomas-assert-405dbfe_GH0.tar.gz) = 71064
-SHA256 (gohugo/alecthomas-chroma-v0.5.0_GH0.tar.gz) = 6ef69c5aa07cfb697e77ea1f793d0a0cbd52df7e1e0109ae0c91134138a451c5
-SIZE (gohugo/alecthomas-chroma-v0.5.0_GH0.tar.gz) = 317226
+SHA256 (gohugo/alecthomas-chroma-v0.6.0_GH0.tar.gz) = be30aa45fac2d401f28fc49c87b1fa315f61273da2097eaba412802e76de17dd
+SIZE (gohugo/alecthomas-chroma-v0.6.0_GH0.tar.gz) = 321145
SHA256 (gohugo/alecthomas-colour-60882d9_GH0.tar.gz) = f7eafbd51169a9c0c3ba6a0b1dc49038eb38733058aae51c3157a5ec86751fe4
SIZE (gohugo/alecthomas-colour-60882d9_GH0.tar.gz) = 3479
SHA256 (gohugo/alecthomas-repr-117648c_GH0.tar.gz) = 5e544f5c42a439e08cc11fecf5d939a9e47be1b554db84bac50c63eb813e7cb2
@@ -25,6 +25,8 @@ SHA256 (gohugo/bep-go-tocss-v0.5.0_GH0.tar.gz) = 1875ceafec32349c7c174597db766b6
SIZE (gohugo/bep-go-tocss-v0.5.0_GH0.tar.gz) = 5370
SHA256 (gohugo/chaseadamsio-goorgeous-v1.1.0_GH0.tar.gz) = e8e1ac258e9f2d0a86f415e03fc7953f67a514710b3b214ef7db57a15febe52f
SIZE (gohugo/chaseadamsio-goorgeous-v1.1.0_GH0.tar.gz) = 34320
+SHA256 (gohugo/cheekybits-is-68e9c06_GH0.tar.gz) = c3789d05b0bd0c02ae413b8c7e2f500e393e17cbaa1d0f21ba1fe370bf019dca
+SIZE (gohugo/cheekybits-is-68e9c06_GH0.tar.gz) = 5850
SHA256 (gohugo/cpuguy83-go-md2man-v1.0.8_GH0.tar.gz) = 84e443c78d048f4a609743704b6bff5c83473691a0793c577ebb9b1f7577c9d5
SIZE (gohugo/cpuguy83-go-md2man-v1.0.8_GH0.tar.gz) = 79284
SHA256 (gohugo/danwakefield-fnmatch-cbb64ac_GH0.tar.gz) = e187c66e99cdae6474edc59c1a63245e8e9428c4035c36e76c2cfe0b46ca7a38
@@ -35,6 +37,8 @@ SHA256 (gohugo/disintegration-imaging-v1.5.0_GH0.tar.gz) = 683391ca41821e45590f0
SIZE (gohugo/disintegration-imaging-v1.5.0_GH0.tar.gz) = 1886547
SHA256 (gohugo/dlclark-regexp2-v1.1.6_GH0.tar.gz) = 81ede5b49ff46bd1c686416c52605aa4698b9dce07d011581c49a1d35b8a5239
SIZE (gohugo/dlclark-regexp2-v1.1.6_GH0.tar.gz) = 203691
+SHA256 (gohugo/dustin-go-humanize-v1.0.0_GH0.tar.gz) = e4540bd50ac855143b4f2e509313079c50cf5d8774f09cc10dbca5ae9803d8ba
+SIZE (gohugo/dustin-go-humanize-v1.0.0_GH0.tar.gz) = 17260
SHA256 (gohugo/eknkc-amber-cdade1c_GH0.tar.gz) = 3e2f7d217f104aa055cd9544cc3181d75406e5f1c11a191361e602fe25ae8e15
SIZE (gohugo/eknkc-amber-cdade1c_GH0.tar.gz) = 22601
SHA256 (gohugo/fortytw2-leaktest-v1.2.0_GH0.tar.gz) = c90171f1a56ddbb9a34e41ab21262606ca653719ae4bc15827baf2a09e523ac3
@@ -71,6 +75,8 @@ SHA256 (gohugo/magiconair-properties-v1.8.0_GH0.tar.gz) = f6c732fe6031e2cf72c6eb
SIZE (gohugo/magiconair-properties-v1.8.0_GH0.tar.gz) = 29504
SHA256 (gohugo/markbates-inflect-a12c3ae_GH0.tar.gz) = f2849b7cd73f15d391ccc1375e0430f7c3ed32fb612f5a2834015450d0d0491a
SIZE (gohugo/markbates-inflect-a12c3ae_GH0.tar.gz) = 10753
+SHA256 (gohugo/matryer-try-9ac251b_GH0.tar.gz) = 6eec844ce4fc732db6fc59a12a9bbdc75448945816eef948ce738b524ecde9ac
+SIZE (gohugo/matryer-try-9ac251b_GH0.tar.gz) = 3039
SHA256 (gohugo/mattn-go-isatty-v0.0.4_GH0.tar.gz) = a6228abe42ccfcad4b17c176117ccf2822d06bde51dc437852854056d8737f12
SIZE (gohugo/mattn-go-isatty-v0.0.4_GH0.tar.gz) = 3377
SHA256 (gohugo/mattn-go-runewidth-v0.0.3_GH0.tar.gz) = 398ec709b006664e527040770056156cb225233d8b44b5a59ba2f5f5f3fa885e
@@ -81,6 +87,8 @@ SHA256 (gohugo/mitchellh-hashstructure-v1.0.0_GH0.tar.gz) = 48cad81434c28dc8c045
SIZE (gohugo/mitchellh-hashstructure-v1.0.0_GH0.tar.gz) = 6507
SHA256 (gohugo/mitchellh-mapstructure-v1.0.0_GH0.tar.gz) = 6eddc2ee4c69177e6b3a47e134277663f7e70b1f23b6f05908503db9d5ad5457
SIZE (gohugo/mitchellh-mapstructure-v1.0.0_GH0.tar.gz) = 18841
+SHA256 (gohugo/bep-mapstructure-bb74f1d_GH0.tar.gz) = 5bf27fc22a2feb060c65ff643880a8ac180fac9326a86b82d6a3eabe78fa9738
+SIZE (gohugo/bep-mapstructure-bb74f1d_GH0.tar.gz) = 18666
SHA256 (gohugo/muesli-smartcrop-f6ebaa7_GH0.tar.gz) = 337fa158b74dd3b2fd4904737329789f7765fe88c815cb099590d9717cc80085
SIZE (gohugo/muesli-smartcrop-f6ebaa7_GH0.tar.gz) = 448029
SHA256 (gohugo/nfnt-resize-83c6a99_GH0.tar.gz) = e439f28cce9090eff9186f0caa346c498859b3e068663fd7055507ce37f31a33
@@ -115,16 +123,16 @@ SHA256 (gohugo/spf13-jwalterweatherman-94f6ae3_GH0.tar.gz) = e72da14aeca6a960169
SIZE (gohugo/spf13-jwalterweatherman-94f6ae3_GH0.tar.gz) = 6872
SHA256 (gohugo/spf13-nitro-24d7ef3_GH0.tar.gz) = e64c8d195990c3aa57c47cc4f090b1f575fa712b8b2fa3f8bdb2dc1b76ec440a
SIZE (gohugo/spf13-nitro-24d7ef3_GH0.tar.gz) = 6741
-SHA256 (gohugo/spf13-pflag-v1.0.2_GH0.tar.gz) = beffdf702402f3e4483c2ed24f9ee57997d1a48a5cd5ccf44ca6d63ceb24fa30
-SIZE (gohugo/spf13-pflag-v1.0.2_GH0.tar.gz) = 44042
+SHA256 (gohugo/spf13-pflag-v1.0.3_GH0.tar.gz) = 9e57f86f493f04d9077fccd04e7139ebf243dd544e917ab83d35729b3e54a124
+SIZE (gohugo/spf13-pflag-v1.0.3_GH0.tar.gz) = 46002
SHA256 (gohugo/spf13-viper-v1.2.0_GH0.tar.gz) = 71207a443c55239a54a7e5b91bfc38627ce3b53e7649b4b70d050bfa457804db
SIZE (gohugo/spf13-viper-v1.2.0_GH0.tar.gz) = 34451
SHA256 (gohugo/stretchr-testify-f2347ac_GH0.tar.gz) = 3d9482c54e66f64fad782341e784d52e994f2b24dd5e71429c3ca14cb29028c8
SIZE (gohugo/stretchr-testify-f2347ac_GH0.tar.gz) = 101555
-SHA256 (gohugo/tdewolff-minify-v2.3.6_GH0.tar.gz) = d596f276fe55a4887268af160942110d27a8efb19219a28519cf920eca31cbdf
-SIZE (gohugo/tdewolff-minify-v2.3.6_GH0.tar.gz) = 2124420
-SHA256 (gohugo/tdewolff-parse-fced451_GH0.tar.gz) = 94feda5f1e428f9d1a46fd8dc8427738de2423d09c36e33d5816a12a398cb22d
-SIZE (gohugo/tdewolff-parse-fced451_GH0.tar.gz) = 74994
+SHA256 (gohugo/tdewolff-minify-v2.3.7_GH0.tar.gz) = 84ff61fc766cc8ec84ba126ab2fe93469d81a1c238bbe3b97075b83118042d8c
+SIZE (gohugo/tdewolff-minify-v2.3.7_GH0.tar.gz) = 2125512
+SHA256 (gohugo/tdewolff-parse-v2.3.5_GH0.tar.gz) = e7d691607f6f53336af7c03a92ba24b78c709513b31a31e719620d4d2d07d813
+SIZE (gohugo/tdewolff-parse-v2.3.5_GH0.tar.gz) = 75027
SHA256 (gohugo/tdewolff-test-v1.0.0_GH0.tar.gz) = 59a698a716e87203b2cf58c7ba9a11a1c75400bff22faf6a4a34fcd2a789e267
SIZE (gohugo/tdewolff-test-v1.0.0_GH0.tar.gz) = 2606
SHA256 (gohugo/wellington-go-libsass-615eaa4_GH0.tar.gz) = c61167dc546c15a0ac085adc6e96305af60b80b4ab5dc763ee90481c0539c21d
@@ -137,8 +145,8 @@ SHA256 (gohugo/golang-net-161cd47_GH0.tar.gz) = 03a66d67eb211331fb5c3941a4f7fef1
SIZE (gohugo/golang-net-161cd47_GH0.tar.gz) = 965339
SHA256 (gohugo/golang-sync-1d60e46_GH0.tar.gz) = 526fab48f250f45ec22dbfd2700df629871ea8aeb8289a49c58f4fc606a7a5e5
SIZE (gohugo/golang-sync-1d60e46_GH0.tar.gz) = 16327
-SHA256 (gohugo/golang-sys-d0be072_GH0.tar.gz) = 9bebf0bdf2149703e369ccde42da5f705db68cdf3d31438e3ec9e7f03f99ae20
-SIZE (gohugo/golang-sys-d0be072_GH0.tar.gz) = 1075457
+SHA256 (gohugo/golang-sys-9b800f9_GH0.tar.gz) = fb70e17a193f1bf01728e2ed6c763abd816fdd88c591aaa4fa71cb7472d011b0
+SIZE (gohugo/golang-sys-9b800f9_GH0.tar.gz) = 1109389
SHA256 (gohugo/go-check-check-788fd78_GH0.tar.gz) = 7348808a92ff352cf0d68a2140a10db9b4758bfb904e0d7a5070d481b4b82d68
SIZE (gohugo/go-check-check-788fd78_GH0.tar.gz) = 31590
SHA256 (gohugo/go-yaml-yaml-v2.2.1_GH0.tar.gz) = 33218aa3bd60a307fe14e66b970473cb411bb6ca3d4f4a5e30c97b44f9b4e84b