aboutsummaryrefslogtreecommitdiff
path: root/www/gohugo
diff options
context:
space:
mode:
authorSteve Wills <swills@FreeBSD.org>2016-07-15 15:01:39 +0000
committerSteve Wills <swills@FreeBSD.org>2016-07-15 15:01:39 +0000
commit142856484e02a39217c386f9daff32cc81b9c95d (patch)
tree89deb8367bbf518cddf92b6f115d0cc57a6c8fab /www/gohugo
parent894aa44247b7596fe146b6beb8e1bb5998bf7556 (diff)
Notes
Diffstat (limited to 'www/gohugo')
-rw-r--r--www/gohugo/Makefile146
-rw-r--r--www/gohugo/distinfo70
-rw-r--r--www/gohugo/pkg-descr11
-rw-r--r--www/gohugo/pkg-plist24
4 files changed, 251 insertions, 0 deletions
diff --git a/www/gohugo/Makefile b/www/gohugo/Makefile
new file mode 100644
index 000000000000..26106a50e9ce
--- /dev/null
+++ b/www/gohugo/Makefile
@@ -0,0 +1,146 @@
+# $FreeBSD$
+
+PORTNAME= hugo
+PORTVERSION= 0.16
+DISTVERSIONPREFIX= v
+CATEGORIES= www
+PKGNAMEPREFIX= go
+DIST_SUBDIR= ${PKGNAMEPREFIX}${PORTNAME}
+
+MAINTAINER= ben.lavery@hashbang0.com
+COMMENT= Fast and modern static website engine
+
+LICENSE= APACHE20
+
+BUILD_DEPENDS= go>=1.5.0:lang/go
+
+USE_GITHUB= yes
+GH_ACCOUNT= eknkc:amber \
+ spf13:DEFAULT,afero,jWalterWeatherman,cast,cobra \
+ spf13:fsync,nitro,pflag,viper \
+ yosssi:ace \
+ BurntSushi:toml \
+ PuerkitoBio:purell,urlesc \
+ bep:inflect \
+ dchest:cssmin \
+ fsnotify:fsnotify \
+ gorilla:websocket \
+ hashicorp:hcl \
+ kardianos:osext \
+ kr:fs \
+ kyokomi:emoji \
+ magiconair:properties \
+ miekg:mmark \
+ mitchellh:mapstructure \
+ pkg:errors,sftp \
+ russross:blackfriday \
+ shurcooL:sanitized_anchor_name \
+ golang:crypto,sys,text \
+ go-yaml:yaml \
+ cpuguy83:go_md2man
+GH_PROJECT= amber:amber afero:afero \
+ jWalterWeatherman:jWalterWeatherman ace:ace toml:toml \
+ purell:purell urlesc:urlesc inflect:inflect cssmin:cssmin \
+ fsnotify:fsnotify websocket:websocket hcl:hcl osext:osext \
+ fs:fs emoji:emoji properties:properties mmark:mmark \
+ mapstructure:mapstructure errors:errors sftp:sftp \
+ go-md2man:go_md2man blackfriday:blackfriday \
+ sanitized_anchor_name:sanitized_anchor_name cast:cast \
+ cobra:cobra fsync:fsync nitro:nitro pflag:pflag viper:viper \
+ crypto:crypto sys:sys text:text yaml:yaml
+GH_TAGNAME= 91774f0:amber 9d16de2:afero \
+ 33c24e7:jWalterWeatherman 71afeb7:ace bec2dac:toml \
+ 1d5d1cf:purell 5fa9ff0:urlesc b896c45:inflect \
+ 2724a9c:go_md2man fb8d9b4:cssmin a8a77c9:fsnotify \
+ a836c37:websocket d8c773c:hcl 29ae4ff:osext 2788f0d:fs \
+ 17c5e70:emoji e2f061e:properties adb5c3e:mmark \
+ d2dd026:mapstructure a2d6902:errors 57fcf4a:sftp \
+ 1d6b8e9:blackfriday 10ef21a:sanitized_anchor_name 27b586b:cast \
+ a272c3c:cobra 1773df7:fsync 24d7ef3:nitro 3678644:pflag \
+ c1ccc37:viper 2c99acd:crypto a408501:sys d5d7737:text \
+ a83829b:yaml
+
+STRIP= # stripping can break go binaries
+
+post-extract:
+ @${MKDIR} ${WRKSRC}/src/github.com/BurntSushi
+ @${MKDIR} ${WRKSRC}/src/github.com/PuerkitoBio
+ @${MKDIR} ${WRKSRC}/src/github.com/bep
+ @${MKDIR} ${WRKSRC}/src/github.com/cpuguy83
+ @${MKDIR} ${WRKSRC}/src/github.com/dchest
+ @${MKDIR} ${WRKSRC}/src/github.com/eknkc
+ @${MKDIR} ${WRKSRC}/src/github.com/fsnotify
+ @${MKDIR} ${WRKSRC}/src/github.com/gorilla
+ @${MKDIR} ${WRKSRC}/src/github.com/hashicorp
+ @${MKDIR} ${WRKSRC}/src/github.com/kardianos
+ @${MKDIR} ${WRKSRC}/src/github.com/kr
+ @${MKDIR} ${WRKSRC}/src/github.com/kyokomi
+ @${MKDIR} ${WRKSRC}/src/github.com/magiconair
+ @${MKDIR} ${WRKSRC}/src/github.com/miekg
+ @${MKDIR} ${WRKSRC}/src/github.com/mitchellh
+ @${MKDIR} ${WRKSRC}/src/github.com/pkg
+ @${MKDIR} ${WRKSRC}/src/github.com/russross
+ @${MKDIR} ${WRKSRC}/src/github.com/shurcooL
+ @${MKDIR} ${WRKSRC}/src/github.com/spf13
+ @${MKDIR} ${WRKSRC}/src/github.com/spf13/hugo
+ @${MKDIR} ${WRKSRC}/src/github.com/yosssi
+ @${MKDIR} ${WRKSRC}/src/golang.org/x
+ @${MKDIR} ${WRKSRC}/src/gopkg.in
+.for src in CONTRIBUTING.md Dockerfile LICENSE.md Makefile README.md bench.sh \
+ bufferpool commands create docs examples helpers hugofs \
+ hugolib livereload main.go parser requirements.txt source \
+ target tpl transform utils watcher wercker.yml
+ @${MV} ${WRKSRC}/${src} \
+ ${WRKSRC}/src/github.com/spf13/${PORTNAME}
+.endfor
+ @${MV} ${WRKSRC_toml} ${WRKSRC}/src/github.com/BurntSushi/toml
+ @${MV} ${WRKSRC_purell} ${WRKSRC}/src/github.com/PuerkitoBio/purell
+ @${MV} ${WRKSRC_urlesc} ${WRKSRC}/src/github.com/PuerkitoBio/urlesc
+ @${MV} ${WRKSRC_inflect} ${WRKSRC}/src/github.com/bep/inflect
+ @${MV} ${WRKSRC_go_md2man} ${WRKSRC}/src/github.com/cpuguy83/go-md2man
+ @${MV} ${WRKSRC_cssmin} ${WRKSRC}/src/github.com/dchest/cssmin
+ @${MV} ${WRKSRC_amber} ${WRKSRC}/src/github.com/eknkc/amber
+ @${MV} ${WRKSRC_fsnotify} ${WRKSRC}/src/github.com/fsnotify/fsnotify
+ @${MV} ${WRKSRC_websocket} ${WRKSRC}/src/github.com/gorilla/websocket
+ @${MV} ${WRKSRC_hcl} ${WRKSRC}/src/github.com/hashicorp/hcl
+ @${MV} ${WRKSRC_osext} ${WRKSRC}/src/github.com/kardianos/osext
+ @${MV} ${WRKSRC_fs} ${WRKSRC}/src/github.com/kr/fs
+ @${MV} ${WRKSRC_emoji} ${WRKSRC}/src/github.com/kyokomi/emoji
+ @${MV} ${WRKSRC_properties} ${WRKSRC}/src/github.com/magiconair/properties
+ @${MV} ${WRKSRC_mmark} ${WRKSRC}/src/github.com/miekg/mmark
+ @${MV} ${WRKSRC_mapstructure} ${WRKSRC}/src/github.com/mitchellh/mapstructure
+ @${MV} ${WRKSRC_errors} ${WRKSRC}/src/github.com/pkg/errors
+ @${MV} ${WRKSRC_sftp} ${WRKSRC}/src/github.com/pkg/sftp
+ @${MV} ${WRKSRC_blackfriday} ${WRKSRC}/src/github.com/russross/blackfriday
+ @${MV} ${WRKSRC_sanitized_anchor_name} ${WRKSRC}/src/github.com/shurcooL/sanitized_anchor_name
+ @${MV} ${WRKSRC_afero} ${WRKSRC}/src/github.com/spf13/afero
+ @${MV} ${WRKSRC_cast} ${WRKSRC}/src/github.com/spf13/cast
+ @${MV} ${WRKSRC_cobra} ${WRKSRC}/src/github.com/spf13/cobra
+ @${MV} ${WRKSRC_fsync} ${WRKSRC}/src/github.com/spf13/fsync
+ @${MV} ${WRKSRC_jWalterWeatherman} ${WRKSRC}/src/github.com/spf13/jwalterweatherman
+ @${MV} ${WRKSRC_nitro} ${WRKSRC}/src/github.com/spf13/nitro
+ @${MV} ${WRKSRC_pflag} ${WRKSRC}/src/github.com/spf13/pflag
+ @${MV} ${WRKSRC_viper} ${WRKSRC}/src/github.com/spf13/viper
+ @${MV} ${WRKSRC_ace} ${WRKSRC}/src/github.com/yosssi/ace
+ @${MV} ${WRKSRC_crypto} ${WRKSRC}/src/golang.org/x/crypto
+ @${MV} ${WRKSRC_sys} ${WRKSRC}/src/golang.org/x/sys
+ @${MV} ${WRKSRC_text} ${WRKSRC}/src/golang.org/x/text
+ @${MV} ${WRKSRC_yaml} ${WRKSRC}/src/gopkg.in/yaml.v2
+
+do-build:
+ @cd ${WRKSRC}/src/github.com/spf13/${PORTNAME} && ${SETENV} GOPATH=${WRKSRC} go build -o bin/${PORTNAME}
+ @cd ${WRKSRC}/src/github.com/spf13/${PORTNAME} && ./bin/${PORTNAME} gen man --dir man/man1/
+
+do-install:
+ ${INSTALL_PROGRAM} ${WRKSRC}/src/github.com/spf13/${PORTNAME}/bin/${PORTNAME} ${STAGEDIR}/${PREFIX}/bin/${PORTNAME}
+.for i in hugo.1 hugo_benchmark.1 hugo_check.1 hugo_config.1 hugo_convert.1 \
+ hugo_convert_toJSON.1 hugo_convert_toTOML.1 \
+ hugo_convert_toYAML.1 hugo_gen.1 hugo_gen_autocomplete.1 \
+ hugo_gen_doc.1 hugo_gen_man.1 hugo_import.1 \
+ hugo_import_jekyll.1 hugo_list.1 hugo_list_drafts.1 \
+ hugo_list_future.1 hugo_new.1 hugo_new_site.1 hugo_new_theme.1 \
+ hugo_server.1 hugo_undraft.1 hugo_version.1
+ ${INSTALL_MAN} ${WRKSRC}/src/github.com/spf13/${PORTNAME}/man/man1/$i ${STAGEDIR}/${PREFIX}/man/man1
+.endfor
+
+.include <bsd.port.mk>
diff --git a/www/gohugo/distinfo b/www/gohugo/distinfo
new file mode 100644
index 000000000000..b4786a881ce6
--- /dev/null
+++ b/www/gohugo/distinfo
@@ -0,0 +1,70 @@
+SHA256 (gohugo/spf13-hugo-v0.16_GH0.tar.gz) = a2dbb243535ba69ae8709ffe5ba340951a8834d2c0e86bb76c88d99ad77ef9f5
+SIZE (gohugo/spf13-hugo-v0.16_GH0.tar.gz) = 8312978
+SHA256 (gohugo/eknkc-amber-91774f0_GH0.tar.gz) = 09233b6bd12426c1d10ec7d479ce48f10febc774529818e5266949e41135cf7b
+SIZE (gohugo/eknkc-amber-91774f0_GH0.tar.gz) = 21102
+SHA256 (gohugo/spf13-hugo-330639d_GH0.tar.gz) = 3bf98d2abe625e0fbed145214340ebd5398b5937fd2b8ca5aadd4c741c8cb17e
+SIZE (gohugo/spf13-hugo-330639d_GH0.tar.gz) = 8508257
+SHA256 (gohugo/spf13-afero-9d16de2_GH0.tar.gz) = 428259c024f2c62ec0bb9e6696d7a6ab9d297f7b729bd2481db6c1125bc9a325
+SIZE (gohugo/spf13-afero-9d16de2_GH0.tar.gz) = 40432
+SHA256 (gohugo/spf13-jWalterWeatherman-33c24e7_GH0.tar.gz) = d9c1b2d075d3e642acbc9fdf7a66c78092ca3d596d496cd43a5f724c94a6417f
+SIZE (gohugo/spf13-jWalterWeatherman-33c24e7_GH0.tar.gz) = 5939
+SHA256 (gohugo/spf13-cast-27b586b_GH0.tar.gz) = 736d949a8e9f328b74947bbfaa24155f157374a4f4083878cd6ea57eaa6a3182
+SIZE (gohugo/spf13-cast-27b586b_GH0.tar.gz) = 5874
+SHA256 (gohugo/spf13-cobra-a272c3c_GH0.tar.gz) = 6c750be20c875220411ab6eedf4d8b572233a5cab168c6a7a79023cf0fa6911a
+SIZE (gohugo/spf13-cobra-a272c3c_GH0.tar.gz) = 71162
+SHA256 (gohugo/spf13-fsync-1773df7_GH0.tar.gz) = 8790dceaa9247149f288cbd05d90c6530ec1b913b90505c8fe69567a82c6b398
+SIZE (gohugo/spf13-fsync-1773df7_GH0.tar.gz) = 4525
+SHA256 (gohugo/spf13-nitro-24d7ef3_GH0.tar.gz) = e64c8d195990c3aa57c47cc4f090b1f575fa712b8b2fa3f8bdb2dc1b76ec440a
+SIZE (gohugo/spf13-nitro-24d7ef3_GH0.tar.gz) = 6741
+SHA256 (gohugo/spf13-pflag-3678644_GH0.tar.gz) = b25854b7234a91e4a65d1c32f53ef3143c38913b52c623cc2d5bbfa865c83205
+SIZE (gohugo/spf13-pflag-3678644_GH0.tar.gz) = 31007
+SHA256 (gohugo/spf13-viper-c1ccc37_GH0.tar.gz) = 806f67e6d0cfdfb5b81a8c24113eb71abcf60ce972c670bf854390c9ee47e951
+SIZE (gohugo/spf13-viper-c1ccc37_GH0.tar.gz) = 23827
+SHA256 (gohugo/yosssi-ace-71afeb7_GH0.tar.gz) = 0c5b9c0aee525124277f479a30628ed7c82a03a4aa8f8ebdf33ca370e3cefcf9
+SIZE (gohugo/yosssi-ace-71afeb7_GH0.tar.gz) = 22057
+SHA256 (gohugo/BurntSushi-toml-bec2dac_GH0.tar.gz) = 00bdfffe6046a16e8eb8ac845fb3cd2d0808328b2501e32198535a6d40bf3687
+SIZE (gohugo/BurntSushi-toml-bec2dac_GH0.tar.gz) = 39906
+SHA256 (gohugo/PuerkitoBio-purell-1d5d1cf_GH0.tar.gz) = 4d8693f73501dbd6a7f2f14e9b4199b0def7da98dd488877780e86142d395ba7
+SIZE (gohugo/PuerkitoBio-purell-1d5d1cf_GH0.tar.gz) = 11262
+SHA256 (gohugo/PuerkitoBio-urlesc-5fa9ff0_GH0.tar.gz) = ec5ae929c84520957c5192176dcdd0ae7b65fb23cdd88cda01bd45d8ddea1f48
+SIZE (gohugo/PuerkitoBio-urlesc-5fa9ff0_GH0.tar.gz) = 6748
+SHA256 (gohugo/bep-inflect-b896c45_GH0.tar.gz) = 11918dab4c6b5f81a40830259cacec50b4d671e08a634a24da292040718211ee
+SIZE (gohugo/bep-inflect-b896c45_GH0.tar.gz) = 9661
+SHA256 (gohugo/dchest-cssmin-fb8d9b4_GH0.tar.gz) = fce78d1a1de9f9e516c24cd38856034f23fce22807ecb3c9566c383602109417
+SIZE (gohugo/dchest-cssmin-fb8d9b4_GH0.tar.gz) = 3354
+SHA256 (gohugo/fsnotify-fsnotify-a8a77c9_GH0.tar.gz) = 46a979871a08564b1a7c75f400c2eb396f5257e80cc875f13e5b9c1f464cf154
+SIZE (gohugo/fsnotify-fsnotify-a8a77c9_GH0.tar.gz) = 28449
+SHA256 (gohugo/gorilla-websocket-a836c37_GH0.tar.gz) = da10f1e1af6ce29538204d3fc4c2c997afdcb2186731629794484988cd68aa90
+SIZE (gohugo/gorilla-websocket-a836c37_GH0.tar.gz) = 35607
+SHA256 (gohugo/hashicorp-hcl-d8c773c_GH0.tar.gz) = b360b7a1548604038743831ed47f597a50cf680513ca7906a6344d0e7d9dc41a
+SIZE (gohugo/hashicorp-hcl-d8c773c_GH0.tar.gz) = 62857
+SHA256 (gohugo/kardianos-osext-29ae4ff_GH0.tar.gz) = ea3cb1266103fb9b07a01bfdf614b0b7384de8f6dd5573295973037165b8ce68
+SIZE (gohugo/kardianos-osext-29ae4ff_GH0.tar.gz) = 4618
+SHA256 (gohugo/kr-fs-2788f0d_GH0.tar.gz) = 51899cf8a55f8feefcdd33c04cf5e74937319d45ce0f04aa175188573f3284c9
+SIZE (gohugo/kr-fs-2788f0d_GH0.tar.gz) = 4361
+SHA256 (gohugo/kyokomi-emoji-17c5e70_GH0.tar.gz) = ac120d8005d73e308bf0c415cf56b412a6b2a24c0634871334df85d1a11e12f6
+SIZE (gohugo/kyokomi-emoji-17c5e70_GH0.tar.gz) = 24790
+SHA256 (gohugo/magiconair-properties-e2f061e_GH0.tar.gz) = 68ac6fa9ac398205a145d5375ecf66d851bb9595983032c9da15db293368ad34
+SIZE (gohugo/magiconair-properties-e2f061e_GH0.tar.gz) = 53836
+SHA256 (gohugo/miekg-mmark-adb5c3e_GH0.tar.gz) = 383c1a986764728a20a6129162aa32ec80324a7df9d2ab1725206f8fd9d060dd
+SIZE (gohugo/miekg-mmark-adb5c3e_GH0.tar.gz) = 197093
+SHA256 (gohugo/mitchellh-mapstructure-d2dd026_GH0.tar.gz) = c86c6ffcc0654bfbbb9adcac17f41d9999cc296524650b9d94e99db0847ed142
+SIZE (gohugo/mitchellh-mapstructure-d2dd026_GH0.tar.gz) = 14257
+SHA256 (gohugo/pkg-errors-a2d6902_GH0.tar.gz) = 488ffb5ea3db9fcc595ad030a2f89336414ccd80579a070cd0b0ad958b674428
+SIZE (gohugo/pkg-errors-a2d6902_GH0.tar.gz) = 8505
+SHA256 (gohugo/pkg-sftp-57fcf4a_GH0.tar.gz) = 23e349b7bb114b3c6a8a2465b693e6b199c07feda528b15dc8b119553a79b577
+SIZE (gohugo/pkg-sftp-57fcf4a_GH0.tar.gz) = 42725
+SHA256 (gohugo/russross-blackfriday-1d6b8e9_GH0.tar.gz) = 7400d51e25241a565fadb870228b0813bb1f07234a3e634fb7da4ec79e898dc5
+SIZE (gohugo/russross-blackfriday-1d6b8e9_GH0.tar.gz) = 70748
+SHA256 (gohugo/shurcooL-sanitized_anchor_name-10ef21a_GH0.tar.gz) = d80f6aa3bd74256d078f5c61acd7b9087c017ff318d23e1dd5b6e48e6ba42120
+SIZE (gohugo/shurcooL-sanitized_anchor_name-10ef21a_GH0.tar.gz) = 1941
+SHA256 (gohugo/golang-crypto-2c99acd_GH0.tar.gz) = 8949d60f1eebb595900278f0b1477994069eedef4b96c5bf979cd5e793f87937
+SIZE (gohugo/golang-crypto-2c99acd_GH0.tar.gz) = 1027889
+SHA256 (gohugo/golang-sys-a408501_GH0.tar.gz) = c353072676fc5f7b3709d3e9e93a11b2de2807a3ab0ccccb47ea9c1abaa0b804
+SIZE (gohugo/golang-sys-a408501_GH0.tar.gz) = 596590
+SHA256 (gohugo/golang-text-d5d7737_GH0.tar.gz) = 4c39613fccf0bbada703f5090daffa3d19c23c9eac7769e47dd653ab48aad795
+SIZE (gohugo/golang-text-d5d7737_GH0.tar.gz) = 4082769
+SHA256 (gohugo/go-yaml-yaml-a83829b_GH0.tar.gz) = f28814393a025308c4ea49d6fec94feff9e0c7dc51b22ffdc62fe53736bef707
+SIZE (gohugo/go-yaml-yaml-a83829b_GH0.tar.gz) = 63064
+SHA256 (gohugo/cpuguy83-go-md2man-2724a9c_GH0.tar.gz) = e497a71936141f7caa9521e2e75274fb1c11d9c50283720f501b546f3d5c001c
+SIZE (gohugo/cpuguy83-go-md2man-2724a9c_GH0.tar.gz) = 3516
diff --git a/www/gohugo/pkg-descr b/www/gohugo/pkg-descr
new file mode 100644
index 000000000000..67c9237c8936
--- /dev/null
+++ b/www/gohugo/pkg-descr
@@ -0,0 +1,11 @@
+Hugo is a general-purpose website framework. Technically speaking, Hugo is a
+static site generator. Unlike other systems which dynamically build a page
+every time a visitor requests one, Hugo does the building when you create your
+content. Since websites are viewed far more often than they are edited, Hugo is
+optimized for website viewing while providing a great writing experience.
+
+Sites built with Hugo are extremely fast and very secure. Hugo sites can be
+hosted anywhere and run without dependencies on expensive runtimes like Ruby,
+Python or PHP and without dependencies on any databases.
+
+WWW: http://gohugo.io
diff --git a/www/gohugo/pkg-plist b/www/gohugo/pkg-plist
new file mode 100644
index 000000000000..773a8166f947
--- /dev/null
+++ b/www/gohugo/pkg-plist
@@ -0,0 +1,24 @@
+bin/hugo
+man/man1/hugo.1.gz
+man/man1/hugo_benchmark.1.gz
+man/man1/hugo_check.1.gz
+man/man1/hugo_config.1.gz
+man/man1/hugo_convert.1.gz
+man/man1/hugo_convert_toJSON.1.gz
+man/man1/hugo_convert_toTOML.1.gz
+man/man1/hugo_convert_toYAML.1.gz
+man/man1/hugo_gen.1.gz
+man/man1/hugo_gen_autocomplete.1.gz
+man/man1/hugo_gen_doc.1.gz
+man/man1/hugo_gen_man.1.gz
+man/man1/hugo_import.1.gz
+man/man1/hugo_import_jekyll.1.gz
+man/man1/hugo_list.1.gz
+man/man1/hugo_list_drafts.1.gz
+man/man1/hugo_list_future.1.gz
+man/man1/hugo_new.1.gz
+man/man1/hugo_new_site.1.gz
+man/man1/hugo_new_theme.1.gz
+man/man1/hugo_server.1.gz
+man/man1/hugo_undraft.1.gz
+man/man1/hugo_version.1.gz