aboutsummaryrefslogtreecommitdiff
path: root/www/google-appengine/Makefile
diff options
context:
space:
mode:
authorNicola Vitale <nivit@FreeBSD.org>2017-04-02 16:42:01 +0000
committerNicola Vitale <nivit@FreeBSD.org>2017-04-02 16:42:01 +0000
commit983296e22a5dce642a5c8abac996af030073948c (patch)
tree782db4cc0afcd5dcb7284541c0e98a5b1eb9fe21 /www/google-appengine/Makefile
parentb7e0113c70c56aa4f8b9859942c25bf50a322982 (diff)
downloadports-983296e22a5dce642a5c8abac996af030073948c.tar.gz
ports-983296e22a5dce642a5c8abac996af030073948c.zip
Notes
Diffstat (limited to 'www/google-appengine/Makefile')
-rw-r--r--www/google-appengine/Makefile24
1 files changed, 9 insertions, 15 deletions
diff --git a/www/google-appengine/Makefile b/www/google-appengine/Makefile
index c3996cdcbe6f..b1a64426e950 100644
--- a/www/google-appengine/Makefile
+++ b/www/google-appengine/Makefile
@@ -2,7 +2,7 @@
# $FreeBSD$
PORTNAME= google-appengine
-PORTVERSION= 1.9.17
+PORTVERSION= 1.9.51
PORTREVISION= 0
CATEGORIES= www devel python
MASTER_SITES= https://storage.googleapis.com/appengine-sdks/featured/
@@ -34,22 +34,16 @@ WRKSRC= ${WRKDIR}/${PORTNAME:S,-,_,}
LN_OPTS= -sf
GAEDATADIR= google lib new_project_template tools
-GAESCRIPTS= _php_runtime.py _python_runtime.py api_server.py appcfg.py \
+GAESCRIPTS= _php_runtime.py _python_runtime.py appcfg.py \
backends_conversion.py bulkload_client.py bulkloader.py \
dev_appserver.py download_appstats.py endpointscfg.py \
- gen_protorpc.py google_sql.py php_cli.py \
- remote_api_shell.py run_tests.py wrapper_util.py
-
-.include <bsd.port.options.mk>
-
-.if ${PORT_OPTIONS:MMYSQL}
-RUN_DEPENDS+= ${PYTHON_PKGNAMEPREFIX}MySQLdb>=1.2.3:databases/py-MySQLdb
-.endif
-.if ${PORT_OPTIONS:MPHP}
-GAEDATADIR+= php
-USE_MYSQL= server
-WANT_MYSQL_VER= 55
-.endif
+ gen_protorpc.py php_cli.py remote_api_shell.py \
+ run_tests.py wrapper_util.py
+
+MYSQL_RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}MySQLdb>=1.2.3:databases/py-MySQLdb
+
+PHP_USE= mysql=server
+PHP_VARS= gaedatadir+=php want_mysql_ver=55
do-install:
@${MKDIR} ${STAGEDIR}${DATADIR}