aboutsummaryrefslogtreecommitdiff
path: root/www/google-appengine
diff options
context:
space:
mode:
authorNicola Vitale <nivit@FreeBSD.org>2012-08-23 15:08:15 +0000
committerNicola Vitale <nivit@FreeBSD.org>2012-08-23 15:08:15 +0000
commitd2dede936aa7ee33df26a9c25befdd846a951230 (patch)
tree9fa2ead842e18c6eb08960ba1131dc00c656423c /www/google-appengine
parentec35e84d1157a9f5160740c359579fd4406e0107 (diff)
downloadports-d2dede936aa7ee33df26a9c25befdd846a951230.tar.gz
ports-d2dede936aa7ee33df26a9c25befdd846a951230.zip
Notes
Diffstat (limited to 'www/google-appengine')
-rw-r--r--www/google-appengine/Makefile5
-rw-r--r--www/google-appengine/distinfo4
-rw-r--r--www/google-appengine/pkg-descr2
-rw-r--r--www/google-appengine/pkg-plist41
4 files changed, 43 insertions, 9 deletions
diff --git a/www/google-appengine/Makefile b/www/google-appengine/Makefile
index a89c3c428be1..9c14f3023bac 100644
--- a/www/google-appengine/Makefile
+++ b/www/google-appengine/Makefile
@@ -6,7 +6,7 @@
#
PORTNAME= google-appengine
-PORTVERSION= 1.7.0
+PORTVERSION= 1.7.1
PORTREVISION= 0
CATEGORIES= www devel python
MASTER_SITES= ${MASTER_SITE_GOOGLE_CODE}
@@ -15,6 +15,9 @@ DISTFILES= ${PORTNAME:S|-|_|}_${PORTVERSION}.zip
MAINTAINER= nivit@FreeBSD.org
COMMENT= Development tools for Google App Engine (SDK)
+LICENSE= AL2 BSD GPLv2 LGPL21 MIT MPL PSFL
+LICENSE_COMB= multi
+
RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}sqlite3>=${PYTHON_VER}:${PORTSDIR}/databases/py-sqlite3 \
${PYTHON_PKGNAMEPREFIX}imaging>=1.1.6_2:${PORTSDIR}/graphics/py-imaging
diff --git a/www/google-appengine/distinfo b/www/google-appengine/distinfo
index 3edbd13a3148..ce4f07cbcde6 100644
--- a/www/google-appengine/distinfo
+++ b/www/google-appengine/distinfo
@@ -1,4 +1,4 @@
-SHA256 (google_appengine_1.7.0.zip) = 7a1189257416dcc64a521316b1229a23100b3b8830e3ab7f5923be7b0d5f2239
-SIZE (google_appengine_1.7.0.zip) = 26248116
+SHA256 (google_appengine_1.7.1.zip) = 40c16a8a5fbd3211fee3fe5761dd42b110c167a5c081ac0a504fdcc7247ddabb
+SIZE (google_appengine_1.7.1.zip) = 26620581
SHA256 (google-appengine-docs-20120228.zip) = b6f8d0c59220a268f48d297640f4d2b0b963585e743479df98363ded0cfaffb0
SIZE (google-appengine-docs-20120228.zip) = 12325540
diff --git a/www/google-appengine/pkg-descr b/www/google-appengine/pkg-descr
index ab3c2467dbab..c0d82c0217ce 100644
--- a/www/google-appengine/pkg-descr
+++ b/www/google-appengine/pkg-descr
@@ -11,4 +11,4 @@ easy to scale as your traffic and data storage needs grow.
With App Engine, there are no servers to maintain: you just upload
your application, and it's ready to serve your users.
-WWW: http://code.google.com/appengine/
+WWW: http://code.google.com/appengine/
diff --git a/www/google-appengine/pkg-plist b/www/google-appengine/pkg-plist
index 3cb829863164..f4f14e1b10d3 100644
--- a/www/google-appengine/pkg-plist
+++ b/www/google-appengine/pkg-plist
@@ -2271,6 +2271,9 @@ bin/remote_api_shell.pyo
%%DATADIR%%/google/appengine/dist27/httplib.py
%%DATADIR%%/google/appengine/dist27/httplib.pyc
%%DATADIR%%/google/appengine/dist27/httplib.pyo
+%%DATADIR%%/google/appengine/dist27/threading.py
+%%DATADIR%%/google/appengine/dist27/threading.pyc
+%%DATADIR%%/google/appengine/dist27/threading.pyo
%%DATADIR%%/google/appengine/dist27/urllib.py
%%DATADIR%%/google/appengine/dist27/urllib.pyc
%%DATADIR%%/google/appengine/dist27/urllib.pyo
@@ -2325,6 +2328,32 @@ bin/remote_api_shell.pyo
%%DATADIR%%/google/appengine/ext/admin_redirect/main.py
%%DATADIR%%/google/appengine/ext/admin_redirect/main.pyc
%%DATADIR%%/google/appengine/ext/admin_redirect/main.pyo
+%%DATADIR%%/google/appengine/ext/analytics/__init__.py
+%%DATADIR%%/google/appengine/ext/analytics/__init__.pyc
+%%DATADIR%%/google/appengine/ext/analytics/__init__.pyo
+%%DATADIR%%/google/appengine/ext/analytics/app.yaml
+%%DATADIR%%/google/appengine/ext/analytics/entity.py
+%%DATADIR%%/google/appengine/ext/analytics/entity.pyc
+%%DATADIR%%/google/appengine/ext/analytics/entity.pyo
+%%DATADIR%%/google/appengine/ext/analytics/main.py
+%%DATADIR%%/google/appengine/ext/analytics/main.pyc
+%%DATADIR%%/google/appengine/ext/analytics/main.pyo
+%%DATADIR%%/google/appengine/ext/analytics/process.py
+%%DATADIR%%/google/appengine/ext/analytics/process.pyc
+%%DATADIR%%/google/appengine/ext/analytics/process.pyo
+%%DATADIR%%/google/appengine/ext/analytics/standaloneapp.py
+%%DATADIR%%/google/appengine/ext/analytics/standaloneapp.pyc
+%%DATADIR%%/google/appengine/ext/analytics/standaloneapp.pyo
+%%DATADIR%%/google/appengine/ext/analytics/static/analytics_css.css
+%%DATADIR%%/google/appengine/ext/analytics/static/analytics_js.js
+%%DATADIR%%/google/appengine/ext/analytics/static/pix.gif
+%%DATADIR%%/google/appengine/ext/analytics/stats.py
+%%DATADIR%%/google/appengine/ext/analytics/stats.pyc
+%%DATADIR%%/google/appengine/ext/analytics/stats.pyo
+%%DATADIR%%/google/appengine/ext/analytics/templates/drill.html
+%%DATADIR%%/google/appengine/ext/analytics/templates/error.html
+%%DATADIR%%/google/appengine/ext/analytics/templates/main.html
+%%DATADIR%%/google/appengine/ext/analytics/templates/showPklFiles.html
%%DATADIR%%/google/appengine/ext/appstats/__init__.py
%%DATADIR%%/google/appengine/ext/appstats/__init__.pyc
%%DATADIR%%/google/appengine/ext/appstats/__init__.pyo
@@ -2426,6 +2455,9 @@ bin/remote_api_shell.pyo
%%DATADIR%%/google/appengine/ext/datastore_admin/backup_handler.py
%%DATADIR%%/google/appengine/ext/datastore_admin/backup_handler.pyc
%%DATADIR%%/google/appengine/ext/datastore_admin/backup_handler.pyo
+%%DATADIR%%/google/appengine/ext/datastore_admin/backup_pb2.py
+%%DATADIR%%/google/appengine/ext/datastore_admin/backup_pb2.pyc
+%%DATADIR%%/google/appengine/ext/datastore_admin/backup_pb2.pyo
%%DATADIR%%/google/appengine/ext/datastore_admin/copy_handler.py
%%DATADIR%%/google/appengine/ext/datastore_admin/copy_handler.pyc
%%DATADIR%%/google/appengine/ext/datastore_admin/copy_handler.pyo
@@ -2991,19 +3023,15 @@ bin/remote_api_shell.pyo
%%DATADIR%%/lib/PyAMF/cpyamf/__init__.pyo
%%DATADIR%%/lib/PyAMF/cpyamf/amf0.c
%%DATADIR%%/lib/PyAMF/cpyamf/amf0.pyx
-%%DATADIR%%/lib/PyAMF/cpyamf/amf0.so
%%DATADIR%%/lib/PyAMF/cpyamf/amf3.c
%%DATADIR%%/lib/PyAMF/cpyamf/amf3.pxd
%%DATADIR%%/lib/PyAMF/cpyamf/amf3.pyx
-%%DATADIR%%/lib/PyAMF/cpyamf/amf3.so
%%DATADIR%%/lib/PyAMF/cpyamf/codec.c
%%DATADIR%%/lib/PyAMF/cpyamf/codec.pxd
%%DATADIR%%/lib/PyAMF/cpyamf/codec.pyx
-%%DATADIR%%/lib/PyAMF/cpyamf/codec.so
%%DATADIR%%/lib/PyAMF/cpyamf/util.c
%%DATADIR%%/lib/PyAMF/cpyamf/util.pxd
%%DATADIR%%/lib/PyAMF/cpyamf/util.pyx
-%%DATADIR%%/lib/PyAMF/cpyamf/util.so
%%DATADIR%%/lib/PyAMF/distribute_setup.py
%%DATADIR%%/lib/PyAMF/distribute_setup.pyc
%%DATADIR%%/lib/PyAMF/distribute_setup.pyo
@@ -18671,7 +18699,7 @@ bin/remote_api_shell.pyo
%%DATADIR%%/lib/httplib2/httplib2/test/test_no_socket.py
%%DATADIR%%/lib/httplib2/httplib2/test/test_no_socket.pyc
%%DATADIR%%/lib/httplib2/httplib2/test/test_no_socket.pyo
-%%DATADIR%%/lib/ipaddr/ipaddr/COPYING
+%%DATADIR%%/lib/ipaddr/ipaddr/LICENSE
%%DATADIR%%/lib/ipaddr/ipaddr/README
%%DATADIR%%/lib/ipaddr/ipaddr/__init__.py
%%DATADIR%%/lib/ipaddr/ipaddr/__init__.pyc
@@ -23505,6 +23533,9 @@ bin/remote_api_shell.pyo
@dirrm %%DATADIR%%/google/appengine/ext/appstats/templates
@dirrm %%DATADIR%%/google/appengine/ext/appstats/static
@dirrm %%DATADIR%%/google/appengine/ext/appstats
+@dirrm %%DATADIR%%/google/appengine/ext/analytics/templates
+@dirrm %%DATADIR%%/google/appengine/ext/analytics/static
+@dirrm %%DATADIR%%/google/appengine/ext/analytics
@dirrm %%DATADIR%%/google/appengine/ext/admin_redirect
@dirrm %%DATADIR%%/google/appengine/ext/admin/templates/js
@dirrm %%DATADIR%%/google/appengine/ext/admin/templates/images