aboutsummaryrefslogtreecommitdiff
path: root/www/gpx2map
diff options
context:
space:
mode:
authorPawel Pekala <pawel@FreeBSD.org>2014-12-22 18:12:17 +0000
committerPawel Pekala <pawel@FreeBSD.org>2014-12-22 18:12:17 +0000
commit080315bb0993a82cf9f577fe81d8110320056001 (patch)
treeb6d3f9f5ba897107516a31dfe2e97a4f735b59dc /www/gpx2map
parentd6a7e1fc3e7e69cfc60c06478273cd183cca668f (diff)
downloadports-080315bb0993a82cf9f577fe81d8110320056001.tar.gz
ports-080315bb0993a82cf9f577fe81d8110320056001.zip
Notes
Diffstat (limited to 'www/gpx2map')
-rw-r--r--www/gpx2map/Makefile48
-rw-r--r--www/gpx2map/distinfo2
-rw-r--r--www/gpx2map/pkg-descr4
3 files changed, 54 insertions, 0 deletions
diff --git a/www/gpx2map/Makefile b/www/gpx2map/Makefile
new file mode 100644
index 000000000000..9a4e5b257fb4
--- /dev/null
+++ b/www/gpx2map/Makefile
@@ -0,0 +1,48 @@
+# $FreeBSD$
+
+PORTNAME= gpx2map
+PORTVERSION= 0.1
+CATEGORIES= www
+
+MAINTAINER= koue@chaosophia.net
+COMMENT= Put GPX track on Google Map or OpenStreetMap
+
+LICENSE= GPLv3
+
+RUN_DEPENDS= p5-XML-Twig>=0:${PORTSDIR}/textproc/p5-XML-Twig \
+ p5-Template-Toolkit>=0:${PORTSDIR}/www/p5-Template-Toolkit \
+ p5-Geo-Distance>=0:${PORTSDIR}/math/p5-Geo-Distance
+
+USE_GITHUB= yes
+GH_ACCOUNT= sd2k9
+GH_COMMIT= 5ab24c4
+GH_TAGNAME= ${PORTVERSION}
+
+USES= shebangfix perl5
+SHEBANG_FILES= gpx2map
+NO_BUILD= yes
+DATADIR= ${PREFIX}/share/${PORTNAME}
+
+PLIST_FILES= bin/gpx2map \
+ share/gpx2map/gpx2map.google.template \
+ share/gpx2map/gpx2map.osm.template
+
+OPTIONS_DEFINE= GNUPLOT
+
+GNUPLOT_DESC= Enable draw track profiles
+GNUPLOT_RUN_DEPENDS= p5-Chart-Gnuplot>=0:${PORTSDIR}/graphics/p5-Chart-Gnuplot
+
+post-patch:
+ @${REINPLACE_CMD} -e "s|gpx2map.google.template|${DATADIR}/gpx2map.google.template|" \
+ -e "s|gpx2map.osm.template|${DATADIR}/gpx2map.osm.template|" \
+ -e "s|.FindBin::RealBin/.opts{'map_template_google'}|${DATADIR}/gpx2map.google.template|" \
+ -e "s|.FindBin::RealBin/.opts{'map_template_osm'}|${DATADIR}/gpx2map.osm.template|" \
+ ${WRKSRC}/gpx2map
+
+do-install:
+ ${INSTALL_SCRIPT} ${WRKSRC}/gpx2map ${STAGEDIR}${PREFIX}/bin
+ @${MKDIR} ${STAGEDIR}${DATADIR}
+ ${INSTALL_DATA} ${WRKSRC}/gpx2map.google.template ${STAGEDIR}${DATADIR}
+ ${INSTALL_DATA} ${WRKSRC}/gpx2map.osm.template ${STAGEDIR}${DATADIR}
+
+.include <bsd.port.mk>
diff --git a/www/gpx2map/distinfo b/www/gpx2map/distinfo
new file mode 100644
index 000000000000..8a0be8315528
--- /dev/null
+++ b/www/gpx2map/distinfo
@@ -0,0 +1,2 @@
+SHA256 (gpx2map-0.1.tar.gz) = adeaff2c6b8c4228476fbc067e346fcb01909d5f73975bac8859b2b47f15b538
+SIZE (gpx2map-0.1.tar.gz) = 106886
diff --git a/www/gpx2map/pkg-descr b/www/gpx2map/pkg-descr
new file mode 100644
index 000000000000..727de9b04fc7
--- /dev/null
+++ b/www/gpx2map/pkg-descr
@@ -0,0 +1,4 @@
+Reads a gps track in GPX format and writes out an Google Map or OpenStreetMaps
+mash-up containing the route and additional information.
+
+WWW: https://github.com/sd2k9/gpx2map