aboutsummaryrefslogtreecommitdiff
path: root/www/grails
diff options
context:
space:
mode:
authorBeech Rintoul <beech@FreeBSD.org>2008-03-11 20:10:29 +0000
committerBeech Rintoul <beech@FreeBSD.org>2008-03-11 20:10:29 +0000
commit02f6020b829e6b885415e85051a4dab871f1d40c (patch)
tree5e1a3a512458ed2a55dc8f6888058656e21fb188 /www/grails
parent6db76aa2a87d9b7e6e82b841efe867ef7dc41967 (diff)
downloadports-02f6020b829e6b885415e85051a4dab871f1d40c.tar.gz
ports-02f6020b829e6b885415e85051a4dab871f1d40c.zip
Notes
Diffstat (limited to 'www/grails')
-rw-r--r--www/grails/Makefile61
-rw-r--r--www/grails/distinfo3
-rw-r--r--www/grails/files/pkg-message.in9
-rw-r--r--www/grails/files/set-grails_home.sed.in5
-rw-r--r--www/grails/pkg-descr9
5 files changed, 87 insertions, 0 deletions
diff --git a/www/grails/Makefile b/www/grails/Makefile
new file mode 100644
index 000000000000..37c6fa992eed
--- /dev/null
+++ b/www/grails/Makefile
@@ -0,0 +1,61 @@
+# New ports collection makefile for: grails
+# Date created: 2008-03-10
+# Whom: Mitchell Smith <mjs@bur.st>
+#
+# $FreeBSD$
+#
+
+PORTNAME= grails
+DISTVERSION= 1.0.1
+CATEGORIES= www java
+MASTER_SITES= http://dist.codehaus.org/grails/
+DISTNAME= ${PORTNAME}-bin-${PORTVERSION}
+
+MAINTAINER= mjs@bur.st
+COMMENT= Web framework built on Groovy
+
+WRKSRC= ${WRKDIR}/${PORTNAME}-${DISTVERSION:U}
+
+USE_JAVA= yes
+JAVA_VERSION= 1.4+
+NO_BUILD= yes
+DATADIR= ${JAVASHAREDIR}/${PORTNAME}
+DATAFILES= LICENSE conf dist media lib scripts
+SCRIPTFILES= grails grails-debug startGrails
+
+.if !defined(NOPORTDOCS)
+PORTDOCS= api
+.endif
+PLIST_FILES= ${SCRIPTFILES:S,^,bin/,}
+SUB_FILES= set-grails_home.sed pkg-message
+
+do-install:
+ @${ECHO_MSG} -n ">> Installing data files in ${DATADIR}..."
+ @cd ${WRKSRC} \
+ && ${FIND} ${DATAFILES} -type d -exec ${MKDIR} ${DATADIR}/{} \; \
+ && ${FIND} ${DATAFILES} -type f -exec ${INSTALL_DATA} {} ${DATADIR}/{} \;
+ @${ECHO_MSG} " [ DONE ]"
+ @${ECHO_MSG} -n ">> Installing executables in ${PREFIX}/bin..."
+ @${REINPLACE_CMD} -f ${WRKDIR}/set-grails_home.sed ${WRKSRC}/bin/startGrails
+.for file in ${SCRIPTFILES}
+ @${ECHO_MSG} -n " ${file}"
+ @${INSTALL_SCRIPT} ${WRKSRC}/bin/${file} ${PREFIX}/bin/
+.endfor
+ @${ECHO_MSG} " [ DONE ]"
+.if !defined(NOPORTDOCS)
+ @${ECHO_MSG} -n ">> Installing documentation in ${DOCSDIR}..."
+ @cd ${WRKSRC}/doc \
+ && ${FIND} . -type d -exec ${MKDIR} ${DOCSDIR}/{} \; \
+ && ${FIND} . -type f -exec ${INSTALL_DATA} {} ${DOCSDIR}/{} \;
+ @${ECHO_MSG} " [ DONE ]"
+.endif
+
+post-install:
+ @${FIND} -s ${DATAFILES:S,^,${WRKSRC}/,} -not -type d 2>/dev/null | \
+ ${SED} -ne 's,^${WRKSRC},${DATADIR:S,^${PREFIX}/,,},p' >> ${TMPPLIST}
+ @${FIND} -s -d ${DATAFILES:S,^,${WRKSRC}/,} -type d 2>/dev/null | \
+ ${SED} -ne 's,^${WRKSRC},@dirrm ${DATADIR:S,^${PREFIX}/,,},p' >> ${TMPPLIST}
+ @${ECHO_CMD} '@dirrm ${DATADIR:S,^${PREFIX}/,,}' >> ${TMPPLIST}
+ @${CAT} ${PKGMESSAGE}
+
+.include <bsd.port.mk>
diff --git a/www/grails/distinfo b/www/grails/distinfo
new file mode 100644
index 000000000000..66d307ac549a
--- /dev/null
+++ b/www/grails/distinfo
@@ -0,0 +1,3 @@
+MD5 (grails-bin-1.0.1.tar.gz) = 17490024e2efd1d6728aff4b5db7d3b0
+SHA256 (grails-bin-1.0.1.tar.gz) = 0c65af80e270e135f89b5c3dac107dfcd99b2649bccb5681f45f44e9c7ab7d6a
+SIZE (grails-bin-1.0.1.tar.gz) = 29267647
diff --git a/www/grails/files/pkg-message.in b/www/grails/files/pkg-message.in
new file mode 100644
index 000000000000..5438c5f98a78
--- /dev/null
+++ b/www/grails/files/pkg-message.in
@@ -0,0 +1,9 @@
+* * * * * * * * * * * * * * * * * * * * * * * * * * * * * * * * * * * * * * * *
+
+Before you start using Grails you will need to set the GRAILS_HOME environment
+variable to %%JAVASHAREDIR%%/grails
+
+Documentation on creating your first Grails application can be found at the
+Grails website http://grails.codehaus.org/
+
+* * * * * * * * * * * * * * * * * * * * * * * * * * * * * * * * * * * * * * * *
diff --git a/www/grails/files/set-grails_home.sed.in b/www/grails/files/set-grails_home.sed.in
new file mode 100644
index 000000000000..a018b404b533
--- /dev/null
+++ b/www/grails/files/set-grails_home.sed.in
@@ -0,0 +1,5 @@
+# $FreeBSD$
+14i\
+: ${GRAILS_HOME="%%DATADIR%%"}
+14i\
+[ -z "${JAVA_HOME}" ] && JAVA_HOME="`env JAVAVM_DRYRUN=yes %%LOCALBASE%%/bin/java | grep '^JAVA_HOME' | cut -c11-`"
diff --git a/www/grails/pkg-descr b/www/grails/pkg-descr
new file mode 100644
index 000000000000..50267b26bc1d
--- /dev/null
+++ b/www/grails/pkg-descr
@@ -0,0 +1,9 @@
+Grails aims to bring the "coding by convention" paradigm to Groovy. It's an
+open-source web application framework that leverages the Groovy language and
+complements Java Web development. You can use Grails as a standalone
+development environment that hides all configuration details or integrate your
+Java business logic. Grails aims to make development as simple as possible and
+hence should appeal to a wide range of developers not just those from the
+Java community.
+
+WWW: http://grails.org