aboutsummaryrefslogtreecommitdiff
path: root/www/gtkhtml38/Makefile
diff options
context:
space:
mode:
authorJoe Marcus Clarke <marcus@FreeBSD.org>2006-04-30 00:47:21 +0000
committerJoe Marcus Clarke <marcus@FreeBSD.org>2006-04-30 00:47:21 +0000
commit798e9bed2a389dce8a970e15b68176fd49f442db (patch)
tree9dc5597aab073298ec381964f72cd853b3dd366c /www/gtkhtml38/Makefile
parent48b92584b0722f7f6ca412e6cfe16f1381e043cc (diff)
downloadports-798e9bed2a389dce8a970e15b68176fd49f442db.tar.gz
ports-798e9bed2a389dce8a970e15b68176fd49f442db.zip
Notes
Diffstat (limited to 'www/gtkhtml38/Makefile')
-rw-r--r--www/gtkhtml38/Makefile10
1 files changed, 5 insertions, 5 deletions
diff --git a/www/gtkhtml38/Makefile b/www/gtkhtml38/Makefile
index 5afc4a824318..d7e40fc2888b 100644
--- a/www/gtkhtml38/Makefile
+++ b/www/gtkhtml38/Makefile
@@ -3,15 +3,14 @@
# Whom: Joe Marcus Clarke <marcus@FreeBSD.org>
#
# $FreeBSD$
-# $MCom: ports/www/gtkhtml3/Makefile,v 1.62 2005/10/03 15:21:56 ahze Exp $
+# $MCom: ports/www/gtkhtml3/Makefile,v 1.77 2006/04/13 07:52:39 bland Exp $
#
PORTNAME= gtkhtml3
-PORTVERSION= 3.8.2
-PORTREVISION= 1
+PORTVERSION= 3.10.1
CATEGORIES= www gnome
MASTER_SITES= ${MASTER_SITE_GNOME}
-MASTER_SITE_SUBDIR= sources/${PORTNAME:S/3$//}/3.8
+MASTER_SITE_SUBDIR= sources/${PORTNAME:S/3$//}/${PORTVERSION:C/^([0-9]+\.[0-9]+).*/\1/}
DISTNAME= ${PORTNAME:S/3$//}-${PORTVERSION}
DIST_SUBDIR= gnome2
@@ -20,13 +19,14 @@ COMMENT= Lightweight HTML rendering/printing/editing engine
LIB_DEPENDS= soup-2.2.8:${PORTSDIR}/devel/libsoup
+USE_GETTEXT= yes
USE_BZIP2= yes
USE_X_PREFIX= yes
USE_GMAKE= yes
USE_GNOME= gnomeprefix gnomehack intlhack gail libgnomeui \
libgnomeprintui ltverhack
INSTALLS_SHLIB= yes
-USE_AUTOTOOLS= libtool:15
+USE_AUTOTOOLS= libtool:15
CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
LDFLAGS="-L${LOCALBASE}/lib"