aboutsummaryrefslogtreecommitdiff
path: root/www/gtkhtml38/Makefile
diff options
context:
space:
mode:
authorAde Lovett <ade@FreeBSD.org>2000-08-04 01:34:38 +0000
committerAde Lovett <ade@FreeBSD.org>2000-08-04 01:34:38 +0000
commit9594f3f8939f5178057c6a588135f0bab6d52511 (patch)
tree923d26a5ec2be934317cf261a38183917c93fe7a /www/gtkhtml38/Makefile
parent5035c4b32a83e9b13642c8ca8569d6ba2b001420 (diff)
downloadports-9594f3f8939f5178057c6a588135f0bab6d52511.tar.gz
ports-9594f3f8939f5178057c6a588135f0bab6d52511.zip
Notes
Diffstat (limited to 'www/gtkhtml38/Makefile')
-rw-r--r--www/gtkhtml38/Makefile9
1 files changed, 8 insertions, 1 deletions
diff --git a/www/gtkhtml38/Makefile b/www/gtkhtml38/Makefile
index d68c87b622f5..8344b03c9b03 100644
--- a/www/gtkhtml38/Makefile
+++ b/www/gtkhtml38/Makefile
@@ -15,7 +15,7 @@ MAINTAINER= ade@FreeBSD.org
LIB_DEPENDS= bonobo.2:${PORTSDIR}/devel/bonobo \
wwwzip.1:${PORTSDIR}/www/libwww \
- gconf.8:${PORTSDIR}/devel/gconf
+ gconf-1.0:${PORTSDIR}/devel/gconf
GLIB_CONFIG?= ${LOCALBASE}/bin/glib12-config
GTK_CONFIG?= ${X11BASE}/bin/gtk12-config
@@ -31,4 +31,11 @@ CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
GTK_CONFIG="${GTK_CONFIG}" \
LIBS="-L${LOCALBASE}/lib"
+post-extract:
+ @${PERL} -pi -e 's|-lpthread|-pthread|g ; \
+ s|DATADIRNAME=lib|DATADIRNAME=share|g' ${WRKSRC}/configure
+ @find ${WRKSRC} -name "Makefile.in" | xargs ${PERL} -pi -e \
+ 's|\$\(datadir\)/gnome/|\$\(datadir\)/|g ; \
+ s|\$\(datadir\)/locale|\$\(prefix\)/share/locale|g'
+
.include <bsd.port.mk>