aboutsummaryrefslogtreecommitdiff
path: root/www/gtkhtml3
diff options
context:
space:
mode:
authorKoop Mast <kwm@FreeBSD.org>2010-11-20 15:37:08 +0000
committerKoop Mast <kwm@FreeBSD.org>2010-11-20 15:37:08 +0000
commit3680f27ebff58ece429c4e032f9ad84fb1372114 (patch)
tree6c5ff4664c1a779ddad350ac887e5706dbfdd4eb /www/gtkhtml3
parent02c6e6b485454dc3f5a27cbc887d9e4aaf376a36 (diff)
downloadports-3680f27ebff58ece429c4e032f9ad84fb1372114.tar.gz
ports-3680f27ebff58ece429c4e032f9ad84fb1372114.zip
Notes
Diffstat (limited to 'www/gtkhtml3')
-rw-r--r--www/gtkhtml3/Makefile9
-rw-r--r--www/gtkhtml3/distinfo5
-rw-r--r--www/gtkhtml3/files/patch-components_editor_gtkhtml-spell-dialog.c13
-rw-r--r--www/gtkhtml3/pkg-plist10
4 files changed, 25 insertions, 12 deletions
diff --git a/www/gtkhtml3/Makefile b/www/gtkhtml3/Makefile
index cbaee3d3933b..eda3d7c5e73b 100644
--- a/www/gtkhtml3/Makefile
+++ b/www/gtkhtml3/Makefile
@@ -3,11 +3,11 @@
# Whom: Joe Marcus Clarke <marcus@FreeBSD.org>
#
# $FreeBSD$
-# $MCom: ports-stable/www/gtkhtml3/Makefile,v 1.9 2010/06/22 20:20:38 kwm Exp $
+# $MCom: ports/www/gtkhtml3/Makefile,v 1.177 2010/11/15 16:59:05 kwm Exp $
#
PORTNAME= gtkhtml3
-PORTVERSION= 3.30.3
+PORTVERSION= 3.32.1
CATEGORIES= www gnome
MASTER_SITES= GNOME
MASTER_SITE_SUBDIR= sources/${PORTNAME:S/3$//}/${PORTVERSION:C/^([0-9]+\.[0-9]+).*/\1/}
@@ -28,7 +28,7 @@ USE_GETTEXT= yes
USE_BZIP2= yes
USE_XORG= xinerama xi xrandr xcursor xcomposite xdamage
USE_GMAKE= yes
-USE_GNOME= gnomeprefix gnomehack intlhack libglade2 ltverhack
+USE_GNOME= gnomeprefix gnomehack intlhack gconf2 ltverhack
USE_LDCONFIG= yes
USE_AUTOTOOLS= libtool:22
CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
@@ -39,7 +39,8 @@ PLIST_SUB= VERSION="3.14"
post-patch:
@${REINPLACE_CMD} -e 's|@INTLTOOL_LIBDIR@|${LOCALBASE}/libdata|' \
${WRKSRC}/intltool-merge.in
- @${REINPLACE_CMD} -e 's|-Wmissing-include-dirs||g' \
+ @${REINPLACE_CMD} -e 's|-Wmissing-include-dirs||g ; \
+ s|-DGDK_DISABLE_DEPRECATED||g' \
${WRKSRC}/configure
.include <bsd.port.mk>
diff --git a/www/gtkhtml3/distinfo b/www/gtkhtml3/distinfo
index 78d2c84e0067..59301a05e64f 100644
--- a/www/gtkhtml3/distinfo
+++ b/www/gtkhtml3/distinfo
@@ -1,3 +1,2 @@
-MD5 (gnome2/gtkhtml-3.30.3.tar.bz2) = 0d11cebd0f1fe25435ab00d7cd26df7b
-SHA256 (gnome2/gtkhtml-3.30.3.tar.bz2) = 99795c154f1c6459063bb8018066ad46baf086a2419510ed959167d4d9e35fae
-SIZE (gnome2/gtkhtml-3.30.3.tar.bz2) = 1354771
+SHA256 (gnome2/gtkhtml-3.32.1.tar.bz2) = 78b6da6c1f4f61947f77de505a626a028ee3ecb6ad3c7c06cc4a6273e16d95c6
+SIZE (gnome2/gtkhtml-3.32.1.tar.bz2) = 1196875
diff --git a/www/gtkhtml3/files/patch-components_editor_gtkhtml-spell-dialog.c b/www/gtkhtml3/files/patch-components_editor_gtkhtml-spell-dialog.c
new file mode 100644
index 000000000000..ec390b5d8173
--- /dev/null
+++ b/www/gtkhtml3/files/patch-components_editor_gtkhtml-spell-dialog.c
@@ -0,0 +1,13 @@
+--- components/editor/gtkhtml-spell-dialog.c.orig 2010-09-19 17:57:00.000000000 +0000
++++ components/editor/gtkhtml-spell-dialog.c 2010-09-19 17:57:41.000000000 +0000
+@@ -443,7 +443,9 @@ spell_dialog_init (GtkhtmlSpellDialog *d
+
+ gtk_dialog_add_button (
+ GTK_DIALOG (dialog), GTK_STOCK_CLOSE, GTK_RESPONSE_CLOSE);
+- gtk_dialog_set_has_separator (GTK_DIALOG (dialog), FALSE);
++#if !GTK_CHECK_VERSION(2,90,7)
++ g_object_set (dialog, "has-separator", FALSE, NULL);
++#endif
+ gtk_window_set_title (GTK_WINDOW (dialog), _("Spell Checker"));
+ gtk_container_set_border_width (GTK_CONTAINER (dialog), 5);
+
diff --git a/www/gtkhtml3/pkg-plist b/www/gtkhtml3/pkg-plist
index 919730fbe361..3a36ed5b8cbf 100644
--- a/www/gtkhtml3/pkg-plist
+++ b/www/gtkhtml3/pkg-plist
@@ -19,11 +19,11 @@ lib/libgtkhtml-%%VERSION%%.a
lib/libgtkhtml-%%VERSION%%.la
lib/libgtkhtml-%%VERSION%%.so
lib/libgtkhtml-%%VERSION%%.so.19
-lib/libgtkhtml-editor.a
-lib/libgtkhtml-editor.la
-lib/libgtkhtml-editor.so
-lib/libgtkhtml-editor.so.0
-libdata/pkgconfig/gtkhtml-editor.pc
+lib/libgtkhtml-editor-%%VERSION%%.a
+lib/libgtkhtml-editor-%%VERSION%%.la
+lib/libgtkhtml-editor-%%VERSION%%.so
+lib/libgtkhtml-editor-%%VERSION%%.so.0
+libdata/pkgconfig/gtkhtml-editor-%%VERSION%%.pc
libdata/pkgconfig/libgtkhtml-%%VERSION%%.pc
share/gtkhtml-%%VERSION%%/gtkhtml-editor-builder.ui
share/gtkhtml-%%VERSION%%/gtkhtml-editor-manager.ui