aboutsummaryrefslogtreecommitdiff
path: root/www/gtkhtml
diff options
context:
space:
mode:
authorAdam Weinberger <adamw@FreeBSD.org>2003-09-25 05:40:49 +0000
committerAdam Weinberger <adamw@FreeBSD.org>2003-09-25 05:40:49 +0000
commit8108744cf62942d79d2d7f88aa9970188c61a83a (patch)
treeaca409691d19a530bd97c61a49563b028b66ea57 /www/gtkhtml
parentb94f2f30862b3190689d0711befcd312bddaca63 (diff)
downloadports-8108744cf62942d79d2d7f88aa9970188c61a83a.tar.gz
ports-8108744cf62942d79d2d7f88aa9970188c61a83a.zip
Notes
Diffstat (limited to 'www/gtkhtml')
-rw-r--r--www/gtkhtml/Makefile3
-rw-r--r--www/gtkhtml/files/patch-src_gtkhtml-propmanager.c16
2 files changed, 18 insertions, 1 deletions
diff --git a/www/gtkhtml/Makefile b/www/gtkhtml/Makefile
index ce9599e785fd..1c889a788754 100644
--- a/www/gtkhtml/Makefile
+++ b/www/gtkhtml/Makefile
@@ -7,6 +7,7 @@
PORTNAME= gtkhtml
PORTVERSION= 1.1.10
+PORTREVISION= 1
CATEGORIES= www gnome
MASTER_SITES= ${MASTER_SITE_GNOME}
MASTER_SITE_SUBDIR= sources/${PORTNAME}/1.1
@@ -24,7 +25,7 @@ USE_GNOME= gnomehack gnomeprefix gnomehier glibwww libghttp libcapplet gal
INSTALLS_SHLIB= yes
USE_LIBTOOL= yes
USE_REINPLACE= yes
-CONFIGURE_ARGS= --with-gconf=yes
+CONFIGURE_ARGS= --with-gconf=no
CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
LIBS="-L${LOCALBASE}/lib"
diff --git a/www/gtkhtml/files/patch-src_gtkhtml-propmanager.c b/www/gtkhtml/files/patch-src_gtkhtml-propmanager.c
new file mode 100644
index 000000000000..3c1d4e916827
--- /dev/null
+++ b/www/gtkhtml/files/patch-src_gtkhtml-propmanager.c
@@ -0,0 +1,16 @@
+--- src/gtkhtml-propmanager.c.orig Mon Sep 22 19:08:54 2003
++++ src/gtkhtml-propmanager.c Mon Sep 22 19:09:24 2003
+@@ -24,6 +24,7 @@
+ #include <glib.h>
+ #include <gnome.h>
+
++#ifdef GTKHTML_HAVE_GCONF
+
+ #include "gtkhtml-propmanager.h"
+ #include "gtkhtml-properties.h"
+@@ -611,3 +612,5 @@
+
+ return propmanager_type;
+ }
++
++#endif