aboutsummaryrefslogtreecommitdiff
path: root/www/harvest/files
diff options
context:
space:
mode:
authorYing-Chieh Liao <ijliao@FreeBSD.org>2002-11-20 13:31:44 +0000
committerYing-Chieh Liao <ijliao@FreeBSD.org>2002-11-20 13:31:44 +0000
commit3639a9cce1809d50e83746e4142c2b611666fd8a (patch)
tree8204a96149d1a0e1c213f61618b3debc294e682c /www/harvest/files
parent528f9f582c4fb4b89fa9a1c58a96d9bd62e3b3d3 (diff)
downloadports-3639a9cce1809d50e83746e4142c2b611666fd8a.tar.gz
ports-3639a9cce1809d50e83746e4142c2b611666fd8a.zip
Notes
Diffstat (limited to 'www/harvest/files')
-rw-r--r--www/harvest/files/patch-aa20
-rw-r--r--www/harvest/files/patch-ac12
-rw-r--r--www/harvest/files/patch-ad11
-rw-r--r--www/harvest/files/patch-ae12
-rw-r--r--www/harvest/files/patch-components::broker::standard::WWW::DisplayObject.c12
-rw-r--r--www/harvest/files/patch-components::broker::swish::Makefile.in11
-rw-r--r--www/harvest/files/patch-components::gatherer::catdoc::charsets::Makefile.in29
-rw-r--r--www/harvest/files/patch-components::gatherer::catdoc::doc::Makefile.in22
-rw-r--r--www/harvest/files/patch-components::gatherer::catdoc::src::Makefile.in36
-rw-r--r--www/harvest/files/patch-src::common::util::strerror.c (renamed from www/harvest/files/patch-ab)4
-rw-r--r--www/harvest/files/patch-src::gatherer::essence::file::print.c12
-rw-r--r--www/harvest/files/patch-src::gatherer::essence::pp_rules.y10
12 files changed, 134 insertions, 57 deletions
diff --git a/www/harvest/files/patch-aa b/www/harvest/files/patch-aa
deleted file mode 100644
index 90e5aae10b26..000000000000
--- a/www/harvest/files/patch-aa
+++ /dev/null
@@ -1,20 +0,0 @@
---- components/gatherer/standard/skim/skim.c.orig Sat Mar 30 18:54:27 2002
-+++ components/gatherer/standard/skim/skim.c Sat Mar 30 18:54:45 2002
-@@ -15,7 +15,7 @@
-
- int Argc;
- char **Argv;
--FILE *InputFile = stdin;
-+FILE *InputFile;
-
- main(argc, argv)
- int argc;
-@@ -25,6 +25,8 @@
- int Skipping = 0, nlines = 0;
- char *Ptr;
- char *EndLine;
-+
-+ InputFile = stdin;
-
- /* Set up globals */
- Argc = argc;
diff --git a/www/harvest/files/patch-ac b/www/harvest/files/patch-ac
deleted file mode 100644
index a525ee60884b..000000000000
--- a/www/harvest/files/patch-ac
+++ /dev/null
@@ -1,12 +0,0 @@
---- ./src/gatherer/essence/file/print.c.orig Sun Oct 20 17:44:09 2002
-+++ ./src/gatherer/essence/file/print.c Sun Oct 20 17:44:18 2002
-@@ -77,8 +77,8 @@
- warning(f, a)
- char *f, *a;
- {
-- extern int errno, sys_nerr;
- #if !defined(__FreeBSD__) && !defined(__NetBSD__)
-+ extern int errno, sys_nerr;
- extern char *sys_errlist[];
- #endif
- int myerrno;
diff --git a/www/harvest/files/patch-ad b/www/harvest/files/patch-ad
deleted file mode 100644
index c3b35674caee..000000000000
--- a/www/harvest/files/patch-ad
+++ /dev/null
@@ -1,11 +0,0 @@
---- src/broker/Glimpse/index.c.old Fri Oct 25 19:52:18 2002
-+++ src/broker/Glimpse/index.c Fri Oct 25 19:52:34 2002
-@@ -192,7 +192,7 @@
- GL_GlimpseSrvPort = -1;
- return;
- }
-- if (GL_GlimpseSrvPort <= IPPORT_USERRESERVED) {
-+ if (GL_GlimpseSrvPort <= 5000) {
- /* choose a random port number between 16384-30000 */
- #if defined(HAVE_SRAND48) && defined(HAVE_LRAND48)
- srand48(time(NULL));
diff --git a/www/harvest/files/patch-ae b/www/harvest/files/patch-ae
deleted file mode 100644
index 7cdc80ec63b3..000000000000
--- a/www/harvest/files/patch-ae
+++ /dev/null
@@ -1,12 +0,0 @@
---- components/broker/standard/WWW/DisplayObject.c.old Tue Oct 29 00:51:14 2002
-+++ components/broker/standard/WWW/DisplayObject.c Tue Oct 29 00:51:30 2002
-@@ -214,8 +214,8 @@
- char *xstrerror(n)
- int n;
- {
-- extern int sys_nerr;
- #if !defined(__FreeBSD__) && !defined(__NetBSD__)
-+ extern int sys_nerr;
- extern char *sys_errlist[];
- #endif
-
diff --git a/www/harvest/files/patch-components::broker::standard::WWW::DisplayObject.c b/www/harvest/files/patch-components::broker::standard::WWW::DisplayObject.c
new file mode 100644
index 000000000000..1622f8058eed
--- /dev/null
+++ b/www/harvest/files/patch-components::broker::standard::WWW::DisplayObject.c
@@ -0,0 +1,12 @@
+--- components/broker/standard/WWW/DisplayObject.c.orig Mon Feb 11 07:57:16 2002
++++ components/broker/standard/WWW/DisplayObject.c Wed Nov 13 09:01:03 2002
+@@ -215,8 +215,8 @@
+ char *xstrerror(n)
+ int n;
+ {
+- extern int sys_nerr;
+ #ifdef NEED_SYS_ERRLIST
++ extern int sys_nerr;
+ extern char *sys_errlist[];
+ #endif
+
diff --git a/www/harvest/files/patch-components::broker::swish::Makefile.in b/www/harvest/files/patch-components::broker::swish::Makefile.in
new file mode 100644
index 000000000000..c63d91aba762
--- /dev/null
+++ b/www/harvest/files/patch-components::broker::swish::Makefile.in
@@ -0,0 +1,11 @@
+--- components/broker/swish/Makefile.in.orig Wed Nov 5 03:14:43 1997
++++ components/broker/swish/Makefile.in Wed Nov 13 10:11:37 2002
+@@ -15,7 +15,7 @@
+ prefix = @prefix@
+ bindir = $(prefix)/lib/broker
+
+-INSTALL_PROG = @INSTALL@
++INSTALL_PROG = @INSTALL_PROGRAM@
+
+ TEMPLATEDIR = ../../../src/common
+ TEMPLATESRC = $(srcdir)/$(TEMPLATEDIR)
diff --git a/www/harvest/files/patch-components::gatherer::catdoc::charsets::Makefile.in b/www/harvest/files/patch-components::gatherer::catdoc::charsets::Makefile.in
new file mode 100644
index 000000000000..c3c855fb0f37
--- /dev/null
+++ b/www/harvest/files/patch-components::gatherer::catdoc::charsets::Makefile.in
@@ -0,0 +1,29 @@
+--- components/gatherer/catdoc/charsets/Makefile.in.orig Sat Jun 8 17:12:36 2002
++++ components/gatherer/catdoc/charsets/Makefile.in Wed Nov 13 10:03:59 2002
+@@ -1,5 +1,7 @@
+ SHELL = /bin/sh
+ INSTALL = @INSTALL@
++INSTALL_BIN = @INSTALL_PROGRAM@
++INSTALL_LIB = @INSTALL_DATA@
+
+ srcdir = @srcdir@
+ top_srcdir = @top_srcdir@
+@@ -29,13 +31,13 @@
+ clean:
+ install: install-dirs install-spc install-charsets
+ install-spc: tex.spc ascii.spc tex.rpl ascii.rpl
+- $(INSTALL) -m 644 $(srcdir)/ascii.spc $(installroot)$(LIB_DIR)/ascii$(SPEC_EXT)
+- $(INSTALL) -m 644 $(srcdir)/tex.spc $(installroot)$(LIB_DIR)/tex$(SPEC_EXT)
+- $(INSTALL) -m 644 $(srcdir)/ascii.rpl $(installroot)$(LIB_DIR)/ascii$(REPL_EXT)
+- $(INSTALL) -m 644 $(srcdir)/tex.rpl $(installroot)$(LIB_DIR)/tex$(REPL_EXT)
++ $(INSTALL_LIB) $(srcdir)/ascii.spc $(installroot)$(LIB_DIR)/ascii$(SPEC_EXT)
++ $(INSTALL_LIB) $(srcdir)/tex.spc $(installroot)$(LIB_DIR)/tex$(SPEC_EXT)
++ $(INSTALL_LIB) $(srcdir)/ascii.rpl $(installroot)$(LIB_DIR)/ascii$(REPL_EXT)
++ $(INSTALL_LIB) $(srcdir)/tex.rpl $(installroot)$(LIB_DIR)/tex$(REPL_EXT)
+ install-charsets:
+ for i in $(srcdir)/*.txt; do\
+- $(INSTALL) -m 0644 $$i $(installroot)$(LIB_DIR);\
++ $(INSTALL_LIB) -m 0644 $$i $(installroot)$(LIB_DIR);\
+ done
+ install-dirs:
+ $(top_srcdir)/mkinstalldirs $(installroot)$(LIB_DIR)
diff --git a/www/harvest/files/patch-components::gatherer::catdoc::doc::Makefile.in b/www/harvest/files/patch-components::gatherer::catdoc::doc::Makefile.in
new file mode 100644
index 000000000000..086e2e9bed99
--- /dev/null
+++ b/www/harvest/files/patch-components::gatherer::catdoc::doc::Makefile.in
@@ -0,0 +1,22 @@
+--- components/gatherer/catdoc/doc/Makefile.in.orig Thu Jan 31 05:00:58 2002
++++ components/gatherer/catdoc/doc/Makefile.in Wed Nov 13 10:00:45 2002
+@@ -5,6 +5,8 @@
+ srcdir = @srcdir@
+ top_srcdir = @top_srcdir@
+ INSTALL = @INSTALL@
++INSTALL_BIN = @INSTALL_PROGRAM@
++INSTALL_LIB = @INSTALL_DATA@
+ VPATH = @srcdir@
+ prefix = @prefix@
+ exec_prefix = @exec_prefix@
+@@ -20,8 +22,8 @@
+ clean:
+ install: catdoc.1 xls2csv.1
+ ../mkinstalldirs $(installroot)$(mandir)
+- $(INSTALL) -m 644 catdoc.1 $(installroot)$(mandir)/catdoc$(manext)
+- $(INSTALL) -m 644 xls2csv.1 $(installroot)$(mandir)/xls2csv$(manext)
++ $(INSTALL_LIB) catdoc.1 $(installroot)$(mandir)/catdoc$(manext)
++ $(INSTALL_LIB) xls2csv.1 $(installroot)$(mandir)/xls2csv$(manext)
+ # Following rules are primarily for developers use. I doubt that you
+ # need to rebuild these versions of documentation
+ distclean: catdoc.1 catdoc.txt catdoc.ps xls2csv.1 xls2csv.txt xls2csv.ps
diff --git a/www/harvest/files/patch-components::gatherer::catdoc::src::Makefile.in b/www/harvest/files/patch-components::gatherer::catdoc::src::Makefile.in
new file mode 100644
index 000000000000..09a7d7e8c3d5
--- /dev/null
+++ b/www/harvest/files/patch-components::gatherer::catdoc::src::Makefile.in
@@ -0,0 +1,36 @@
+--- components/gatherer/catdoc/src/Makefile.in.orig Sat Jun 8 17:13:17 2002
++++ components/gatherer/catdoc/src/Makefile.in Wed Nov 13 10:02:19 2002
+@@ -12,13 +12,15 @@
+ libdir = @prefix@/lib/gatherer/catdoc-lib
+ mandir = @mandir@
+ INSTALL = @INSTALL@
++INSTALL_BIN = @INSTALL_PROGRAM@
++INSTALL_LIB = @INSTALL_DATA@
+ WISH = @WISH@
+ CC = @CC@
+ build_targets = @buildtargets@
+ install_targets = @installtargets@
+ # Flags to pass to your C compilier
+ # remove -O2 on HP/UX 9. It is known to cause problems
+-FLAGS=-Wall -O2 -g
++CFLAGS = @CFLAGS@
+
+ #Compile-time configuration of catdoc itself. Edit according to taste
+
+@@ -77,12 +79,12 @@
+ install: @installtargets@
+ install-catdoc:catdoc xls2csv
+ $(top_srcdir)/mkinstalldirs $(installroot)$(bindir)
+- $(INSTALL) -m 755 catdoc $(installroot)$(bindir)/catdoc
+- $(INSTALL) -m 755 xls2csv $(installroot)$(bindir)/xls2csv
+-# $(INSTALL) -m 755 msxlsview.sh $(installroot)$(bindir)/xlsview
++ $(INSTALL_BIN) catdoc $(installroot)$(bindir)/catdoc
++ $(INSTALL_BIN) xls2csv $(installroot)$(bindir)/xls2csv
++# $(INSTALL_BIN) msxlsview.sh $(installroot)$(bindir)/xlsview
+ install-wordview: wordview
+ $(top_srcdir)/mkinstalldirs $(installroot)$(bindir)
+- $(INSTALL) -m 755 wordview $(installroot)$(bindir)/wordview
++ $(INSTALL_BIN) wordview $(installroot)$(bindir)/wordview
+ wordview: wordview.tcl
+ echo "#! $(WISH)" >wordview
+ echo set charset_lib "\"$(LIB_DIR)\"">>wordview
diff --git a/www/harvest/files/patch-ab b/www/harvest/files/patch-src::common::util::strerror.c
index 1e39ca0f6c6b..947fc4433193 100644
--- a/www/harvest/files/patch-ab
+++ b/www/harvest/files/patch-src::common::util::strerror.c
@@ -1,5 +1,5 @@
---- ./src/common/util/strerror.c.orig Sun Oct 20 17:43:50 2002
-+++ ./src/common/util/strerror.c Sun Oct 20 17:43:59 2002
+--- src/common/util/strerror.c.orig Mon Mar 17 07:16:32 1997
++++ src/common/util/strerror.c Wed Nov 13 08:58:11 2002
@@ -89,8 +89,10 @@
char *strerror(n)
int n;
diff --git a/www/harvest/files/patch-src::gatherer::essence::file::print.c b/www/harvest/files/patch-src::gatherer::essence::file::print.c
new file mode 100644
index 000000000000..bf01e67fa518
--- /dev/null
+++ b/www/harvest/files/patch-src::gatherer::essence::file::print.c
@@ -0,0 +1,12 @@
+--- src/gatherer/essence/file/print.c.orig Sat Dec 13 01:02:15 1997
++++ src/gatherer/essence/file/print.c Wed Nov 13 08:56:34 2002
+@@ -78,8 +78,8 @@
+ warning(f, a)
+ char *f, *a;
+ {
+- extern int errno, sys_nerr;
+ #ifdef NEED_SYS_ERRLIST
++ extern int errno, sys_nerr;
+ extern char *sys_errlist[];
+ #endif
+ int myerrno;
diff --git a/www/harvest/files/patch-src::gatherer::essence::pp_rules.y b/www/harvest/files/patch-src::gatherer::essence::pp_rules.y
new file mode 100644
index 000000000000..9bef0cf1cd4b
--- /dev/null
+++ b/www/harvest/files/patch-src::gatherer::essence::pp_rules.y
@@ -0,0 +1,10 @@
+--- src/gatherer/essence/pp_rules.y.orig Mon Mar 17 07:18:10 1997
++++ src/gatherer/essence/pp_rules.y Wed Nov 13 09:06:33 2002
+@@ -65,6 +65,7 @@
+ ;
+
+ condition : condattr condop condstr { $$ = mk_cond ($1, $2, $3); }
++ ;
+
+ condattr : word { $$ = $1; }
+ ;