aboutsummaryrefslogtreecommitdiff
path: root/www/hastymail/Makefile
diff options
context:
space:
mode:
authorRong-En Fan <rafan@FreeBSD.org>2007-06-11 14:38:55 +0000
committerRong-En Fan <rafan@FreeBSD.org>2007-06-11 14:38:55 +0000
commit1c44bbfa715d12633a8d51716f7f6df0ed8985a8 (patch)
treeefeb82b139e28601035445338e0eef07ca394367 /www/hastymail/Makefile
parent1c23601f1bf5924abbe0bd469064c7fbd0c456b5 (diff)
downloadports-1c44bbfa715d12633a8d51716f7f6df0ed8985a8.tar.gz
ports-1c44bbfa715d12633a8d51716f7f6df0ed8985a8.zip
Notes
Diffstat (limited to 'www/hastymail/Makefile')
-rw-r--r--www/hastymail/Makefile28
1 files changed, 21 insertions, 7 deletions
diff --git a/www/hastymail/Makefile b/www/hastymail/Makefile
index 5577b05d96ad..956d5913c894 100644
--- a/www/hastymail/Makefile
+++ b/www/hastymail/Makefile
@@ -7,7 +7,7 @@
PORTNAME= hastymail
PORTVERSION= 1.5
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= www
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE_EXTENDED}
MASTER_SITE_SUBDIR= hastymail
@@ -27,16 +27,30 @@ USE_PHP= session imap
.include <bsd.port.pre.mk>
+# Don't install automatically CVS directories, patched files and the default config file.
+FIND_SKIP_OPTS= -not -name hastymail.conf-example -not -name '*.orig' \
+ -not -name '*.bak' -not -path '*/CVS/*' -not -name CVS
+
+post-patch:
+ @${REINPLACE_CMD} -e "s,%%PREFIX%%,${PREFIX}," \
+ ${WRKSRC}/lib/constant.php
+
pre-install:
- @${FIND} -s -d ${WRKSRC}/ -type f | ${SED} "s?${WRKSRC}?${INSTALL_DIR}?g" >${PLIST}
- @${FIND} -s -d ${WRKSRC}/ -type d | ${SED} "s?${WRKSRC}?@dirrm ${INSTALL_DIR}?g" >> ${PLIST}
+ @${FIND} -s -d ${WRKSRC}/ -type f ${FIND_SKIP_OPTS} | \
+ ${SED} "s?${WRKSRC}?${INSTALL_DIR}?g" >${PLIST}
+ @${FIND} -s -d ${WRKSRC}/ -type d ${FIND_SKIP_OPTS} | \
+ ${SED} "s?${WRKSRC}?@dirrm ${INSTALL_DIR}?g" >> ${PLIST}
+ @${ECHO_CMD} etc/hastymail.conf.sample >> ${PLIST}
do-install:
- @${MKDIR} ${PREFIX}/${INSTALL_DIR}
- @cd ${WRKSRC} && ${FIND} . | ${PAX} -rw ${PREFIX}/${INSTALL_DIR}
- @${CHOWN} -R ${WWWOWN}:${WWWGRP} ${PREFIX}/${INSTALL_DIR}
+ @${MKDIR} ${PREFIX}/${INSTALL_DIR}
+ @cd ${WRKSRC} && ${FIND} . ${FIND_SKIP_OPTS} | \
+ ${PAX} -rwd ${PREFIX}/${INSTALL_DIR}
+ @${CHOWN} -R ${WWWOWN}:${WWWGRP} ${PREFIX}/${INSTALL_DIR}
+ @${INSTALL_DATA} ${WRKSRC}/hastymail.conf-example \
+ ${PREFIX}/etc/hastymail.conf.sample
post-install:
- @${CAT} ${PKGMESSAGE}
+ @${CAT} ${PKGMESSAGE}
.include <bsd.port.post.mk>