aboutsummaryrefslogtreecommitdiff
path: root/www/hastymail2/Makefile
diff options
context:
space:
mode:
authorMartin Wilke <miwi@FreeBSD.org>2006-11-18 22:55:43 +0000
committerMartin Wilke <miwi@FreeBSD.org>2006-11-18 22:55:43 +0000
commit5b5d978c24a35eee0fda39d399763dae38fff498 (patch)
treedd4f08b322a7187faa81045c7f10ac6b9bca5a4a /www/hastymail2/Makefile
parent793b724c23f41355f770505af4fcb5daa0438c9b (diff)
Hastymail is a streamlined, secure, fast web based IMAP client written
in PHP. Hastymail is designed to have low server requirements and follow internet standards for MIME, IMAP and SMTP communications. Hastymail is also designed to work with all the major and not so major web browsers available. Hastymail does not use frames, javascript, or cookies and all output is 100% W3C compliant 4.01 transitional HTML. WWW: http://hastymail.sourceforge.net/ PR: ports/105646 Submitted by: Bartlomiej Rutkowski <r at robakdesign.com>
Notes
Notes: svn path=/head/; revision=177534
Diffstat (limited to 'www/hastymail2/Makefile')
-rw-r--r--www/hastymail2/Makefile42
1 files changed, 42 insertions, 0 deletions
diff --git a/www/hastymail2/Makefile b/www/hastymail2/Makefile
new file mode 100644
index 000000000000..b4f55b7b9478
--- /dev/null
+++ b/www/hastymail2/Makefile
@@ -0,0 +1,42 @@
+# New ports collection makefile for: hastymail
+# Date created: 2006-11-04
+# Whom: Bartlomiej Rutkowski <r@robakdesign.com>
+#
+# $FreeBSD$
+#
+
+PORTNAME= hastymail
+PORTVERSION= 1.5
+CATEGORIES= www
+MASTER_SITES= ${MASTER_SITE_SOURCEFORGE_EXTENDED}
+MASTER_SITE_SUBDIR= hastymail
+
+MAINTAINER= r@robakdesign.com
+COMMENT= Small, fast and secure yet powerful IMAP webmail
+
+WRKSRC= ${WRKDIR}/${PORTNAME}-${PORTVERSION}
+NO_BUILD= yes
+SUB_FILES= pkg-message
+
+WWWOWN?= www
+WWWGRP?= www
+INSTALL_DIR?= www/data/${PORTNAME}
+
+WANT_PHP_WEB= yes
+USE_PHP= session imap
+
+.include <bsd.port.pre.mk>
+
+pre-install:
+ @${FIND} -s -d ${WRKSRC}/ -type f | ${SED} "s?${WRKSRC}?${INSTALL_DIR}?g" >${PLIST}
+ @${FIND} -s -d ${WRKSRC}/ -type d | ${SED} "s?${WRKSRC}?@dirrm ${INSTALL_DIR}?g" >> ${PLIST}
+
+do-install:
+ @${MKDIR} ${PREFIX}/${INSTALL_DIR}
+ @cd ${WRKSRC} && ${FIND} . | ${PAX} -rw ${PREFIX}/${INSTALL_DIR}
+ @${CHOWN} -R ${WWWOWN}:${WWWGRP} ${PREFIX}/${INSTALL_DIR}
+
+post-install:
+ @${CAT} ${PKGMESSAGE}
+
+.include <bsd.port.post.mk>