aboutsummaryrefslogtreecommitdiff
path: root/www/havp
diff options
context:
space:
mode:
authorRenato Botelho <garga@FreeBSD.org>2007-02-18 18:34:13 +0000
committerRenato Botelho <garga@FreeBSD.org>2007-02-18 18:34:13 +0000
commit56cfde4f5847a7a0c5c355a37e7c4fbcefc3f4d8 (patch)
tree51fde5fc8a9bdf6a282a735d4f9c85a885e36246 /www/havp
parent3904a5b66afd542d22dc7e0adb86ff4e39adfb2e (diff)
downloadports-56cfde4f5847a7a0c5c355a37e7c4fbcefc3f4d8.tar.gz
ports-56cfde4f5847a7a0c5c355a37e7c4fbcefc3f4d8.zip
Notes
Diffstat (limited to 'www/havp')
-rw-r--r--www/havp/Makefile1
-rw-r--r--www/havp/files/patch-havp_scanners_clamlibscanner.cpp20
2 files changed, 21 insertions, 0 deletions
diff --git a/www/havp/Makefile b/www/havp/Makefile
index 98a3bfd686f2..111626f04387 100644
--- a/www/havp/Makefile
+++ b/www/havp/Makefile
@@ -7,6 +7,7 @@
PORTNAME= havp
PORTVERSION= 0.82
+PORTREVISION= 1
CATEGORIES= www
MASTER_SITES= http://www.server-side.de/download/ \
http://bio3k.softboard.ru/uploads/arch/
diff --git a/www/havp/files/patch-havp_scanners_clamlibscanner.cpp b/www/havp/files/patch-havp_scanners_clamlibscanner.cpp
new file mode 100644
index 000000000000..7e49825f8fbd
--- /dev/null
+++ b/www/havp/files/patch-havp_scanners_clamlibscanner.cpp
@@ -0,0 +1,20 @@
+--- havp/scanners/clamlibscanner.cpp.orig Sun Feb 18 15:32:07 2007
++++ havp/scanners/clamlibscanner.cpp Sun Feb 18 15:32:35 2007
+@@ -29,7 +29,7 @@
+
+ LogFile::ErrorMessage("ClamAV: Using database directory: %s\n", dbdir);
+
+- if ( (ret = cl_loaddbdir(dbdir, &root, &no)) != 0 )
++ if ( (ret = cl_load(dbdir, &root, &no, CL_DB_STDOPT)) != 0 )
+ {
+ LogFile::ErrorMessage("ClamAV: Could not load database: %s\n", cl_strerror(ret));
+ return false;
+@@ -65,7 +65,7 @@
+
+ cl_settempdir(Params::GetConfigString("TEMPDIR").c_str(), 0);
+
+- if ( (ret = cl_loaddbdir(dbdir, &root, &no)) != 0 )
++ if ( (ret = cl_load(dbdir, &root, &no, CL_DB_STDOPT)) != 0 )
+ {
+ LogFile::ErrorMessage("ClamAV: Could not reload database: %s\n", cl_strerror(ret));
+ return false;