aboutsummaryrefslogtreecommitdiff
path: root/www/helma
diff options
context:
space:
mode:
authorMartin Wilke <miwi@FreeBSD.org>2008-12-22 21:13:16 +0000
committerMartin Wilke <miwi@FreeBSD.org>2008-12-22 21:13:16 +0000
commitd603258b9d2582954c9ec2e0a619c6076205e0eb (patch)
tree6322395b4f647553403cdc36ad59d05e3202b6d9 /www/helma
parent9625114c0b1d8e90c7d5563a54a079427a709b59 (diff)
downloadports-d603258b9d2582954c9ec2e0a619c6076205e0eb.tar.gz
ports-d603258b9d2582954c9ec2e0a619c6076205e0eb.zip
Notes
Diffstat (limited to 'www/helma')
-rw-r--r--www/helma/Makefile10
-rw-r--r--www/helma/distinfo12
-rw-r--r--www/helma/files/patch-ApplicationManager.java12
-rw-r--r--www/helma/files/patch-Server.java26
-rw-r--r--www/helma/pkg-plist3
5 files changed, 13 insertions, 50 deletions
diff --git a/www/helma/Makefile b/www/helma/Makefile
index 645c783a9c64..67f009468298 100644
--- a/www/helma/Makefile
+++ b/www/helma/Makefile
@@ -1,26 +1,26 @@
# New ports collection makefile for: helma
# Date created: 2008-06-22
-# Whom: Bernhard Fr__hlich <decke@bluelife.at>
+# Whom: Bernhard Froehlich <decke@bluelife.at>
#
# $FreeBSD$
#
PORTNAME= helma
-PORTVERSION= 1.6.2
+PORTVERSION= 1.6.3
CATEGORIES= www java
MASTER_SITES= http://adele.helma.org/download/helma/${PORTVERSION}/
-DISTFILES= helma-1.6.2.tar.gz helma-1.6.2-src.tar.gz
+DISTFILES= helma-${PORTVERSION}.tar.gz helma-${PORTVERSION}-src.tar.gz
MAINTAINER= decke@bluelife.at
COMMENT= A Web application framework for fast and efficient scripting
WRKBASE= ${WRKDIR}/${PORTNAME}-${PORTVERSION}
-WRKSRC= ${WRKBASE}/build
+WRKSRC= ${WRKBASE}
DATADIR= ${JAVASHAREDIR}/${PORTNAME}
USE_RC_SUBR= helma
USE_JAVA= yes
-JAVA_VERSION= 1.5+
+JAVA_VERSION= 1.4+
USE_ANT= yes
ALL_TARGET= clean jar
diff --git a/www/helma/distinfo b/www/helma/distinfo
index 4e0c57ec3eca..73265eefe4e8 100644
--- a/www/helma/distinfo
+++ b/www/helma/distinfo
@@ -1,6 +1,6 @@
-MD5 (helma-1.6.2.tar.gz) = 24d37010aeeb1f4303674ea0dcdecf82
-SHA256 (helma-1.6.2.tar.gz) = 5f0e7a54ae07b14ffa3055d81b63e34fc6bebc15e2f4ebd0a591802ea446dd12
-SIZE (helma-1.6.2.tar.gz) = 6543555
-MD5 (helma-1.6.2-src.tar.gz) = 644781ad8eb914307c82d571c8aa8b8e
-SHA256 (helma-1.6.2-src.tar.gz) = 225d2527b264bb2042ee0e9b912da74178a4a6cd7c41b2707f3195bf7d12004a
-SIZE (helma-1.6.2-src.tar.gz) = 4810577
+MD5 (helma-1.6.3.tar.gz) = 8999bb92c7192e7adaab7596e581c520
+SHA256 (helma-1.6.3.tar.gz) = 01d71d17bbc2c5456af338e4290e820d9bda7bae05e9d4ce48ad22f17061d6f3
+SIZE (helma-1.6.3.tar.gz) = 6553371
+MD5 (helma-1.6.3-src.tar.gz) = ad8dea492dc1147ff17ec07cc74aead5
+SHA256 (helma-1.6.3-src.tar.gz) = 8273b7cbd2186a0dda475b6d0e0dcadfe0124e347a1d7a0062a96b1a82a0f5f7
+SIZE (helma-1.6.3-src.tar.gz) = 4815576
diff --git a/www/helma/files/patch-ApplicationManager.java b/www/helma/files/patch-ApplicationManager.java
deleted file mode 100644
index 9cf258490882..000000000000
--- a/www/helma/files/patch-ApplicationManager.java
+++ /dev/null
@@ -1,12 +0,0 @@
---- ../src/helma/main/ApplicationManager.java.orig 2008-04-07 14:45:30.000000000 +0200
-+++ ../src/helma/main/ApplicationManager.java 2008-07-12 16:16:14.000000000 +0200
-@@ -369,6 +369,9 @@
- repositoryImpl = "helma.framework.repository.FileRepository";
- }
- }
-+
-+ if(!new File(repositoryArgs).isAbsolute())
-+ repositoryArgs = server.getHopHome() + "/" + repositoryArgs;
-
- try {
- Repository newRepository = (Repository) Class.forName(repositoryImpl)
diff --git a/www/helma/files/patch-Server.java b/www/helma/files/patch-Server.java
deleted file mode 100644
index caa3099de1fb..000000000000
--- a/www/helma/files/patch-Server.java
+++ /dev/null
@@ -1,26 +0,0 @@
---- ../src/helma/main/Server.java.orig 2008-04-07 14:45:30.000000000 +0200
-+++ ../src/helma/main/Server.java 2008-07-13 21:36:06.000000000 +0200
-@@ -444,14 +444,21 @@
-
-
- // read db.properties file in helma home directory
-+ String dbPropfile = sysProps.getProperty("dbPropFile");
-+ File file;
-+ if ((dbPropfile != null) && !"".equals(dbPropfile.trim())) {
-+ file = new File(dbPropfile);
-+ } else {
-+ file = new File(hopHome, "db.properties");
-+ }
-+
- dbProps = new ResourceProperties();
- dbProps.setIgnoreCase(false);
-- dbProps.addResource(new FileResource(new File(hopHome, "db.properties")));
-+ dbProps.addResource(new FileResource(file));
- DbSource.setDefaultProps(dbProps);
-
- // read apps.properties file
- String appsPropfile = sysProps.getProperty("appsPropFile");
-- File file;
- if ((appsPropfile != null) && !"".equals(appsPropfile.trim())) {
- file = new File(appsPropfile);
- } else {
diff --git a/www/helma/pkg-plist b/www/helma/pkg-plist
index 076bf20b26b2..09f9148155f9 100644
--- a/www/helma/pkg-plist
+++ b/www/helma/pkg-plist
@@ -345,6 +345,7 @@ bin/helma
%%PORTDOCS%%%%DOCSDIR%%/docs/api/helma/main/HelmaSecurityManager.html
%%PORTDOCS%%%%DOCSDIR%%/docs/api/helma/main/HelmaShutdownHook.html
%%PORTDOCS%%%%DOCSDIR%%/docs/api/helma/main/HelmaSocketFactory.html
+%%PORTDOCS%%%%DOCSDIR%%/docs/api/helma/main/JettyServer.html
%%PORTDOCS%%%%DOCSDIR%%/docs/api/helma/main/Server.html
%%PORTDOCS%%%%DOCSDIR%%/docs/api/helma/main/ServerConfig.html
%%PORTDOCS%%%%DOCSDIR%%/docs/api/helma/main/package-frame.html
@@ -423,7 +424,6 @@ bin/helma
%%PORTDOCS%%%%DOCSDIR%%/docs/api/helma/scripting/rhino/HopObjectCtor.html
%%PORTDOCS%%%%DOCSDIR%%/docs/api/helma/scripting/rhino/JSAdapter.html
%%PORTDOCS%%%%DOCSDIR%%/docs/api/helma/scripting/rhino/JavaObject.html
-%%PORTDOCS%%%%DOCSDIR%%/docs/api/helma/scripting/rhino/ListViewWrapper.html
%%PORTDOCS%%%%DOCSDIR%%/docs/api/helma/scripting/rhino/MapWrapper.html
%%PORTDOCS%%%%DOCSDIR%%/docs/api/helma/scripting/rhino/PathWrapper.html
%%PORTDOCS%%%%DOCSDIR%%/docs/api/helma/scripting/rhino/PropertyRecorder.html
@@ -742,6 +742,7 @@ bin/helma
%%PORTDOCS%%%%DOCSDIR%%/docs/framework/session.html
%%PORTDOCS%%%%DOCSDIR%%/docs/framework/styles.css
%%PORTDOCS%%%%DOCSDIR%%/licenses/apache.txt
+%%PORTDOCS%%%%DOCSDIR%%/licenses/cddl.txt
%%PORTDOCS%%%%DOCSDIR%%/licenses/jetty.html
%%PORTDOCS%%%%DOCSDIR%%/licenses/lgpl.txt
%%PORTDOCS%%%%DOCSDIR%%/licenses/license.txt