aboutsummaryrefslogtreecommitdiff
path: root/www/hiawatha/Makefile
diff options
context:
space:
mode:
authorMarcelo Araujo <araujo@FreeBSD.org>2008-02-17 12:24:03 +0000
committerMarcelo Araujo <araujo@FreeBSD.org>2008-02-17 12:24:03 +0000
commit370c6b56bb363f4fe36dd942372f5a3ce96f0fa8 (patch)
treefb0091967f015a45cba2744c0c1cc428c44ec185 /www/hiawatha/Makefile
parentd68951ddadce043caf2d17e6de759fc98cc0b46c (diff)
Notes
Diffstat (limited to 'www/hiawatha/Makefile')
-rw-r--r--www/hiawatha/Makefile50
1 files changed, 33 insertions, 17 deletions
diff --git a/www/hiawatha/Makefile b/www/hiawatha/Makefile
index 0efdfd204b8e..e90ba6479325 100644
--- a/www/hiawatha/Makefile
+++ b/www/hiawatha/Makefile
@@ -6,48 +6,64 @@
#
PORTNAME= hiawatha
-PORTVERSION= 6.0
+PORTVERSION= 6.3
CATEGORIES= www
MASTER_SITES= http://hiawatha.leisink.org/files/
MAINTAINER= hugo@leisink.net
COMMENT= An advanced and secure webserver for Unix
-MAN1= hiawatha.1 cgi-wrapper.1 php-fcgi.1 wigwam.1 newroot.1
+DOCS= AUTHORS COPYING ChangeLog INSTALL
+EXAMPLES= hiawatha mkcert newroot php-fcgi
+CONFIG_FILES= httpd.conf mimetype.conf cgi-wrapper.conf php-fcgi.conf
+MAN1= cgi-wrapper.1 hiawatha.1 newroot.1 php-fcgi.1 wigwam.1
MANCOMPRESSED= no
USE_RC_SUBR= hiawatha
SUB_FILES= pkg-message
GNU_CONFIGURE= yes
-CONFIGURE_ARGS= --localstatedir=/var webrootdir=${PREFIX}/www/hiawatha
+CONFIGURE_ARGS= --localstatedir=/var webrootdir=${WWWDIR}
CONFIGURE_TARGET=--build=${MACHINE_ARCH}-portbld-freebsd${OSREL}
-OPTIONS= SSL "Support for Secure Sockets Layer (SSL)?" On
-OPTIONS+= CACHE "Internal file caching support?" On
-OPTIONS+= COMMAND "Enable the Hiawatha CommandChannel?" Off
-
-CONFIG_FILES= httpd.conf mimetype.conf cgi-wrapper.conf php-fcgi.conf
+OPTIONS= SSL "Support for Secure Sockets Layer (SSL)" On \
+ CACHE "Internal file caching support" On \
+ REWRITE "Enable URL rewriting" On \
+ COMMAND "Enable the Hiawatha CommandChannel" Off \
+ IPV6 "Enable IPv6 Support" Off
.include <bsd.port.pre.mk>
-.if defined(WITHOUT_SSL)
-CONFIGURE_ARGS+=--disable-ssl
+.if !defined(WITH_SSL)
+CONFIGURE_ARGS+= --disable-ssl
+.endif
+
+.if !defined(WITH_CACHE)
+CONFIGURE_ARGS+= --disable-cache
.endif
-.if defined(WITHOUT_CACHE)
-CONFIGURE_ARGS+=--disable-cache
+.if !defined(WITH_REWRITE)
+CONFIGURE_ARGS+= --disable-rewrite
.endif
.if defined(WITH_COMMAND)
-CONFIGURE_ARGS+=--enable-command
+CONFIGURE_ARGS+= --enable-command
+.endif
+
+.if !defined(WITH_IPV6)
+CONFIGURE_ARGS+= --disable-ipv6
.endif
post-install:
- @for file in ${CONFIG_FILES} ; do \
- ${CP} -f ${WRKSRC}/etc/hiawatha/$${file} ${PREFIX}/etc/hiawatha/$${file}.sample ; \
- done
- ${CP} -f ${WRKSRC}/doc/index.html ${PREFIX}/www/hiawatha/index.html.sample
+.if !defined(NOPORTDOCS)
+ @${MKDIR} ${DOCSDIR} ${EXAMPLESDIR} ${ETCDIR}
+ @${INSTALL_DATA} ${DOCS:S,^,${WRKSRC}/,} ${DOCSDIR}/
+ @${INSTALL_DATA} ${EXAMPLES:S,^,${WRKSRC}/extra/,} ${EXAMPLESDIR}/
+.endif
+ @${INSTALL_MAN} ${MAN1:S,^,${WRKSRC}/doc/,} ${MAN1PREFIX}/man/man1/
+ @${INSTALL_DATA} ${CONFIG_FILES:S,^,${WRKSRC}/etc/${PORTNAME}/,} ${ETCDIR}/
+ @${MKDIR} ${WWWDIR}
+ @${CP} -f ${WRKSRC}/doc/index.html ${WWWDIR}/
@${CAT} ${PKGMESSAGE}
.include <bsd.port.post.mk>