aboutsummaryrefslogtreecommitdiff
path: root/www/hiawatha
diff options
context:
space:
mode:
authorMark Felder <feld@FreeBSD.org>2014-05-21 11:49:17 +0000
committerMark Felder <feld@FreeBSD.org>2014-05-21 11:49:17 +0000
commitd498ef7ceaa3f40864a919e1ab3db26178fadd5f (patch)
tree960eba753e0aa4b90d32ed5a11c55c3a2639ca7d /www/hiawatha
parentf97d195f62a1ed7ce5bbee81bd8e3379c841599e (diff)
downloadports-d498ef7ceaa3f40864a919e1ab3db26178fadd5f.tar.gz
ports-d498ef7ceaa3f40864a919e1ab3db26178fadd5f.zip
Notes
Diffstat (limited to 'www/hiawatha')
-rw-r--r--www/hiawatha/Makefile13
-rw-r--r--www/hiawatha/distinfo4
-rw-r--r--www/hiawatha/files/hiawatha.in11
-rw-r--r--www/hiawatha/files/pkg-message.in7
-rw-r--r--www/hiawatha/pkg-plist40
5 files changed, 32 insertions, 43 deletions
diff --git a/www/hiawatha/Makefile b/www/hiawatha/Makefile
index 3bb191c26488..de7b60dd48e8 100644
--- a/www/hiawatha/Makefile
+++ b/www/hiawatha/Makefile
@@ -2,25 +2,24 @@
# $FreeBSD$
PORTNAME= hiawatha
-PORTVERSION= 9.3.1
+PORTVERSION= 9.5
CATEGORIES= www
MASTER_SITES= http://www.hiawatha-webserver.org/files/ \
- http://www.c-s.li/ports/
+ SF/fbsdports/hiawatha/
-MAINTAINER= c.petrik.sosa@gmail.com
+MAINTAINER= chris@bsdjunk.com
COMMENT= Advanced and secure webserver for Unix
LICENSE= GPLv2
PORTDOCS= ChangeLog README.md
CONFIG_FILES= hiawatha.conf mimetype.conf cgi-wrapper.conf toolkit.conf \
- index.xslt
+ error.xslt index.xslt
SUB_FILES= pkg-message
-USES= cmake
+USES= cmake compiler:c11
USE_LDCONFIG= yes
USE_RC_SUBR= hiawatha
-WANT_GNOME= yes
CMAKE_ARGS+= -DCMAKE_INSTALL_BINDIR=${PREFIX}/bin \
-DCMAKE_INSTALL_SBINDIR=${PREFIX}/sbin \
@@ -87,6 +86,6 @@ post-install:
.endfor
@${MKDIR} ${STAGEDIR}${WWWDIR} ; \
- ${CP} ${WRKSRC}/extra/index.html ${STAGEDIR}${WWWDIR}/index.hiawatha.html
+ ${INSTALL_DATA} ${WRKSRC}/extra/index.html ${STAGEDIR}${WWWDIR}/index.html.sample
.include <bsd.port.mk>
diff --git a/www/hiawatha/distinfo b/www/hiawatha/distinfo
index 3933cf1ad555..877df40b8015 100644
--- a/www/hiawatha/distinfo
+++ b/www/hiawatha/distinfo
@@ -1,2 +1,2 @@
-SHA256 (hiawatha-9.3.1.tar.gz) = 2fb5a7bf2004cb55511c3e165563e6b2119e863ec2cad773cbe79e75e3c0775a
-SIZE (hiawatha-9.3.1.tar.gz) = 793782
+SHA256 (hiawatha-9.5.tar.gz) = c181011db1af187006190fc186689a0707a6f1e7b524c2a4347840e8fdf68b4f
+SIZE (hiawatha-9.5.tar.gz) = 847545
diff --git a/www/hiawatha/files/hiawatha.in b/www/hiawatha/files/hiawatha.in
index c8d5f565f281..ce09739171ca 100644
--- a/www/hiawatha/files/hiawatha.in
+++ b/www/hiawatha/files/hiawatha.in
@@ -13,21 +13,16 @@
. /etc/rc.subr
-name="hiawatha"
+name=hiawatha
rcvar=hiawatha_enable
load_rc_config $name
-: ${hiawatha_enable="NO"}
+: ${hiawatha_enable:=NO}
command="%%PREFIX%%/sbin/${name}"
pidfile=${hiawatha_pidfile:-"/var/run/hiawatha.pid"}
-stop_postcmd="${name}_stop_postcmd"
-
-hiawatha_stop_postcmd()
-{
- rm -f ${pidfile}
-}
+stop_postcmd="rm -f ${pidfile}"
run_rc_command "$1"
diff --git a/www/hiawatha/files/pkg-message.in b/www/hiawatha/files/pkg-message.in
index 8910cecef72b..65812dc6ea00 100644
--- a/www/hiawatha/files/pkg-message.in
+++ b/www/hiawatha/files/pkg-message.in
@@ -2,13 +2,16 @@
The Hiawatha webserver is now installed.
-Edit the configuration files in %%ETCDIR%% to suit your needs.
+Sample configs were copied to .conf. Edit the configuration files in %%ETCDIR%%
+to suit your needs.
Add hiawatha_enable="YES" to rc.conf and start Hiawatha by running:
-%%PREFIX%%/etc/rc.d/hiawatha start
+service hiawatha start
If you configured Hiawatha with Monitor, download and install the respective
files needed to monitor your webserver:
http://www.hiawatha-webserver.org/monitor
+A port to do this for you is in the making...
+
===============================================================================
diff --git a/www/hiawatha/pkg-plist b/www/hiawatha/pkg-plist
index 0706efaa6b98..1fa7321a5bbd 100644
--- a/www/hiawatha/pkg-plist
+++ b/www/hiawatha/pkg-plist
@@ -1,34 +1,26 @@
bin/ssi-cgi
+@sample %%ETCDIR%%/cgi-wrapper.conf.sample
+@sample %%ETCDIR%%/error.xslt.sample
+@sample %%ETCDIR%%/hiawatha.conf.sample
+@sample %%ETCDIR%%/index.xslt.sample
+@sample %%ETCDIR%%/mimetype.conf.sample
+@sample %%ETCDIR%%/toolkit.conf.sample
sbin/cgi-wrapper
sbin/hiawatha
sbin/wigwam
+lib/hiawatha/libpolarssl.so
+lib/hiawatha/libpolarssl.so.1.3.6
+lib/hiawatha/libpolarssl.so.6
man/man1/cgi-wrapper.1.gz
man/man1/hiawatha.1.gz
man/man1/ssi-cgi.1.gz
man/man1/wigwam.1.gz
-@unexec if cmp -s %D/etc/hiawatha/cgi-wrapper.conf.sample %D/etc/hiawatha/cgi-wrapper.conf ; then rm -f %D/etc/hiawatha/cgi-wrapper.conf; fi
-%%ETCDIR%%/cgi-wrapper.conf.sample
-@exec if [ ! -f %D/etc/hiawatha/cgi-wrapper.conf.sample ] ; then cp -p %D/%F %%ETCDIR%%/cgi-wrapper.conf; fi
-@unexec if cmp -s %D/etc/hiawatha/hiawatha.conf.sample %D/etc/hiawatha/hiawatha.conf ; then rm -f %D/etc/hiawatha/hiawatha.conf; fi
-%%ETCDIR%%/hiawatha.conf.sample
-@exec if [ ! -f %D/etc/hiawatha/hiawatha.conf.sample ] ; then cp -p %D/%F %%ETCDIR%%/hiawatha.conf; fi
-@unexec if cmp -s %D/etc/hiawatha/index.xslt.sample %D/etc/hiawatha/index.xslt ; then rm -f %D/etc/hiawatha/index.xslt; fi
-%%ETCDIR%%/index.xslt.sample
-@exec if [ ! -f %D/etc/hiawatha/index.xslt.sample ] ; then cp -p %D/%F %%ETCDIR%%/index.xslt; fi
-@unexec if cmp -s %D/etc/hiawatha/mimetype.conf.sample %D/etc/hiawatha/mimetype.conf ; then rm -f %D/etc/hiawatha/mimetype.conf; fi
-%%ETCDIR%%/mimetype.conf.sample
-@exec if [ ! -f %D/etc/hiawatha/mimetype.conf.sample ] ; then cp -p %D/%F %%ETCDIR%%/mimetype.conf; fi
-@unexec if cmp -s %D/etc/hiawatha/toolkit.conf.sample %D/etc/hiawatha/toolkit.conf ; then rm -f %D/etc/hiawatha/toolkit.conf; fi
-%%ETCDIR%%/toolkit.conf.sample
-@exec if [ ! -f %D/etc/hiawatha/toolkit.conf.sample ] ; then cp -p %D/%F %%ETCDIR%%/toolkit.conf; fi
-@unexec t=`/bin/ls %D/etc/hiawatha`; if [ -z "$t" ]; then %%ECHO_MSG%% "===> Configuration directory is empty, removing it."; rmdir %D/etc/hiawatha; fi;
+@sample %%WWWDIR%%/index.html.sample
+@dirrmtry %%WWWDIR%%
+@dirrmtry var/lib/hiawatha
+@dirrmtry var/lib
+@dirrmtry var
+@dirrmtry lib/hiawatha
+@dirrmtry %%ETCDIR%%
@exec if [ ! -d /var/log/hiawatha ] ; then mkdir /var/log/hiawatha ; fi
@unexec t=`/bin/ls /var/log/hiawatha`; if [ -z "$t" ]; then %%ECHO_MSG%% "===> Log directory is empty, removing it."; rmdir /var/log/hiawatha; fi;
-@unexec if cmp -s %D/www/hiawatha/index.html %D/www/hiawatha/index.hiawatha.html ; then rm -f %D/www/hiawatha/index.html; fi
-%%WWWDIR%%/index.hiawatha.html
-@exec if [ ! -f %D/www/hiawatha/index.html ] ; then cp -p %D/%F %%WWWDIR%%/index.html; fi
-@unexec t=`/bin/ls %D/www/hiawatha`; if [ -z "$t" ]; then %%ECHO_MSG%% "===> WWW directory is empty, removing it."; rmdir %D/www/hiawatha; fi;
-lib/hiawatha/libpolarssl.so
-lib/hiawatha/libpolarssl.so.5
-lib/hiawatha/libpolarssl.so.1.3.2
-@dirrm lib/hiawatha